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Liquent InSight Rendering 4.4
Administration
This documentation is designed for system administrators and describes how to:

• Configure an InSight Rendering repository
• Configure an  InSight Rendering domain
• Submit job tickets
• Administer an domain and the activities performed by a domain

Liquent InSight Rendering 4.4 Administration
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What is Liquent InSight Rendering
Liquent InSight Rendering consists of three parts:

• A library of components known as business services that perform requested tasks
• A performance framework that handles the execution of the business services with failover and load balancing
• A user interface for configuring the framework

The Liquent InSight Rendering Watch Manager enables users to create a wizard-generated set of rendering
options defined in an XML job ticket that can be executed at a specified time or interval. The Watch Manager is
commonly used to setup a re-occurring polling of a document repository. XML job tickets invoke the business
services to render source documents to PDF, based on your license key.

Liquent InSight Rendering Framework
The library of components consists of various business services that can operate independently of one another
within the Liquent InSight Rendering framework. The framework handles the execution of the business services
on one or more servers, also known as repositories. The framework actually is considered the host of the services.
It is a workflow engine that manages the execution of workflow components on one or more repositories.

Highlights of the Liquent InSight Rendering framework include:

• Scalable single-server and multiple-server workflow management
• Ability to perform automatic load balancing
• Event processing and remote notification
• Status and error logging
• Services can be stacked or used interchangeably
• Through TCP/IP, Liquent InSight Rendering can communicate with a Web service or Web site.

The installation of Liquent InSight Rendering on a server is called a repository. There can be only one repository
on one server. The installation of a Liquent InSight Rendering repository includes the complete framework: the
BusinessServiceServer service that launches the Business Service Manager, which manages the activity of the
business services. The figure below illustrates the layout of the framework on a single Liquent InSight Rendering
repository server. An application, such as Liquent InSight Rendering Watch Manager, or Liquent InSight submits
XML job tickets to the Liquent InSight Rendering framework.

Figure 1:

Representation of the Liquent InSight Rendering framework (single server)

Liquent InSight Rendering Framework What is Liquent InSight Rendering
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Workflow Engine
A workflow is the computerized facilitation or automation of the steps in a business process, in whole or part. For
example, an InSight Rendering workflow for the business process of rendering a document may include the
following steps:

• Retrieving a document
• Rendering a document
• Distributing the document back to a Document Management System (DMS)

In the workflow, the business process is represented as XML. This XML representation is called a job ticket. In an
XML job ticket file, the parent node is the workflow and the child nodes are the business service steps of the
workflow. You can customize your own XML job ticket with specific business services.

InSight Rendering Domain
As represented in the figure below, an  InSight Rendering domain can be comprised of either one or more
repository servers that share a central database, login information, and a license key. In a multiple-repository
domain, the repositories communicate with each other to distribute work evenly across the domain and to protect
against the loss of jobs when failures occur. The InSight Rendering domain can be configured to assign specific
business services to a repository, and to notify users by e-mail of the events occurring on the repositories.

License Activated Business Services
While the InSight Rendering installation includes the complete library of business services, the license key that
you purchase from  determines which business services are activated for use. Please note, the InSight Rendering
Watch Manager interface will not restrict you from submitting job tickets that request a business service for
which you are not licensed. However, the submitted job ticket will fail since the unlicensed business service will
not attempt to perform the requested job. 

Workflow Engine What is Liquent InSight Rendering
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Liquent InSight Rendering
Components
The Liquent InSight Rendering environment contains several components, which are available for use based on
your license:

• Business Services are the library of components that represent business functions used by Liquent InSight
Rendering-based applications, that is, applications that submit XML job tickets to the Liquent InSight
Rendering framework. The business services that may be employed is determined by your license key. The
Liquent InSight Rendering business services are primarily designed to perform and manage document
processing.

• Domain Manager is used to configure and administer the Liquent InSight Rendering domain and the
repositories within that domain.

• Watch Manager is used to schedule watches for rendering documents and to write customized Scheduled
Work job tickets.

• Liquent PDF Creator is a printer driver that uses the Windows Print function with the freely provided PDF
Converter technology to produce a print stream to encapsulate page elements in PDF.

• Plug-ins are format translators that let you open source documents in authoring programs and send them to
the PDF printer.

• DMS modules enable you to access document repositories in a document management system (DMS). These
modules handle logging on to a DMS, retrieving and distributing documents and their renditions, and gathering
properties for documents.

License Activated Business Services Liquent InSight Rendering Components
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Notes Regarding Authoring
Applications
Consider the following with regards to InSight Rendering authoring application support:

• If a source document is not compatible with the rendering server authoring tools, change the source document
to make it compatible. You cannot use downgraded versions of the authoring tools on the servers.  

• Before installing Microsoft Office, if you set the Regional Option to non-US/English for your operating system,
bookmark extraction will not work properly when rendering a document. Any non-US/English Regional Option
settings should be made after Microsoft Office has been installed.

• InSight Rendering can render documents for many different authoring programs to PDF, license permitting.
The authoring programs for which you want to render source documents must be installed on each repository
in the  InSight Rendering domain. Using the service account that you set up when you installed InSight
Rendering, install the authoring programs following the installation instructions provided by that vendor.

• InSight Rendering can render documents accurately only if authoring programs run successfully and without
prompts or dialogs, including registration dialogs. After you install InSight Rendering, start each authoring
program to confirm that it runs this way.

License Activated Business Services Notes Regarding Authoring Applications
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Configuring a Liquent InSight
Rendering Domain
These topics describe in detail how to configure a Liquent InSight Rendering domain, to which one or more
Liquent InSight Rendering repositories belong.

Liquent InSight Rendering Domain Manager
The Liquent InSight Rendering Domain Manager is used to configure and administer the Liquent InSight
Rendering domain and the Liquent InSight Rendering repositories within the domain. The graphical user interface
(GUI) has a directory tree view in the left pane with related information displayed in the right pane. You can use
the left pane to manage repository machines, logins, licenses and services.

To access Domain Manager, on the Windows desktop, double-click the Domain Manager icon. This icon is shown
in Icons Used in the Domain Manager.

Icons Used in the Domain Manager
You can use the following icons in the Domain Manager:

Icon Name Description

Domain Manager Starts the Domain Manager.

New Create a new service, input, login, routing, subdomain, content type, or data category.

Delete Delete a service, input, login, routing, subdomain, content type, data category,
repository, job, scheduled job, notification, log message.

Properties Edit the properties of a domain, subdomain, repository, service, input, login, content
type, data category, license, job, scheduled job, or routing.

Suspend Suspend a repository, job, scheduled job, or routing.

Resume Resume a repository,  job, scheduled job, or routing.

Cancel Cancel a job.

Filter Filter details about a notification, job, scheduled job, or log message.

Refresh Update the current page or pane.

Install License Install an license.

In Progress Indicates the In Progress job status.

Completed Indicates the Completed job status.

Liquent InSight Rendering Domain Manager Configuring a Liquent InSight Rendering Domain

Liquent InSight Rendering 4.4 Administration 6



Icon Name Description

Suspended Indicates the Suspended job status.

Failed Indicates the Failed job status.

Cancelled Indicates the Cancelled job status.

Saving and Restoring Domain Settings
Any changes that you make using the Domain Manager do not take effect until you save your changes. Up until
the moment you save your changes, you can revert back to the Domain Manager settings from the last time they
were saved.

1. To save your Domain Manager changes, from the menu bar, choose File > Save.
2. To revert your Domain Manager settings to the last save, from the menu bar, choose File > Reload.

Viewing License Properties
The license file that provides you controls aspects of your InSight Rendering domain and determines which
business services can be used.

To view license properties:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain and then click Licenses.

a) In the right pane, all the business services installed for this repository are listed.
If you are licensed to use a business service, yes appears in the Licensed column.

3. Right-click on Licenses in the left pane and choose Properties.
The License Properties dialog box opens.

License Properties
On the General tab:
Setting Description

Version The Liquent InSight Rendering version number.

Company The name of the company that bought the product.

License Period The length of time when the license is active.

Expires: The date when the license expires.

Max Servers The maximum number of servers on which InSight Rendering can be installed.

Max Services The maximum number of business services that can be configured and licensed on an
InSight Rendering repository server.

Saving and Restoring Domain Settings Configuring a Liquent InSight Rendering Domain

Liquent InSight Rendering 4.4 Administration 7



Setting Description

OEM Indicates whether the license is for an OEM customer that will be redistribute the
license.

Allow Custom Services Indicates whether you can create your own custom business services.

On the Products tab:
Setting Description

RenderPerfect or StatusViewer Indicates whether you have a license for the associated product.

Version The StatusViewer version.

Max Users The maximum number of users who can use StatusViewer.

Configuring URL's for Online Help
When you install InSight Rendering, default URLs for the locations where you can access online help for InSight
Rendering are configured automatically.

After installation, you can change these URLs.

If you want to change the URLs, note the following:

• A user who runs  InSight Rendering needs access rights to the help file location to be able to use the help.
• The help can be in any shared folder in the same InSight Rendering domain.

To change the URLS for InSight Rendering help, do the following:
1. Open the Domain Manager.
2. On the menu bar, click Help.
3. On the Help menu, click Help Configuration....
4. On the Help Configuration window, change the URLs.
5. Click OK.

Changing the Service Account
Prior to installing InSight Rendering, you were instructed to set up a service account for installing all required
applications, and for installing, configuring, and running all InSight Rendering repositories. If necessary, you can
configure InSight Rendering to work with another service account that you have set up.

This procedure requires the InSight Rendering application to be restarted. Confirm that no jobs are in progress
before proceeding. Unless instructed to do so, changing the service account is not recommended.

To change the service account:

Note: Perform this procedure on each repository in a domain.

1. In Domain Manager, choose File > Set User.
The Set User dialog box opens.

2. In the Domain box, enter the name of this repository server.

Configuring URL's for Online Help Configuring a Liquent InSight Rendering Domain
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3. In the User box, enter the user name for the new service account.
4. Enter the password for the new service account in the Password and Confirm Password boxes.

You are prompted that in order for the setting to take effect, the application must be restarted.
5. Click Yes to confirm.

Configuring the Liquent InSight Rendering
Database
The Liquent InSight Rendering domain of repositories is served by a central database in which domain settings
and job tickets are stored. These topics include various procedures for configuring your Liquent InSight Rendering
database.

Establishing an External Database
A multi-repository domain requires a separate server running an Oracle database.

An Oracle database running on a separate server is required for a multiple-repository Liquent InSight Rendering
domain. Use this procedure to set up an external database for your Liquent InSight Rendering domain.

Note: The following procedure should only be performed on the first repository server to be added to the a
multiple-repository Liquent InSight Rendering domain.

To establish an external database for a Liquent InSight Rendering domain:
1. In the left pane of Domain Manager, click the Configuration tab.
2. At the top of the directory tree, right-click Domain and choose Properties.

The Domain Properties dialog opens.
3. Click the Database tab.
4. To use Oracle, it must already be installed on a database server with the Liquent InSight Rendering tables

created, see Oracle requirements.
5. Do the following:

a) For Service, specify the Oracle server database service that you created when you installed the Oracle
Client on the repository server.

b) Enter VISTA1 for the user, and then enter the password defined when the database was established.
c) After confirming the database is installed and started on the database server, and that the database tables

have been created, click Test Database.
d) Click Test Database once the tables have been created. A dialog stating that the Database test was

successful appears.
6. Click OK in the Domain Properties dialog box.
7. When prompted, click Yes to confirm that you want to change to the Oracle database.
8. Select File > Save to save your changes.
9. Restart the Liquent InSight Rendering server.

Configuring the Liquent InSight Rendering Database Configuring a Liquent InSight Rendering Domain
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Moving Repositories to the External Database
Now that you have added a repository server to the domain of an external database, you can move additional
repository servers to that InSight Rendering domain by joining them to the database.

To move a repository to the database for a InSight Rendering domain:
1. Start Domain Manager on the repository server that you want to move.
2. Suspend the repository.

Suspending the repository enables it to finish processing current jobs but prevents it from processing any
others while you are moving it.

3. Do the following:
a) In the left pane, click the Administration tab.
b) Expand Domain.
c) Click the repository that you want to move.
d) After the right pane refreshes to display the business services, right-click the repository and click Suspend.

4. If the repository is the logging server for the domain, configure another repository to be the logging server.
5. Click the Configuration tab in the left pane.
6. Expand Domain > Repositories, and then click the repository you are moving.
7. From the menu bar, choose Edit > Move.

The Move Repository dialog box opens.
8. Since the database was established for the first repository server in the InSight Rendering domain, you can

move the repository by clicking Machine and specifying the Name of the first repository server. This action
joins the repository server on which you are working to the InSight Rendering domain and database. You can
also move the repository by clicking Database and specifying the database as you did in Establishing an external
database.

9. Click OK.
10. Return to the Administration tab in the left pane, right-click on the server you moved and select Resume.
11. Choose File > Save to save your changes.
12. Restart Domain Manager.

Now that this repository server has been moved from the local single-repository InSight Rendering domain to
the multiple-repository InSight Rendering domain, the repository disappears from the Domain Manager
window. To view this repository in the multiple-repository InSight Rendering domain, choose View > Domain
to change the InSight Rendering domain you are viewing in the Domain Manager window.

Repairing a Database Configuration
There are many reasons why your initial configuration settings for your database may no longer apply, such as
your database password has changed, the connection information in your registry is no longer accurate, or the
originally configured database no longer exists.

When the Domain Manager cannot connect to the database using the established configuration settings or
password, the Domain Repair dialog box opens. The Domain Repair dialog box displays your previous settings and
enables you to change, test, and execute new database configuration and password settings.

If an outdated password is the reason for activating the Domain Repair function, refer to the topic Changing the
database password.

Configuring the Liquent InSight Rendering Database Configuring a Liquent InSight Rendering Domain
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Repairing Configuration Settings

When the Domain Manager is unable to connect to the database due to inaccurate registry information or a
change in database, you need to reset your configuration settings. Depending on the condition that activated the
Domain Repair function, you may need to complete some or all of the following steps.

Note: A Domain Manager repair must be performed from each machine in the domain.

To repair your configuration settings for an Oracle server:

1. In the Domain Repair dialog box, select the service.
2. Click Repair.
3. If a license is required, the Install License dialog box opens.
4. Click the browse button and navigate to the location of the license file.
5. Click the license file.
6. Click Open.
7. Click Install License.
8. Confirm that you want to continue with the installation of the license file.
9. When the installation is complete and the date and time have updated in the dialog box, click Close.

Changing the Database Password

When the Domain Manager detects an out-of-date password, the Domain Repair function is activated. The
Domain Repair dialog box opens to the database type in question and requests a new password.

To change the database password:
1. Enter the new password.
2. Click Repair.

Domain Manager connects to the database server automatically, using the new password.

Configuring E-mail
InSight Rendering has the ability to send e-mail notifications regarding the status of jobs and repositories within
the domain. These topics explain how to setup e-mail notifications in Domain Manager.

Defining E-Mail Notifications
Once you establish an SMTP server on each repository in the domain, you can specify the e-mail addresses of the
users to be notified, and the monitored events for which they will receive e-mail notifications.

Note: Perform this domain-level procedure on only one repository in a domain.

To configure e-mail notifications:
1. In Domain Manager, click the Administration tab in the left pane.
2. Click the Notifications tab in the right pane.

Configuring E-mail Configuring a Liquent InSight Rendering Domain
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3. Right-click within the Notifications tab and choose New notification from the shortcut menu.
The New Notification Properties dialog box opens.

4. In the General tab, do the following:
a) In the Recipient box, enter a user's e-mail address.
b) The Requestor box is read-only since you are defining a domain-level notification from Domain Manager.
c) In the Events list box, click each event for which you want e-mail notifications to be sent.
d) Click Select All for e-mail notifications on all monitored events.

Note: E-mail notifications can also be established at the job level so that users receive e-mails regarding the
progress of a specific job, see Submitting Job Requests for more information.

5. Use the Job Filter and Scheduled Job Filter tabs to further narrow the job events for which notifications are
sent, see Filter Criteria.

6. Click OK.
7. Repeat this process for each individual to receive domain-level notifications.

Configuring Content Types for Rendering
The rendering to PDF documents is accomplished using plug-ins. A plug-in is a format translator that can also
contain entity identification rules. Each plug-in must be associated with a content type so that InSight Rendering
can determine which plug-ins to use for processing a source document.

Every source file has a file format descriptor. File format descriptors can be either a file extension or a DMS
attribute assigned to a document. For example, the file type of a Microsoft Word document in a file system is doc,
while it is msw<version> in Documentum. If you are using two or more DMSs, then you must create a content
type for each file format descriptor included in your publications. If a document’s file format descriptor is not
associated with a plug-in, then InSight Rendering cannot render that source document.

Note: Perform this domain-level procedure on only one repository in a domain.

To configure content types:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain and click Content Types.
3. In the right pane, the File Extension column shows the file extensions for which plug-ins have been associated.

To change a content type settings:
a) Right-click the content type and choose Properties.
b) Continue to step 5.

4. To associate a new content type with a plug-in, right-click in the right pane and choose New content type.
The Content Type Properties dialog box opens.

5. In the File Extension box, enter the file extension, without the period, to which the plug-in is to be associated.
You may also associate a plug-in to a Documentum file type.

6. In the Description box, provide a description of the content type.
7. In the Plugin box, select the plug-in to associate with the file extension.
8. Check Create Bookmarks if you want to use the plug-in to generate bookmarks in your rendered output.
9. To customize the rendering or bookmark extraction settings for a content type, click either Rendering Options

or Bookmark Options.
If the content type permits customization, the button will not be greyed-out.

10. Click OK to close the Add Content Type dialog box.
11. Repeat steps 3 through 10 for each content type that you need to configure.

Configuring Content Types for Rendering Configuring a Liquent InSight Rendering Domain
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12. Choose File > Save to save your changes.

Note: On international operating systems, if you configure the bookmark options for the Microsoft Word
content type to use template extraction, and then after rendering a document you attempt to reconfigure the
bookmark options, you may receive an error. If this occurs, delete and then recreate the Microsoft Word
content type to reconfigure it.

Configuring Archive and Purge Intervals
To eliminate the unnecessary accumulation of processed job tickets and temporary files, the Domain Manager
provides a means for archiving job tickets and for purging job tickets and temporary files.

To support the InSight Rendering fault tolerance mechanism, XML job tickets and temporary files used by
business services are stored and retained.

Note: Perform this domain-level procedure on only one repository in a domain.

To specify the job archive and purge intervals:
1. In Domain Manager, select the Configuration tab in the left pane.
2. At the top of the directory tree, right-click Domain and select Properties.

The Domain Properties dialog box opens.
3. In the Domain Properties dialog box, select the General tab.
4. Under Job Archiving, define the following:

a) From the Archive Machine list, specify the repository that handles the tasks of archiving/purging job tickets
from the database.

b) In the Purge Age box, specify the age (in days) at which archived job tickets whose age exceeds the purge
interval are purged.

c) In the Archive Age box, specify the age (in days) at which processed job tickets whose age exceeds the
archive interval are archived. The archive interval must be less than purge interval.

5. Under Temporary files (com platform only), do the following:
a) In the Delete Age box, specify the age (in days) at which saved temporary files whose age exceeds the

delete interval are deleted. On an hourly basis, files are deleted based on each file’s date/time stamp.
b) Clear the Use network shared folders setting to disable network sharing among the local SharedTemp

folders. It is selected by default and is required for InSight.

Note: Clearing the Use network shared folders setting can result in inconsistent versions for output
documents in a multi-server environment.

6. Click OK.
7. To save your change, choose File > Save.

Every midnight the archive server archives processed jobs and purges archived jobs based on the intervals that
you defined.

Setting the Automated Purge of Temporary Files

When a server executes business services, temporary files are created in several places throughout the operating
system by the authoring applications.  These files are not needed after the original document has been processed,
but  there is no way to easily clean up the temporary files.  Leaving these files in place can lead to problems later
as they accumulate.  To that end, there is a new function to automate the deleting of these temporary files.
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InSight Rendering comes with a default set of folders specified.  These folders have been known to be
problematic if too many files accumulate therein.

To access the temporary folders cleanup function:
1. In the Configuration tab of Domain Manager, right-click on Domain.
2. Select Properties, then select the Temp Folders tab.

The default folders can be removed or edited here, and additional folders can be added.

Specifying a Folder to be Cleaned Up

To specify a folder to be cleaned up:
1. Choose the folder, and click Edit.
2. Set the Age.

Files this age or older when the process is run (every hour) will be deleted from each  InSight Rendering server
in the Domain.

3. Set any filter criteria for the file types to be purged.

Configuring Centralized Logging
As rendering and publishing activities take place in an domain, each repository records log messages on the server
hosting the repository. Included with Domain Manager is a user interface that enables you to view and query the
log messages generated on all the repository servers in an InSight Rendering domain.

To use this centralized logging feature, you must configure one of the repository servers in the domain as the log
server. The log server will “collect” the log messages from the repositories in the domain and store them in the
domain database. Once the log messages are stored in the database, the Log Messages tab can be used to view
and query the messages.

Be aware that you can still view the log files individually on each repository server using a text editor such as
Notepad.

Centralized logging is most useful if you are having a problem with . You can configure centralized logging to
provide one view of all log messages in the domain while you are troubleshooting the problem. After you resolve
the problem, disable centralized logging because it increases the size of the database on the domain log server,
reducing the performance of .

To set up a repository server as the domain log server:
1. On the desktop of the repository server that you want to be the log server, right-click My Computer, and on

the menu, click Manage.
2. In the left pane of the Computer Management window, expand Services and Applications, and click Services.
3. In the right pane, right-click BusinessServiceLogServer, and click Properties.
4. On the General tab of the BusinessServiceLogServer Properties dialog box, on the Startup type list, click
Automatic.

5. Under Service status, click Start.
6. Click OK.
7. Close the Computer Management window.
8. In Domain Manager, select the Configuration tab in the left pane.
9. At the top of the directory tree, right-click Domain and choose Properties.

The Domain Properties dialog box appears.
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10. In the Domain Properties dialog box, select the Logging tab.
11. Under Logging Level, select the messages detail level. 

This determines the type of messages that the log server collects and stores in the domain database. Any
logging level increases the size of the domain database, but the Error level has the least negative impact on the
performance of InSight Rendering.

12. Under Log Server, do the following:
a) Specify the Machine that will be the log server for the domain.

It is recommended that you do not change the default Port setting.
b) In the Purge Age box, specify the age (in days) at which archived log messages whose age exceeds the

purge interval are purged.
c) In the Archive Interval box, specify the age (in days) at which log messages whose age exceeds the archive

interval are archived.
The archive interval must be less than purge interval.

d) Click Check Log Server to confirm that the repository server is available.
13. Click OK.
14. Choose File > Save to save your changes.

Note: With centralized logging enabled, you will receive “unable to notify business service” warnings when
jobs are processed for which e-mail notifications are not configured.

Disabling Centralized Logging

To disable centralized logging:
1. On the desktop of the domain log server, right-click My Computer, and on the menu, click Manage.
2. In the left pane of the Computer Management window, expand Services and Applications.
3. Click Services.
4. In the right pane, right-click BusinessServiceLogServer, and on the menu, click Properties.
5. On the General tab of the BusinessServiceLogServer Properties dialog box, on the Startup type list, click

Manual or Disabled.
6. Under Service status, click Stop.
7. Click OK.
8. Close the Computer Management window.
9. In Domain Manager, select the Configuration tab in the left pane.

10. At the top of the directory tree, right-click Domain and choose Properties.
The Domain Properties dialog box opens.

11. In the Domain Properties dialog box, select the Logging tab.
12. Under Log Server, select Machine and use the Delete or Back Space keys to clear the value.
13. Click OK.
14. Choose FileSave to save your changes.

Configuring Content-Based Routing of Jobs
Domain Manager allows you to route job requests to individual repository servers or groups of servers, called
subdomains, within the InSight Rendering domain based on job properties or business services.
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Defining Subdomains
A subdomain is a grouping of repository servers that represents a subset of the servers belonging to an InSight
Rendering domain.

For example, if your InSight Rendering domain consists of servers in the US and UK, you can define a subdomain
including all the US servers and a subdomain including all the UK servers. There is no limit to the number of
servers that you can join to a subdomain, and an individual repository server can belong to more than one
subdomain.

Regarding content-based routing, if you want to route job requests to a group of servers in a subdomain, you
must first define the subdomain before you can define the content-based routing criteria.

If you want to route job requests to a group of servers in a subdomain, based on job properties or business
services, you must first define the subdomain before you can define the content-based routing criteria.

You need to perform this procedure on only one repository in a domain.

To define a subdomain:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain and click Subdomains.

In the right pane, the Name column lists any subdomains that have already been defined.
3. To change a subdomain’s settings:

a) Right-click the subdomain and choose Properties.
b) Continue to step 5.

4. To create a new subdomain, right-click in the right pane and choose New subdomain.
The Subdomain Properties dialog box opens.

5. In the Name box, enter a name for the subdomain.
6. In the Description box, enter a description for the subdomain.
7. In the Repositories list box, check the repository servers that you want to join to this subdomain. You can also

join repositories to existing subdomains using the Repository Properties dialog box; see Repository Properties.
8. Click OK.
9. Repeat steps 3 through 8 for each subdomain that you need to define.

10. Choose File > Save to save your changes.
Once you have established your subdomains, you can use them when defining job routing criteria.

Defining Routing Criteria
Content-based routing enables you to direct job requests to individual repository servers or sub-domains based
on the routing criteria you define. You can define routing criteria by job property or by business service.

Routing by Job Property

You can route job requests based on the following properties that appear in an XML job ticket:

Job property Description

job-name This routes jobs by job name.

priority This routes jobs by the priority (1-10) assigned to a job with the priority attribute.

product This routes jobs based on the product attribute.

submitted-on This routes jobs by the name of the repository server that submitted the job.

submitter This routes jobs based on the submitter attribute.
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Job property Description

tag This routes jobs based on the tag attribute.
Defining Routing by Job Property

Note: Perform this domain-level procedure on only one repository in a domain.

To define routing by job property:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain > Routing and click Routing by job.
3. In the right pane, the Job Property column lists any routing criteria that have already been defined.
4. To change a routing criterion’s settings, right-click the routing criterion and choose Properties.
5. To create a new routing criterion, right-click in the right pane and choose New routing.

The Routing by Job Properties dialog box opens.
6. On the General tab, do the following:

a) In the Property drop-down box, select the job property by which you want to route job requests.
b) In the Condition drop-down box, select the option by which you want to qualify the job property you

selected.
c) In the Value box, enter the value that determines whether a job request meets the routing criterion.

7. On the Routing tab, check the sub-domains and individual repository servers to which job requests meeting
the routing criterion are directed.

8. Click OK.
9. Repeat steps 3 through 8 for each routing criterion that you need to define.

10. Choose File > Save to save your changes.
Routing by Business Service

You can route job requests based on the business service requested in the job request.

Note: Perform this domain-level procedure on only one repository in a domain.

To define routing by business service:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain > Routing and click Routing by service.
3. In the right pane, the Service column lists any routing criteria that have already been defined.
4. To change a routing criterion’s settings, right-click the routing criterion and choose Properties.
5. To create a new routing criterion, right-click in the right pane and choose New routing.

The Routing by Service Properties dialog box opens.
6. On the General tab, do the following:

a) In the Service, Request and Parameter drop-down boxes, select the business service and attributes by
which you want to route job requests.

b) In the Condition drop-down box, select the option by which you want to qualify the business service you
selected.

c) In the Value box, enter the value that determines whether a job request meets the routing criterion.
7. On the Routing tab, check the sub-domains and individual repository servers to which job requests meeting

the routing criterion are directed.
8. Click OK.
9. Repeat steps 3 through 8 for each routing criterion that you need to define.
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10. Choose File > Save to save your changes.

Setting PDF Rendering Options
To set options that determine how PDF documents are rendered, do the following on only one repository in a
domain:
1. In Domain Manager, click the Configuration tab in the left pane.
2. On the Domain tree, click PDF options.
3. For each of the following group of options, click the option group under PDF Options in the Domain tree or

click the tab for the option group, and type or select values for the options:

• Render Method
• General Settings
• Font substitution
• Font embedding

4. Click OK.
5. On the menu bar, click File.
6. On the File menu, click Save.

Render Method Options
In Domain Manager, you can set PDF options for rendered PDF documents. The following PDF options are set on
the Render Method tab.

All the options on this tab apply to the LIQUENT PDF Creator printer.

Option Description

LIQUENT
PDF Creator

Use the LIQUENT PDF Creator to render documents. This is the default.

Predefined The predefined page size of rendered documents.

To render A4-size documents, select Predefined, and then select A4 from the drop-down list.

To render 8.5 x 11 (letter) documents, click Predefined, and then select Letter from the drop-
down list.

If you assign a value to either of the following, that value overrides the value of Predefined Page
Size:

• Disallow A4/Letter paper resizing in the transformation options for the Microsoft Word plug-
in

• Scale content for A4 or 8.5 x 11" paper sizes in Microsoft Word

For more information about options for resizing, see Configuring Microsoft Office for Rendering and
Microsoft Word.

Custom Renders 8.5 x 14 (legal) documents as documents with the page size that you specify.

To define a default paper size for the LIQUENT PDF Creator printer, select Custom, type values
for Width and Height, and select the unit of measure for Units
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General Settings
To configure Domain Manager, you can set PDF options for rendered PDF documents. The following options are
set on the General Settings tab.

Option Description

Version The Acrobat PDF version for rendered output. If you assign a value to either of the
following, that value overrides the Version option:

• The version option in Watch Manager
• The version parameter for the Render business service in a custom-written job ticket

The default option of Version is Acrobat 5 (1.4).

Optimize for fast
web view

Makes PDF files more suitable for viewing on the Web. This option makes the first page of a
PDF document load as fast as possible.

The PDF Document Properties dialog box in Adobe Acrobat indicates whether a PDF
document is optimized for fast Web view. 

Delete blank
bookmarks

When heading level styles are not included in a source document, InSight Rendering includes
blanks in the bookmark tree by default for the missing heading levels. If you select this
option, InSight Rendering removes the blank bookmarks and adjusts the nesting of the
bookmarks. For example, if Heading 1 is missing from the source document, the Heading 2
bookmark is nested in the bookmark tree where Heading 1 would have been.

Bookmark level on
open

The number of bookmark levels in a rendered document when it is opened. This can be All
or a number from 1 to 20.

If the Page Mode option is set to UseNone, a rendered document is opened without
bookmarks and the Bookmark level on open option is not used. If Page Mode is set to
UseBookmarks, a rendered document is opened with the number of bookmark levels that
Bookmark level on open specifies.

Bookmark level on open is a global option for all your PDF renditions. However, it can be
overridden by options made in Watch Manager and by an optional parameter in the Render
business service of a custom-written job ticket.

Show bookmark
panel when no
bookmarks

Shows the Bookmarks panel without bookmarks in a rendered document when the
document does not contain bookmarks and the Page Mode option is set to UseBookmarks.

Open cross-
document links in
same window

Sets whether cross-document links in rendered output are opened in the same window:

• Default: Use the Preferences setting configured in the user's PDF viewer.
• No: Do not open cross-document links in the same window.
• Yes: Open cross-document links in the same window.

Page Layout One of the following page layouts for a rendered document when is is opened:

• Single Page: Displays one page in the document pane at a time.
• OneColumn: Arranges the pages in one continuous column.
• TwoColumnLeft: Arranges the pages in two columns, with all odd-numbered pages in the
left column.

• TwoColumnRight: Arranges the pages in two columns, with all odd-numbered pages in
the right column.

The default page layout is set on a user's Adobe Acrobat Document Properties dialog box.
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Option Description

Page Mode One of the following page modes for a rendered document when it is opened:

• UseNone: Displays the document pane without a navigation pane containing bookmarks
and thumbnails.

• UseBookmarks: Displays the document pane and the navigation pane with the
Bookmarks panel in the following cases. If the PDF document contains bookmarks,
UseBookmarks displays the Bookmarks panel with bookmarks. If the PDF document
does not contain bookmarks and the option Show bookmark panel when no bookmarks
is selected, UseBookmarks displays the Bookmarks panel without bookmarks.

• UseThumbnails: Displays the document pane and the navigation pane with thumbnails
for the pages.

Magnification One of the following kinds of magnification for a rendered document when is is opened:

• Default: The default zoom magnification on the user’s Adobe Acrobat Document
Properties dialog box.

• Fit Width: The width of the page is the width of the window.
• Fit Height: The height of the page is the height of the window.
• Fit Visible: The width of the page content (text and graphics) is the width of the window.

The window does not contain the left and right vertical margins.
• A percentage of the actual page size.

Hide menubar Hides the Acrobat or Acrobat Reader menu bar.

Hide toolbar Hides the Acrobat or Acrobat Reader toolbar.

Hide window
controls

Displays a PDF file without the left pane and status bar.

Fit window Displays the PDF page to fill the screen.

Center window Centers the PDF page on the screen.

Display document
title

Displays the document title on the page.

Font Substitution Options

To configure Domain Manager, you can set PDF options for rendered PDF documents.

When creating published PDF output from InSight, InSight Rendering substitutes Windows fonts for PDF
postscript fonts in the PDF.

Out-of-the-box,  InSight Rendering maps many of the commonly occuring postscript fonts to their Windows font
equivalent for substitution. Using the Font Substitution tab, you can define the mapping for fonts.

You can select the default Window font for all PDF postscript fonts by going to the Default Window font box and
clicking the font.

To override the default Window font for a specific PDF postscript font:
1. On the Font Substitution tab, in the table at the bottom, right-click anywhere.
2. Click New font substitute.
3. On the New Font Substitute Properties page, in the PDF font box, type the PDF font name.
4. In the Windows font box, click the Windows font that you want to substitute for the PDF font.
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Where Office 2013 is installed throughout the InSight Rendering domain, select Arial Unicode MS. This has all
of the characters that will be needed for most languages.

Where there is at least one instance of Office 2016 installed in the InSight Rendering domain, use the
following as a guide (select any font that will work; these are merely suggestions):

• Arial - Latin characters
• Meiryo - Japanese characters
• PMingLiU - Traditional Chinese (Taiwan/HK/Macau) characters
• SimSun - Simplified Chinese (P.R.C. Mainland/Singapore) characters
• Betang - Korean characters

5. Click OK.

Font Substitution: Delete Window Font

To delete the Window font mapped to a specific PDF postscript font:

1. On the Font Substitution tab, right-click a row containing a PDF font and Windows font.
2. Click Delete.
3. Click Yes.

Font Embedding Options
In Domain Manager, you can set font embedding options for rendering PDF documents.

Option Description

Optimized Font
Embedding

Enables the creation of fonts in a uniform fashion for the entire InSight Rendering system. It
utilizes the CompactFont format and Identity-H encoding to embed the fonts while achieving
the most portable and compliant PDF possible.

Standard Font
Embedding

Enables the standard font embedding for the entire InSight Rendering system. 

Embed fonts Enables or disables font embedding for the entire InSight Rendering system. 

Subset If Embed fonts is selected, Subset embeds only the font characters used in the document.

This setting does not apply to fonts for which you define exceptions in the table below this
option. For example, if Subset is selected but for the MSMincho font the Embedding field in
the table is set to None, no characters from the MSMincho font are embedded in the
document.

Full If Embed fonts is selected, Full embeds all characters from the fonts used in the document,
whether or not those characters are used in the document. 

This setting does not apply to fonts for which you define exceptions in the table below this
option. For example, if Full is selected but for the MSMincho font the Embedding field in the
table is set to Subset, only the MSMincho characters that are in the document are embedded in
it.
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Setting Specific Font Embedding Options
You can specify exceptions to the Embed fonts option by specifying whether specific fonts are embedded in PDF
documents.

Note: To make a document comply with FDA regulations, do not specify any exceptions to full embedding.

To set a specific font embedding option:
1. On the Font Embedding tab, in the table at the bottom, right-click anywhere.
2. To define an exception for a specific font, click New font embedding.
3. On the New font Embedding Properties dialog box, in the Windows Font box, click the font name.
4. In the Embedding box, click one of the following embed rules for the font that you selected:

• None. This does not embed the font for any characters.
• Full. This embeds the font for all characters, whether or not they are used in the document.
• Subset. This embeds the font only for the characters used in the document.

5. Click OK.

Deleting a Specific Font Embedding Option

To delete a specific font embedding option:
1. On the Font Embedding tab, right-click the row containing the font for which you no longer want a specific

embedding option defined. 
2. Click Delete.
3. Click Yes. 

The font you deleted will now adhere to the overall system setting defined at the top of the Font Embedding
tab.

Configuring a Repository
Within the InSight Rendering domain, there are settings for each repository that determine how a repository
functions and interacts in the domain. These settings affect business services, communications, and database
connections.

Repository Properties

To view or modify repository properties:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain > Repositories and click a repository in the directory tree.
3. Choose Edit > Properties. The Repository Properties dialog box opens.

• The General tab consists of TCP/IP ports on which the repositories in an  InSight Rendering domain
communicate. It is recommended that you do not change the default port settings, however you can
change the port settings in the event of a conflict with another application.

• The Database tab enables you to specify connection pooling settings. By checking Connection Pooling, you
can specify the Max Connections that are held open and available at all times, and the Connection Timeout
value that specifies in minutes how long before a connection is dropped between calls to the database.

• The Sub-domains tab enables you to join a repository to a subdomain.
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4. To close the Repository Properties dialog box, click OK.
5. To save your changes, choose File > Save.
6. Restart the InSight Rendering server.

Business Services
When InSight Rendering is installed, all the  Parexel business services available in are included with the
installation. The license that you purchase from  Parexel determines whether a business service is available for
use. Using Domain Manager, you can:

• Determine if you are licensed for a service
• Add or delete a business service from a repository
• View and modify the default configuration of a business service for a repository
• Specify which business services a repository performs.

Licensed Business Services

To view your licensed business services:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain and click License in the directory tree.
3. In the right pane, all the business services installed for this repository are listed.

If you are licensed to use a business service, yes appears in the Licensed column.

Add or Delete a Business Service
Depending on your license, you can create custom business services that the Business Service Server can invoke
when the service is called in an XML job ticket.

To add a business service to a repository:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain > Repositories > <repository name>, right-click Services, and choose New service.
3. Complete the Add New Service Properties dialog box while referencing the field descriptions in Business

Service configuration.
4. Click OK.

Include the new business process in the list of business services processed by this repository.
5. To save your change, choose File > Save.
Deleting a Business Service

To delete a business service from a repository:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain > Repositories > <repository name>, and then click Services.
3. In the right pane, highlight the service(s) that you wish to delete, right-click on a highlighted service, and then

choose Delete.
4. After confirming the deletion, the business service(s) no longer appears in the list of services.
5. To save your change, choose File > Save.
6. Restart the InSight Rendering server.
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Business Service Configuration

The  Parexel business services properties are initially installed with default settings, some of which may be
modified to suit your needs.

To view and modify the configuration of a business service for a repository:

1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain > Repositories > <repository name> and click Services to view the list of services installed on

this repository in the right pane.
Included in the right pane are several columns representing the settings for a business service.

3. Right-click the business service you wish to modify and choose Properties.
Service Properties

4. The business service settings are as follows:

Business Service
Setting

Description

Alias* The name of the business service as it appears in an XML job ticket.

Concurrent The number of simultaneous instances of this business service that may run on the
repository.

Concurrent must be set to 1 for the following business services: Backbone-generator,
IpFusion, IpLinkSetter, MSWord, and Render.

Platform † Indicated whether the service is COM (Windows)-based or JAVA-based.

Prog ID* † The ID that is referenced to instantiate the business service executable.

Queue Type This defines the priority order for the execution of business service requests from job
tickets. A business service can process job ticket requests as first-in, first-out (fifo), or in
a priority order of 1-10 as defined in a job ticket.

Retry Count † How many times the business service should attempt to reprocess an unsuccessful job.

Retry Interval † How many seconds the business service should wait before attempting to reprocess an
unsuccessful job. This value must be set to 1 or greater if the Retry Count is set to 1 or
greater.

Timeout † This specifies the maximum amount of time that you expect a business service to need
to process a job. If a job runs longer than this timeout period, the job is cancelled. For
BusinessServiceRender, you might need to increase this value to process the content of
the documents that you usually render.

Persist Jobs* Whether to save the job ticket for the business service in the InSight Rendering
domain’s database. It is highly recommended that you select this option.

* denotes a default setting that should not be changed for the  Parexel business services installed with .
† denotes fields that are disabled for the Workflow business service since they are not relevant to that service.

5. Click OK.
6. To save your change, choose File > Save.
7. Restart the InSight Rendering server.
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Default InSight Rendering Service Settings
The following are the recommended default settings for the services displayed in the InSight Rendering Domain
Manager.

Alias Concurrent Timeout Retry Count Retry Interval

backbone-generator 1 60 0 0

distribute 5 30 2 4

file 5 5 0 0

ftp 5 5 0 0

IpFusion 1 5 1 3

IpLinkSetter 1 30 1 3

MsWord 1 30 2 2

notify 5 5 0 0

PDFFile 5 5 1 3

printer 1 30 1 2

queue 5 5 2 3

render 1 30 2 2

retrieve 5 5 2 3

watermark 5 5 1 2

workflow 5 0 0 0

zip 5 5 0 0

Business Services Performed by a Repository

You can restrict which licensed business services are performed by a repository. The ability to limit the business
services performed provides a means for load balancing the work processed in an InSight Rendering domain.

To specify the business services performed by a repository:
1. In Domain Manager, click the Configuration tab in the left pane.
2. Expand Domain > Repositories > <repository name>, and then click Inputs.

The right pane displays the TCP/IP socket port through which jobs are submitted to the repository for
processing.

3. Right-click the TCP/IP port and choose Properties.

Channel specifies the TCP/IP port number used for internal communications among the repositories in the
domain. The default input channel for the repositories in an InSight Rendering domain is 2867. It is highly
recommended that you do not change the default port setting. Under Specify which services use this input are
all the business services installed on the repository. A check next to a business service means that jobs for that
service can be sent to this repository for processing.

The Input Properties dialog box opens.
4. Check all the licensed business services that you want this repository to process.

By unchecking a service, jobs for that service will not be submitted to this repository.
5. Click OK.
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6. To save your change, choose File > Save.
7. Restart the InSight Rendering server.

Deleting a Repository

A repository server can be removed from an InSight Rendering domain by deleting it from the Domain Manager
window.

To delete a repository from an InSight Rendering domain:
1. Suspend the repository.

Suspending the repository enables it to finish processing current jobs but prevents it from processing any
others while you are deleting it.

2. Do the following:
a) In the left pane, click the Administration tab.
b) Expand Domain.
c) Click the repository that you want to delete.
d) After the right pane refreshes to display the business services, right-click the repository and click Suspend.

3. If the repository is the logging server for the domain, configure another repository to be the logging server.
4. Click the Configuration tab in the left pane.
5. Expand Domain > Repositories, and then click the repository you are deleting.
6. From the menu bar, choose Edit > Delete.
After confirming the deletion, the repository no longer appears in the left pane.

7. To save your change, choose File > Save.
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Improving Repository Server
Performance
There are settings that can be defined to improve the publishing and rendering performance of the InSight
Rendering repository servers in an domain.

Improving Performance on a VmWare Host
If an InSight Rendering server runs on a VMWare host, configure the following VMWare reservations for InSight
Rendering to improve performance:

• 50% CPU reservation 
• 100% RAM reservation 

For information on how to configure VMWare reservations and tune for VMWare, refer to the Enterprise Java
Applications on VMware Best Practices Guide - http://www.vmware.com/files/pdf/techpaper/Enterprise-Java-
Applications-on-VMware-Best-Practices-Guide.pdf.

Collected links
http://www.vmware.com/files/pdf/techpaper/Enterprise-Java-Applications-on-VMware-Best-Practices-
Guide.pdf

Memory Allocated to Java-Based Business
Services
InSight uses the Java-based eCTD backbone business service to create the XML files and checksum files required
for a compliant eCTD submission. The eCTD backbone business service, as well as any other Java-based business
service, is allocated a maximum of 512 MB of memory by default on an repository server, which is usually
sufficient for most publishing jobs. However, if the memory allocation is not enough, the eCTD backbone job will
fail. To avoid this error, Domain Manager enables you to increase the maximum amount of memory on the servers
in the InSight Rendering domain that can be allocated to a Java-based business service.

Perform this domain-level procedure on only one repository server in a domain.

To increase the memory allocation:
1. In Domain Manager, click the Configuration tab in the left pane.
2. At the top of the directory tree, right-click Domain and choose Properties.

The Domain Properties dialog box opens.
3. In the Domain Properties dialog box, select the General tab.
4. Under JVM Option (Java business services), in the Memory Size box, enter a value between 512 and 1024

MB.
5. Click OK.
6. Choose File > Save to save your changes.

Improving Performance on a VmWare Host Improving Repository Server Performance
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Server Performance Options
In order for an  InSight Rendering repository server to process rendering jobs in a proficient manner, certain
performance options must be set on the server. The following procedures explains how to set these performance
options.

Note: This procedure must be performed on each repository server in a domain.

To set the system performance settings:
1. On the Windows desktop, right-click on Computer and choose Properties.
2. In the Control Panel\System window, click Advanced system settings.
3. In the System Properties dialog box, click the Advanced tab.
4. Under Performance, click Settings.
5. Performance Options dialog box, click the Advanced tab.
6. Under Processor scheduling, click Programs.
7. Click OK to save the setting and close the Performance Options dialog box.
8. Click OK to close the System Properties dialog box.
9. Close the Control Panel\System window.

Restricting Virus Scans on InSight Rendering
Do not run a virus scan on the following:

• InSight Rendering install folder
• VistaTempDir folder
• Target file for the Liquent PS Printer

Running a virus scan on an  InSight Rendering folder can do the following:

• Make Java fail
• Corrupt documents
• Reduce performance

Do not run a virus scan on any InSight Rendering folder continuously. Continuous virus scans reduce InSight
Rendering performance.

Server Performance Options Improving Repository Server Performance
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Liquent InSight Rendering Repository
In the realm of a Liquent InSight Rendering domain, the servers that belong to the domain are called repositories.
Except where explicitly stated otherwise, the term "repository" is a reference to a Liquent InSight Rendering
server.

Restricting Virus Scans on InSight Rendering Liquent InSight Rendering Repository
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Fault Tolerance and Load Balancing
InSight Rendering always provides:

• Fault tolerance that minimizes the loss of jobs when repositories fail.
• Load balancing that ensures that over time work is evenly distributed across the repositories, and at any given
time, work is sent to the least busy repository.

Optionally, you can also configure fault tolerance and load balancing for Service (IRS). See Fault Tolerance and Load
Balancing for Liquent InSight Rendering Service (IRS).

Fault Tolerance for Repositories
InSight Rendering makes a reasonable attempt to protect against the loss of jobs when repository failures occur.
All jobs are initially 'owned' by the repository to which the job was submitted. The owning repository is
responsible for ensuring that the job gets done. However, if a repository goes down (for example, a machine
failure or program crash), the fault tolerance mechanism is initiated. How fault tolerance is provided depends on:

• Whether the domain has one or more repositories
• Whether a repository shutdown is abnormal (failure) or normal (all jobs are suspended and the

BusinessServiceServer service is stopped)
• The state that the job is in (in-progress or queued)

If a domain has more than one repository, then each repository acts as a backup repository for the others. A
backup repository is responsible for taking ownership of another repository's queued and in-progress jobs if that
repository goes down.

If termination of a repository is normal (that is, user requested), in-progress jobs will be cancelled (the Jobs tab will
show them as "cancelled"). If desired, the Jobs tab can be used to resubmit these jobs. If a backup repository is
available, the backup will take ownership of queued jobs (that is, jobs not yet started) and resume them. If no
backup is available, then queued jobs are resumed when the terminated repository is restarted.

If termination is abnormal (that is, due to failure) then the backup (if any) will take ownership of queued and in-
progress jobs and resume them. If no backup, then these jobs will be resumed when the repository is restarted.

In a multiple-repository domain, repositories may send jobs to other repositories to be executed. Each repository
monitors other repositories in the domain and is aware of which repositories are down. This prevents jobs from
being sent to repositories that are not available. In addition, if a job is sent to another repository and that
repository subsequently goes down then the sending repository will detect this condition and retry execution of
the job.

Not mentioned above are scheduled jobs and event notifications. Like regular jobs, these are owned by the
machines on which they were originally requested. If a repository goes down, then the backup repository (if any)
will take ownership and be responsible for performing the work until the original repository is restarted.
Ownership is then transferred back to the original repository and the work continues there. If no backup is
available (single-repository domain), then the work will continue when the single-repository is restarted.

Managing Large Tickets
To support the fault tolerance mechanism and control the size of an domain's database, job tickets 128,000
characters for an Oracle database are stored on the submitting repository server's local drive while the file names
of the job tickets are still stored in the domain's database.
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Job ticket files are also stored on up to two additional repository servers in a multiple-repository domain. The
repositories designated by the domain to backup the job ticket files are identified by a Y in the Database Backup
column on the Repositories tab.

When a job ticket is purged from the InSight Rendering domain's database the job ticket file is deleted from the
local drives of the submitting and backup repository servers.

Hardware Exceptions
The following hardware exceptions might be relevant to InSight Rendering on your system.

Virtual Memory and Rendering Graphics-Laden Documents

For the vast majority of rendering jobs, the amount of physical memory and virtual memory available on a server
for rendering documents is more than adequate. However, when rendering documents that contain a large
amount of graphics, it is possible to receive warnings from the server that you are running low on virtual memory.
If virtual memory errors persist, increase the virtual memory to eliminate these errors.

Load Balancing for Repositories
Load balancing for repositories is used to ensure that:

• Work is evenly distributed across the repositories.
• At any given time, work will be sent to the least busy repository.

For business services other than the Render business service, this is accomplished by each repository periodically
publishing its current work load to the other repositories. When a repository has the option to send a job to more
than one repository, it uses this information to choose the best repository.

For the Render business service, due to potentially long running rendering jobs, an “on demand” queuing
approach is used. A rendering job is held by the server on which the job request was submitted while the server
notifies the other servers in the domain that a job is available. The idle server that first responds to the
notification is given the job. In other words, only a server that is ready to do the work is given the work. This “on
demand” queuing approach for rendering avoids having jobs queued up behind a long running job while idle
servers are available.

Fault Tolerance and Load Balancing for Liquent
InSight Rendering Service (IRS)
Liquent InSight Rendering releases before 4.1 included the VistaJ component, installed on the Insight application
server. This server used VistaJ services to communicate with  Liquent InSight Rendering.

Liquent InSight Rendering releases starting with 4.1 include the Service (IRS) Web service, installed on one or
more servers, instead of VistaJ. The InSight application server now uses IRS services to communicate with 
Liquent InSight Rendering.

Eliminating the Single Point of Failure
You configure InSight Publisher to have the URL for an IRS that handles all job requests to Liquent InSight
Rendering. However, if this IRS fails, InSight Publisher cannot communicate with Liquent InSight Rendering.

Hardware Exceptions Fault Tolerance and Load Balancing
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To eliminate this single point of failure, you can use several industry-standard, third-party, load-balancing and fail-
over solutions. All the solutions require IRS to be installed on more than one InSight Rendering server. You can
contract the Parexel Client Enablement team to configure these solutions.

If you do not use a software or hardware load balancer, you can create a DNS alias for the InSight Rendering
server.

If you do not implement a fail-over solution and the IRS fails, you must configure the InSight application to have a
new URL. Then you must restart the  InSight Rendering server. 

Configuring Web Farms
Microsoft provides fault-tolerant or load-balancing software solutions for use with Microsoft Internet Information
Server (IIS) and the InSight Publisher application server. A Web farm enables InSight Publisher to point to the URL
of a server that distributes job requests to all active IRS servers in the Web farm. If one IRS servers fails, the Web
farm continues to send requests to other active IRS servers.

To create a Web farm on a Windows server, an IT administrator installs IIS with Application Request Routing
(ARR) and URL Rewrite Module. For more information, see the Microsoft tutorials at http://www.iis.net/learn/
web-hosting/scenario-build-a-web-farm-with-iis-servers.  

Collected links
>http://www.iis.net/learn/web-hosting/scenario-build-a-web-farm-with-iis-servers

Managing Memory Usage by the LIQUENT
InSight Rendering Service (IRS)
The web.config file installed with the InSight Rendering Service (IRS) controls how the Microsoft Internet
Information Server (IIS) interacts with IRS and how the IRS operates.

Generally, you do not need to change the properties in this file. However, you can, for example, if you encounter
out of memory errors when is processing large tickets. To use less memory, change the following threshold
properties in the appSetting section of the file:

• DecompresAsFileThresholdKB. The IRS decompresses any compressed job ticket smaller than this in memory.
The IRS decompresses larger tickets by using a temporary file.

• SubmitJobAsFileThresholdKB. The IRS passes any job ticket larger than this to a business service manager as a
filename and a file, rather than keeping the ticket only in memory.

To use less IRS memory, decrease the value of either property, but note that using less memory degrades IRS
performance.

Note: The web.config file also contains properties for ticket dump variables used for debugging. Do not change
these properties unless Technical Support asks you to.

Managing Memory Usage by the LIQUENT InSight Rendering
Service (IRS)
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Administer a Liquent InSight
Rendering Domain
These topics discuss the tools provided with Liquent InSight Rendering for monitoring and administering Liquent
InSight Rendering domain and the repositories within the domain.

Liquent InSight Rendering Domain
Administration
In the left pane of the Domain Manager window is the Administration tab, which consists of several tools for
monitoring and administering a Liquent InSight Rendering domain and the repositories in that domain.

When you click on Domain at the top of the directory tree in the left pane, five tabs appear in the right pane for
managing your Liquent InSight Rendering domain.

Repositories Tab
The Repositories tab shows the availability of each repository in the InSight Rendering domain. By right-clicking
on a repository in the right pane, you can:

• Suspend – This prevents a repository from processing jobs.
• Resume – This resumes a suspended repository.
• Refresh – This updates the information displayed in the right pane.

Note: If you suspend a repository that is the logging server for the domain, configure another repository to be the
logging server.

Services Tab
The Services tab lists all the InSight Rendering business services and shows the number of jobs in each of the
various processing stages.

Jobs Tab
The Jobs tab is used to monitor the jobs in an domain that are in process or have been processed. Information
about the jobs are presented in three panes: the Parent Job Status pane, the Child Job Status pane and the Job
Details pane. The jobs that appear in these panes are the result of job tickets submitted to an InSight Rendering
repository, see Submitting job requests.

Job Options
You can select one or more jobs in the Parent Job Status pane and then right-click to open a shortcut menu
containing several job options. The Domain Manager window has icons that correspond to some of these menu
options. The following table describes these menu options and icons:
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Option Icon Description

Archive jobs No icon Archive the ticket information for the selected jobs. This information is archived from
the domain database.

Cancel jobs Cancel the selected jobs.

Delete jobs Remove from the  domain database all ticket information for the selected jobs. The
information is not archived.

Resume jobs Resume any suspended jobs that you selected. If you suspend a job and it does not
resume after you choose the Resume jobs option, choose the Re-submit jobs option to
reprocess the job.

Suspend jobs Immediately suspend processing the selected jobs.

Re-submit jobs No icon Reprocess the selected jobs. Use this to re-submit a failed job. If you suspend a job and
it does not resume after you choose the Resume jobs option, choose the Re-submit
jobs option to reprocess the job.

Submit new job No icon Create and submit a job ticket.

Cancel all jobs No icon Cancel all jobs listed in the Parent Job Status pane.

Resume all jobs No icon Resume all jobs listed in the Parent Job Status pane.

Suspend all jobs No icon Immediately suspend processing all jobs listed in the Parent Job Status pane.

Filter jobs Filter the job status details. See Defining Filter Criteria.

Refresh jobs Return to the beginning of the job list and update the displayed information and color-
coded status icons for the jobs on the list.

Save request as No icon Save the XML job ticket that appears on the Original Request tab of the Job Details
pane as a .xml file. This option is available only when just one job is selected.

Save results as No icon Save the XML job ticket that appears in the Current Results tab of the Job Details pane
as a .xml file. This option is available only when just one job is selected.

Parent Job Status Pane

Jobs are submitted to the InSight Rendering repositories as job tickets in XML format. Use the Parent Job Status
pane to monitor the progress of the jobs being processed in InSight Rendering domain. Each of the following
color-coded icons quickly communicates the status of a job.

Icon Name Description

In Progress Indicates the In Progress job status.

Completed Indicates the Completed job status.

Suspended Indicates the Suspended job status.

Failed Indicates the Failed job status.

Cancelled Indicates the Cancelled job status.

The jobs displayed in this pane can become numerous and are shown in increments of 100. To continue through
the list of jobs, click Next Set. To return to the beginning of the job list and to update the progress of the jobs
displayed and the color-coded status icons, click the Refresh icon. This icon is shown in Icons Used in the Domain
Manager.
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Child Job Status Pane
The XML job tickets that are submitted to the InSight Rendering repositories consist of “sub-jobs” representing
the business service steps of the workflow. The Child Job Status pane “breaks down” the job you have highlighted
in the Parent Job Status pane into its sub-jobs.

Each time you click on a parent job in the Parent Job Status pane, the Child Job Status pane refreshes, which may
effect system performance. You can avoid automatic refreshing by clearing the Auto-display sub-jobs option. You
can then click Display to control when you want to view the sub-jobs for a parent job.

The sub-jobs displayed in this pane can become numerous and are shown in increments of 100. To continue
through the list of sub-jobs, click Next Set. To return to the beginning of the list and update the sub-job displayed,
click the Refresh icon. This is icon is shown in Icons Used in the Domain Manager.

You can highlight one or more sub-jobs in the Child Job Status pane and then right-click to open a shortcut menu
of sub-job options. The Domain Manager window has icons that correspond to these Sub-job Edit menu options.
The following table describes these menu options and icons:

Sub-Job Options
Option Icon Description

Filter sub-jobs Filter the sub-job status details.

Refresh sub-jobs Return to the beginning of the sub-job list and update the information and color-coded
status icons for the displayed sub-jobs.

Job Details Pane
The Job Details pane shows you advanced job ticket information for the parent job or child job that you have
highlighted in either the Parent Job Status pane or Child Job Status pane. The tabbed sections in the Job Details
pane show XML ticket information, current results, and brief descriptions of executed processes:

• Status Detail – This tab gives a general breakdown of the job ticket
• Original Request – This is the original XML job ticket request
• Current Results – This tab shows the XML-encoded results of a processed job ticket
• Status Description - This tab displays any messages generated by the repository regarding the current status.

If the job failed, this description should contain an appropriate error message.

InSight Rendering Job Fails at InSight Job Requests

If a job request (such as publish, prepare to publish, or volumization by size) takes longer than 12 hours, please
contact your account executive or Technical Support. The Enterprise Connector web service timeout is set to 12
hours (43200 seconds) in the web.config file. If necessary, your system administrator can modify the
web.config file in the Enterprise Connector folder to increase the default timeout.

Scheduled Jobs Tab
The Scheduled Jobs tab is used to manage the XML job tickets with which a specified time or recurring interval is
associated, that is, the job tickets to be executed at a defined schedule. The individual recurring jobs performed
by the business services as requested by a scheduled job ticket appear in the panes of Jobs tab.

Scheduled Job Options

You can select one or more scheduled jobs and then right-click to open a shortcut menu of  scheduled job
options. The Domain Manager window has icons that correspond to most of these menu options. The following
table describes these menu options and icons:
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New scheduled job No icon Create and submit a scheduled job ticket.

Delete scheduled jobs Remove from the InSight Rendering domain database the ticket information for
the selected scheduled jobs. The information is not archived.

Suspend scheduled jobs Immediately suspend processing the selected scheduled jobs.

Resume scheduled jobs Resume the suspended scheduled jobs that you selected.

Filter scheduled jobs Filter details about the selected scheduled jobs.

Refresh scheduled jobs Return to the beginning of the scheduled jobs list and update the displayed
information and color-coded status icons for the scheduled jobs on the list.

Properties Edit a scheduled job ticket. This option is available only when just one
scheduled job is selected.

Notifications Tab
The Notifications tab allows you to manage the jobs, recipients and events for which e-mail notifications are sent.

From the Notifications tab you can create domain-level event notifications and modify job-level event
notifications.

Notification Options

You can select one or more e-mail notifications and then right-click to open a shortcut menu of notification
options. The Domain Manager window has icons that correspond to most of these menu options. The following
table describes these menu options and icons:

Option Icon Description

New No icon Create a domain-level e-mail notification for a user.

Delete Removes the selected notifications.

Filter Filter details about the selected notifications.

Refresh Return to the beginning of the notifications list and update the displayed
notifications information.

Properties Edit a notification. This option is available only when just one notification is selected. For a
job-level notification, you can edit only the events for which the notification is sent.

Log Messages Tab
The Log Messages tab enables you to view and query the log messages stored in the InSight Rendering domain’s
database by the log server. However, before you can use the Log Messages tab, your domain must be set up for
centralized logging.

The log messages displayed can become numerous and are shown in increments of 100. To continue through the
list of messages, click Next Set. To return to the beginning of the list, and to update the display with the most
recently generated log messages, click the Refresh button..

Log Message Options

You can highlight one or more scheduled jobs and then right-click to open a shortcut menu of sub-job options:
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• Archive log messages – This allows you to archive the selected messages.
• Delete log messages – This allows you to delete the selected messages.
• Save log messages as – This allows you to export the selected messages by saving them to a specified file

name and location.

You can also export log messages by choosing File > Export Log Messages and then completing the filter criteria
in the Export Log Messages dialog box. See Filter criteria for an explanation of the fields in the Export Log
Messages dialog box.

To filter log messages, click the Filter icon. This icon is shown in Icons Used in the Domain Manager.

Defining Filter Criteria

For the Jobs, Scheduled Jobs, and Notifications tabs, the items listed in the tabs depend upon the defined filter
criteria shown in the Filter drop down box just above the listed items. In the Filter drop down box you can choose
from canned filters or custom filters that you define.

To define filtering criteria:
1. Do one of the following to open the Filter Criteria dialog box:

• Click the Filter icon next to the Filter drop down box just above the listed items you wish to filter.
• Right-click within the listed items you wish to filter and choose the filter option from the shortcut menu.

The screen shown here is the filter criteria dialog box for the Parent Job pane in the Jobs tab. While the
definable criteria that appear in a dialog box vary based on what you are filtering, the steps for defining criteria
are the same.

2. Do one of the following:

• To create a new job filter, click Add and then name the filter.
• To edit an existing job filter, click the job filter you wish to edit in the list box to the left.
• To delete a job filter, click the job filter you wish to delete in the list box to the left and then click Remove.

3. If you are creating or editing a job filter, define the filter criteria as desired.
4. Click OK.
5. To apply a new or edited filter, choose the filter name from the Filter drop down box just above the listed

items you wish to filter.
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Filter Criteria
The following table is a comprehensive list of the filter criteria you may see in the various dialog boxes for
defining filter criteria.

Criteria Description

Activity This filters jobs by business service.

Activity On This filters jobs by the name of the repository server that processed the job.

Agent This filters e-mail notifications by the business service that sent the e-mail.

Archived Jobs or
Archived Logs

This option only displays jobs or logs that have been archived in the InSight Rendering
domain’s database.

Creation Date/
Time

This filters scheduled jobs by the date(s) and time(s) at which the recurring job ticket for a
scheduled job is submitted.

Events This filters e-mail notifications by the notification event(s) defined for each e-mail
notification.

File This filters log messages by the file in the InSight Rendering application generating the
message.

ID This filters jobs by the internal ID assigned to a job and embedded in the processed job
ticket.

Machine This filters log messages by the repository server on which the message was generated.

Message This filters log messages by the text you specify.

Module This filters log messages by the component generating the message; for example
BusinessServiceManager or DomainManager.

Name This filters jobs by job name.

Priority This filters jobs by the priority (1-10) assigned to a job with the priority attribute in an XML
job ticket.

Product This filters jobs based on the product attribute in an XML job ticket. This can be user or
application defined.
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Criteria Description

Recipient This filters e-mail notifications by receiving e-mail address.

Requestor This filters e-mail notifications by the application used to define the e-mail notification(s).

Schedule ID This filters jobs by the ID assigned to a scheduling job ticket.

Source This filters log messages by the event or method in the application code generating the
message.

Start Date/Time This filters jobs (not scheduled jobs) by the date(s) and time(s) at which the job ticket is
submitted.

Status This filters jobs by job status.

Submitter This filters jobs based on the submitter attribute in an XML job ticket. This can be user or
application defined.

Submitted On This filters jobs by the name of the repository server that submitted the job.

Tag This filters jobs based on the tag attribute in an XML job ticket. This can be user or
application defined.

Types This filters log messages by the log message types selected.

Repository Administration
On the Domain Manager Administration tab, when you expand Domain at the top of the directory tree in the left
pane, all the repositories belonging to the InSight Rendering domain are displayed. Click a repository and the right
pane displays the business services that are available on the repository, the maximum number of jobs that each
business service can concurrently process, and the number of jobs in each of the various processing stages for a
business service.

Repository Options

Right-click a repository to open a shortcut menu of options:

• Suspend – This prevents a repository from processing jobs. New execute requests will be rejected, but
requests that are already queued or in progress will be processed.

• Resume – This resumes a suspended repository.
• Refresh – This updates the information displayed in the right pane.

Note: If you suspend a repository that is the logging server for the domain, configure another repository to be the
logging server.

Services Options

You can highlight one or more business services and then right-click to open a shortcut menu of options:

• Suspend – This prevents a business service from processing jobs.
• Resume – This resumes a suspended business service.
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Routing Administration
On the Domain Manager Administration tab, when you expand Domain at the top of the directory tree in the left
pane, the routing categories for which you can define routing criteria are displayed. Click either Routing by job or
Routing by service and the right pane displays the routing criteria that have been defined.

Routing Options

Right-click Routing, Routing by job or Routing by service in the left pane and you can choose Refresh from the
shortcut menu to update the information displayed in the right pane.

Routing Criteria Options

You can highlight one or more routing criteria and then right-click to open a shortcut menu of options:

• Suspend – This prevents the routing of job requests for a routing criterion.
• Resume – This resumes a suspended routing criterion.

Diagnostic Tools and Procedures
These topics describe some tools and procedures for diagnosing issues and for correcting installations.

Log Files
The InSight Rendering repositories generate log files that report on the activity and any errors occurring on the
repositories in an domain. The default log file location is <Installation_folder>\Log. There are several
types of log files generated, including:

• A log file for each business service
• A log file for each administration component, specifically Domain Manager and Watch Manager
• A log file for the InSight Rendering Resource Manager that manages instances of Microsoft Word
• A Documentum trace log file that records all Documentum calls and responses for a session. This log is a
configurable option that is not set by default, see Setting Documentum Properties.

If centralized logging is enabled, you can use the Log Messages tab to view the messages from the log files for the
repositories.

To assist  Parexel Technical Support with investigating issues in your InSight Rendering environment, you can e-
mail copies of the log files from the locations mentioned above, or you can e-mail copies of specific log messages.

Documentum Database Table
If you want to know the result (success or failure) of a request to render a document in a Documentum database,
check the dmi_queue_table in the docbase. now optionally writes job results for Documentum documents in this
table.  To enable this functionality, check the Update queue item with results checkbox in the Watch Properties
screen of Watch Manager (queue watch only).

Exporting an InSight Rendering Domain Configuration

To assist  Parexel Technical Support with investigating issues in your InSight Rendering environment, you can
export details about your InSight Renderingdomain’s configuration to an XML file.
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To export an InSight Rendering domain configuration:
1. In Domain Manager, choose File > Export Configuration.

The Save Export Configuration dialog box opens.
2. Navigate to the location where you want to save the XML configuration file.
3. In the File Name box, enter a name for the XML configuration file.
4. Click Save.

The saved XML configuration file can now be e-mailed to Parexel Technical Support.

Exporting an InSight Rendering License

To assist  Parexel Technical Support with investigating issues in your InSight Rendering environment, you can
export your license to an XML file.

To export an InSight Rendering license:
1. In Domain Manager, choose File > Export License.

The Save Export License dialog box opens.
2. Navigate to the location where you want to save the XML license file.
3. In the File Name box, enter a name for the XML license file.
4. Click Save.

The saved XML license file can now be e-mailed to Parexel Technical Support.

Adding a Repository Server to a Domain

After completing the installation of an InSight Rendering repository on a server, if for some reason the repository
server does not belong to any domains, you can complete the following procedure to join the repository to a
domain.

Note: This procedure should not be completed for a repository that already belongs to a domain. If you want to
move a repository from one  domain to another, see Moving Repositories to the External Database.

To add a repository to a domain:
1. Start Domain Manager on the repository server that needs to be added to an domain.
2. Confirm that the repository server does not belong to any domains.

• If you have more than one InSight Rendering domain, choose View > Domain to select a domain by server
name or by a domain’s database.

• In the left pane, click the Configuration tab, then expand Domain > Repositories to view the repositories
that belong to the domain.

3. If necessary, choose View > Domain to select the InSight Rendering domain to which the repository will be
added.

4. Choose File > Add Repository.
The Repository Properties dialog box opens.

5. Enter the name of the repository server in the Machine box.
6. Choose com from the Platform drop-down list.

See Repository properties for information on the remaining fields.
7. Click OK.
8. To save your change, choose File > Save.
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9. Expand Domain > Repositories on the Configuration tab to confirm that the repository has been added.

Registering Business Services

Occasionally when executing a job, you may get either the error Invalid class string or Unable to
create instance of Vista.Name on the Status Description tab; see Job Details Pane. This occurs because
the business service specified in the error message failed to register correctly during installation. To correct this,
you need to manually register the business service.

To register an .exe business service:
1. Navigate to the InSight Rendering installation folder, which is usually located at C:\Program Files
(x86)\Common Files\Liquent.

2. In the Windows task bar, click Start and then Run.
3. Click and drag the .exe file for the business service specified in the error message the InSight Rendering
installation folder to the Open box in the Run dialog box. 

4. Type /regserver after the .exe file name in the Open box, and then press Enter.
You do not receive a confirmation that the registration was successful, but you will no longer encounter the
error when invoking the business service.

Registering a Business Service (.DLL Format)

To register a .dll business service:
1. Open the DOS command line.
2. Copy the full path of the business service that you want to register. 
3. Include the business service name.

For example, the path can be c:\Liquent\BusinessServiceFile.dll.
4. Navigate to the .NET framework folder that contains the utility regasm.exe.

For example, this folder can be C:\Windows\Microsoft.NET\Framework\v4.0.30319.
5. Run the utility regasm.exe with the parameter codebase.

This parameter ensures that the registry contains all the necessary information.
6. At the prompt, type: regasm.exe “<.dll path>" /codebase
regasm.exe “c:\Liquent\BusinessServiceFile.dll” /codebase

Showing or Hiding Rendering Applications

When generating rendered output, InSight Rendering works with the applications that are associated with the
content types being rendered; see Configuring Content Types for Rendering. By default, the applications and any
dialog boxes are not shown to the user during the rendering process. For troubleshooting purposes, it can be
useful to view the applications during the rendering process.

This procedure allows you to configure InSight Rendering to show or hide the applications during the rendering
process. This procedure requires the application to be restarted. Confirm that no jobs are in progress before
proceeding.

Note: Perform this procedure on each repository server in a domain.

To set InSight Rendering to show or hide rendering applications:
1. In Domain Manager, choose File > Show/Hide Rendering.
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The Show Rendering dialog box opens and shows your current setting.
2. Do one of the following:

• To configure InSight Rendering to show the applications, select Show rendering applications, and then click
OK.

• To configure InSight Rendering to hide the applications, select Hide rendering applications. Enter the user
for the Network Service Account Information that you set up for installing and applications. Enter the
user's password, and enter it again to confirm it. See Setting Up the Service Account Used for Installation, and
then click OK.

3. You are prompted that in order for the setting to take effect, the application must be restarted.
Click Yes to confirm.
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Submitting Job Requests
These topics describe the various user interfaces for submitting job tickets to the InSight Rendering framework
and the InSight business services for which you are licensed.

InSight Rendering Job Tickets
In the InSight Rendering framework, jobs are tickets written in XML that make requests to the InSight Rendering
business services to perform tasks. Included in the user interface installed with InSight Rendering are wizards and
dialog boxes for creating and submitting job tickets. The topics below discuss how to use these tools.

Regarding the wizards and dialog boxes, be aware that they do not restrict you from submitting a job ticket that
requests a business service for which you are not licensed. If you do submit a ticket for an unlicensed business
service, the submitted job ticket will fail since the business service will not attempt to perform the requested job.

Source Document Considerations
Before submitting job tickets to create renditions of your source documents, consider the following regarding
your source documents.

Microsoft Excel Documents

When rendering Excel documents to HTML, sometimes the Excel plug-in generates a hidden error dialog warning
that the data conversion feature will not be saved in the HTML file. BusinessServiceRender does not properly
handle this dialog and the rendition job fails.

When printing an Excel file containing multiple sheets, you can print page numbers in the header or footer in
sequential order across all the sheets in the workbook. However, the rendered output of the same workbook
results in the page numbers starting over for each sheet. With InSight Rendering, you can render an entire
workbook, but the pagination is not preserved in the PDF output.

InSight Rendering does not process password-protected documents created using applications other than Word.
For example, it does not process password-protected sheets in a Microsoft Excel workbook.

A chart for which Paper size in Excel is set to a value other than Letter, A4, or Tabloid is not resized correctly in
Liquent InSight Rendering if all of the following apply:

• InSight Rendering is running in hide mode. (Applications and dialog boxes are not shown to you during
rendering.)

• On the Excel Transformation dialog box in Liquent InSight Rendering, Paper Orientation is set to a value that
does not match the Orientation setting in Excel.

• On the Excel Transformation dialog box, Page Size is set to Original.

Microsoft Outlook Documents

You cannot render a Microsoft Outlook meeting request if either of the following is true:

• No Microsoft Exchange accounts have been configured in Outlook on the InSight Rendering server.
• The calendar entry for the meeting request was deleted after the request was saved.
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Microsoft PowerPoint Documents

InSight Rendering does not resolve hyperlinks in PowerPoint documents.

Microsoft Project Documents

Microsoft Project renditions might contain more pages than you expected from the original source document.
This is because the pages that are rendered depend on what was displayed in the Microsoft Project window
when you last saved the document. To avoid additional pages, save the Microsoft Project source file with only the
desired information displayed.

Microsoft Visio Documents

To configure the rendering of Microsoft Visio source documents, you can set Visio transformation options for all
documents or options for each document. The transformation options override the options for individual
documents.

InSight Rendering might not render a Visio diagram with the number of sheets (tiles) in the width or length that
you specify. For example, if you specify two sheets across and two sheets down, InSight Rendering might render
the diagram with two sheets across but only one sheet down.

You can configure InSight Rendering to render a Visio document with links. A Visio document can link to:

• External documents
• Websites
• Locations in the source document, if you print all document pages, not just the active page

If a Visio source document has links:

• In the rendered document, if a link hot spot on two tiles is divided by a page break between the tiles, then
each tile has part of the hot spot. 

• In the rendered document, if the target page of a link is tiled and the page breaks between tiles, the link
destination is the first tile.

• If you resize the rendered page containing the diagrams, the link hot spots can be misaligned.
• If a Visio object contains multiple links, only the top-most link is rendered.
• If a Visio object that contains a link has child objects that contain links, only the link from the parent object is

rendered.
• If a link hot spot is an entire Visio page, the link is not rendered.
• If you print only the active page, links to the same document are not rendered.
• If you set the number of sheets in the width or length of a Visio diagram to 2 but Visio prints the document on

one page, the link hot spots in the rendered diagram can be misaligned.

Microsoft Word Documents

InSight Rendering does not render Word source documents that contain the AutoOpen macro fields. Confirm that
your Word source documents do not include AutoOpen macro fields before trying to generate PDFs.

You can create a PDF file from a Word document that contains secured or protected fields. However,  Parexel
cannot guarantee that any transformation options that you select will work. Word documents that contain
secured or protected fields can be successfully rendered to PDF, but features such as bookmarks and links might
not work.

InSight Rendering processes password-protected documents created in Word, although it does not process
password-protected documents created in other applications.

InSight Rendering can process protected Word documents that require a password to open or change, if all the
documents have the same password. InSight Rendering can also process protected Microsoft Word documents
that do not require a password.

InSight Rendering renders blank Word documents, that is, Word documents that are either entirely empty, or
contain only a header, footer, or image.
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Word enables you to create bookmarks to hidden text. If you deactivate hidden text and then render a document,
these bookmarks still appear in the rendered document. Consequently, because the hidden text (containing the
targets for such bookmarks) is excluded, some or all of the bookmarks can reference the wrong pages.

When using a reference as a field code in a Word document, the reference is rendered by the Render business
service as a hyperlink, and the link color matches what is defined for preserved internal TOC links in the Word
content type.

To preserve links in shapes in PDF files rendered from .docx documents on systems with Word 2013, configure
InSight Rendering to show Word windows during rendering.

InSight Rendering cannot extract any character from an equation object in a Word source document. An equation
object does not appear in a bookmark in a PDF document rendered from a Word document.

If you render a Microsoft Word .doc document created in Word 2007 or earlier, some characters can be
rendered in a different font size and unbolded characters can be bolded in the output PDF document. If you
encounter either of these errors, save the document in the .docx format or resave it in Word 2013. Then render
it again to produce a rendition without the error.

Password-Protected Documents from Applications Other Than Microsoft Word

InSight Rendering does not process password-protected documents created by using applications other than
Word. For example, it does not process sheets in an Excel workbook or a PowerPoint document.

If you try to render a password-protected PowerPoint document, the rendering process times out and you cannot
render any other PowerPoint document until you close and reopen PowerPoint.

Files Other than Microsoft Office Files

If you render a file other than a Microsoft Office file from the file system to PDF, the properties of the PDF file
might be different from the properties of the source file.

Text Documents

If a text file source document contains a tab, the rendered document might look different from the source
document. The application used to view the rendered document might replace the tab with a number of spaces.
Consequently, some text on the line that has the tab might exceed the right margin and even be truncated. To
prevent this, set a text transformation option to substitute a space for a tab.

Use of the Less-Than Sign (<) and the Greater-Than Sign (>)

In a cover page or overlay, do not use the less-than sign or the greater-than sign, except to enclose variables.
Using these characters for any other purpose can cause undesired results.

Watch Wizard for Rendering
A watch item is a wizard-generated set of rendering options defined in an XML job ticket that can be executed at
a specified time or interval. This feature is commonly used to setup a recurring poll of a document repository.

Using the Watch Wizard to Create a Watch
You run the Watch Wizard to create a watch that defines options for rendering a document at a specific time or
interval.
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Watch Properties in Domain Manager and the Watch Wizard

When you run the Watch Wizard, some fields are prefilled with global values set in the Domain Manager. You can
accept or override those values. After you run the wizard, changing the values in the Domain Manager does not
change the values for watches that the Watch Wizard already created.

Create A Watch

To create a watch:
1. Start the Watch Manager application. .
2. Select Edit > New > Watch.

The Watch Wizard opens and displays the Watch Properties dialog box.
3. Enter or select values for the following.

Field Description

Name The name that identifies the watch.

Priority The priority for this watch. This is the priority for looking in a specific folder for a document
to render, not the priority for rendering the document.

Watch The type of folder or queue that you want to watch.

Folder The path to the folder or queue that you want to watch. Browse to this folder or queue.

User The user name required to access the folder contents, if the folder has security settings.

Note: If you enter values for User and Password, they are not encrypted. You do not have to
enter these values in the Watch Wizard. If you want these values encrypted, use Domain
Manager to configure them.

Password The password required to access the folder contents, if the folder has security settings.

Output sub-
folder

The location of the rendered files, if you do not want to use the default folder (Output).

Filter The specific files or file types that you want to render. Use an asterisk as a wild card. For
example, to render all files in the folder, do not change the *.* default. To render only
Microsoft Word documents, enter .docx.

4. Click Next.
The Scheduling dialog box opens.

5. To specify when the watch item will run, enter or select values for the Schedule fields:

Field Description

Once At Once at the time that the Now or At option specifies. Now means as soon as you finish
creating the watch.

Daily At Every day at the time that the At option specifies, in the date range that the From and To
options specify.

Daily Between Every day, between the times that the Between option specifies, in the date range that the
From and To options specify, at the frequency that the Every option specifies. Do not set
Every to less than 30 seconds.

Weekdays At At the time that the At option specifies, in the date range that the From and To options
specify, on the weekdays that the On option specifies.
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Field Description

Weekdays
Between

Between the times of day that the Between option specifies, in the date range that the
From and To options specify, at the frequency that the Every option specifies, on the
weekdays that the On option specifies. Do not set Every to less than 30 seconds.

Monthly At Once a month, at the time that the At option specifies, in the date range that the From and
To options specify.

Monthly
Between

Once a month, between the times of day that the Between option specifies, in the date
range that the From and To options specify, at the frequency that the Every option
specifies. Do not set Every to less than 30 seconds.

6. Select either Now to initiate the watch as soon as the wizard settings are complete, or select At and then set
the date and time.

7. Click Next.
The PDF Options dialog box opens.

8. In the PDF Options dialog box, enter or select values for the following:

Field Description

Version The Acrobat PDF version for rendered output.

Optimize for fast
web view

Makes PDF files more suitable for viewing on the Web. This option makes the first page
of a PDF document load as fast as possible.

The PDF Document Properties dialog box in Adobe Acrobat indicates whether a PDF
document is optimized for fast Web view.

Delete blank
bookmarks

When heading level styles are not included in a source document, InSight Rendering
includes blanks in the bookmark tree by default for the missing heading levels. If you
select this option, InSight Rendering removes the blank bookmarks and adjusts the
nesting of the bookmarks. For example, if Heading 1 is missing from the source
document, the Heading 2 bookmark is nested in the bookmark tree where Heading 1
would have been.

Bookmark level on
open

The number of bookmark levels in a rendered document when it is opened. This can be
All or a number from 1 to 20.

If Bookmark level on open is set to any value except All:

• If the Page Mode option is set to UseNone, a rendered document is opened without
bookmarks and the Bookmark level on open option is not used.

• If Page Mode is set to UseBookmarks, a rendered document is opened with the
number of bookmark levels that Bookmark level on open specifies.

Show bookmark
panel when no
bookmarks

Shows an empty bookmark panel in a rendered document when the document does not
contain bookmarks.

Open cross-
document links in
same window

Sets whether cross-document links in rendered output are opened in the same window:

• Default: Use the Preferences setting configured in the user's PDF viewer.
• No: Do not open cross-document links in the same window.
• Yes: Open cross-document links in the same window.

User password To password-protect the file, select User Password and enter a password. Passwords
are case-sensitive. Do not use the same password for User Password and Owner
Password .
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Field Description

Owner password To prevent unauthorized changes to the other PDF security properties that you set,
select Owner Password and enter a password. Passwords are case-sensitive. Do not
use the same password for Owner Password and User Password.

Do not allow
printing

Prevents printing of the PDF.

Do not allow
changing text

Prevents editing of the PDF.

Do not allow
copying text

Prevents copying text from the body of the PDF.

Do not allow
changing comments

Prevents adding comments to the PDF.

Page layouts One of the following page layouts for a rendered document when it is opened:

• Single Page: Displays one page in the document pane at a time.
• OneColumn: Arranges the pages in one continuous column.
• TwoColumnLeft: Arranges the pages in two columns, with all odd-numbered pages

in the left column.
• TwoColumnRight: Arranges the pages in two columns, with all odd-numbered pages

in the right column.

The default page layout is set on a user's Adobe Acrobat Document Properties dialog
box.

Page Mode One of the following page modes for a rendered document when it is opened:

• UseNone: Displays the document pane without bookmarks and thumbnails.
• UseBookmarks: Displays the document pane and the navigation pane with

bookmarks. The Bookmark pane is displayed only if bookmarks are defined in the
PDF document.

• UseThumbnails: Displays the document pane and the navigation pane with
thumbnails for the pages.

Magnification One of the following kinds of magnification for a rendered document when it is opened:

• Default: The default zoom magnification on the user's Adobe Acrobat Document
Properties dialog box.

• Fit Width: The width of the page is the width of the window.
• Fit Height: The height of the page is the height of the window.
• Fit Visible: The width of the page content (text and graphics) is the width of the

window. The window does not contain the left and right vertical margins.
• A percentage of the actual page size.

Watermark To add a watermark to all the pages in the PDF, select Watermark and enter the
watermark text.

Text The watermark text.
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Field Description

Font The font family for the watermark text.

• For a watermark where Office 2013 is installed throughout the InSight Rendering
domain, select Arial Unicode MS. This has all of the characters that will be needed
for most languages.

• For a watermark where there is at least one instance of Office 2016 installed in the
InSight Rendering domain, use the following as a guide (select any font that will
work; these are merely suggestions):

• Arial - Latin characters
• Meiryo - Japanese characters
• PMingLiU - Traditional Chinese (Taiwan/HK/Macau) characters
• SimSun - Simplified Chinese (P.R.C. Mainland/Singapore) characters
• Betang - Korean characters

Position The watermark location on the page. The default position is Centered On Page.

Intensity The watermark location on the page. The default position is Centered On Page.

Hide menubar Hides the Acrobat or Acrobat Reader menu bar.

Hide toolbar Hides the Acrobat or Acrobat Reader toolbar.

Hide window
controls

Displays a PDF file without the left pane and status bar.

Fit window Displays the PDF page on the screen.

Center window Centers the PDF page on the screen.

Display document
title

Displays the document title on the page.

9. Click Next.
The Mail Notification dialog box opens.

10. If you want users to receive automatic e-mail notifications of the progress of this watch item, perform the
following for each user:
a) In the Notification recipient list box, click Add and enter the user's e-mail address.
b) In the Monitored events list box, click each event for which you want the user to receive e-mail
notifications, or click Select All if you want the user to receive e-mail notifications for all monitored events.

You must set up an SMTP server for mail notification on each InSight Renderingrepository.

You can also establish e-mail notifications at the domain level so that one or more users receive e-mails about
the progress of all jobs defined in a InSight Rendering domain.

11. Click Next.
The Finish dialog box summarizes the watch for you to review.

12. If you want to view the XML job ticket that the wizard created, click Display info.
13. If you want to save a displayed XML job ticket as an .xml file, click Save Request As.

This can be useful if you need to manually submit jobs.
14. Click Finish.

The watch that you created appears in the left pane of the Watch Manager under WatchManger > Watches >
<document repository>, with an icon indicating the watch status
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Watch Properties in Domain Manager and the Watch Wizard
When you run the Watch Wizard, some fields are prefilled with global values set in the Domain Manager. You can
accept or override those values. After you run the wizard, changing the values in the Domain Manager does not
change the values for watches that the Watch Wizard already created.

Watch Folder and Queue Settings
When completing the Watch Properties screen of the Watch Wizard, you must specify the folder or queue that
you want InSight Rendering to watch, and define settings related to watching the folder or queue.

Watch Type = FileSystem Folder

Choose this to watch a file system folder. Ensure that the folder to be watched only contains copies of source
materials, because documents are deleted from the watched folder after processing. Specify the following:

• The folder to be watched.
• For file system folders, you can watch a shared folder on a local drive, but we recommend that the file system

folder resides on a network drive. Do not specify mapped network drives. Use full UNC paths to network
drives.

• The username/password for folder access (if necessary).
• The name of the destination sub-folder for rendered output (folder resides in same directory as the watch

folder).
• An optional filter to restrict jobs to a specific file name or file extension (for example, *.doc to only process
Microsoft Word documents).

Watch Type = Documentum Folder, Open Text Folder, or SharePoint Folder

Choose one of these to watch a folder in a Documentum, Open Text, or SharePoint. For Documentum, to avoid
processing errors, ensure that virtual documents in a watch Documentum folder contain content. Specify the
following:

• Select a folder within a repository by clicking the browse button, choosing a repository, and typing the
username/password necessary to connect to the repository.

Note: Ensure that you only set one watch per folder or queue.

• The user/password for DMS access (You do not need to complete this step if you defined a login for the DMS
in Domain Manager.

• The name of the destination sub-folder for rendered output (folder resides in same directory as the watch
folder).

• The name of the work sub-folder. InSight Rendering copies the source files to be rendered from the watch
folder and temporarily stores them in the work folder (folder resides in same directory as the watch folder).

• The name of the error sub-folder where InSight Rendering stores unsuccessful rendering attempts (folder
resides in same directory as the watch folder).

• For Documentum, you can define an optional DQL WHERE clause (excluding the word "where" from your
clause) that filters the source documents to be rendered.

Note: For SharePoint watches, rendered output is stored in a folder named Liquent Renditions that is located in
the top level of the SharePoint site's folder hierarchy. The sub-folder that you defined in the watch as the
destination for rendered output is used for storing a copy of the source document.

Watch Type = Documentum Queue 

Choose this to watch a Documentum queue. Specify the following:
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• Select a Documentum queue within a Docbase by clicking the browse button, choosing a Docbase, and typing
the username/password necessary to connect to the Docbase. The default Documentum queue is
dm_autorender_win31.

• The user/password for DMS access (you need not complete this step if you defined a login for the DMS in
Domain Manager; see InSight Rendering Domain Manager).

• An optional DQL WHERE clause (excluding the word "where" from your clause) that filters the source
documents to be rendered.

Creating A Watch

To create a watch:
1. Start the Watch Manager application.
2. Select Edit > New > Watch.

The Watch Wizard opens and displays the Watch Properties dialog box.
3. Enter or select values for the following.

Field Description

Name The name that identifies the watch.

Priority The priority for this watch. This is the priority for looking in a specific folder for a document
to render, not the priority for rendering the document.

Watch The type of folder or queue that you want to watch.

Folder The path to the folder or queue that you want to watch. Browse to this folder or queue.

User The user name required to access the folder contents, if the folder has security settings.

Note: If you enter values for User and Password, they are not encrypted. You do not have to
enter these values in the Watch Wizard. If you want these values encrypted, use Domain
Manager to configure them. For information on how to configure these values in Domain
Manager, see Configuring DMS Logins.

Password The password required to access the folder contents, if the folder has security settings. (See
the warning in the description of the User field.)

Output sub-
folder

The location of the rendered files, if you do not want to use the default folder (Output).

Filter The specific files or file types that you want to render. Use an asterisk as a wild card. For
example, to render all files in the folder, do not change the *.* default. To render only
Microsoft Word documents, enter docx.

4. Click Next.
The Scheduling dialog box opens.

5. To specify when the watch item will run, enter or select values for the Schedule fields:

Field Description

Once At Once at the time that the Now or At option specifies. Now means as soon as you finish
creating the watch.

Daily At Every day at the time that the At option specifies, in the date range that the From and To
options specify.

Daily Between Every day, between the times that the Between option specifies, in the date range that the
From and To options specify, at the frequency that the Every option specifies. Do not set
Every to less than 30 seconds.
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Field Description

Weekdays At At the time that the At option specifies, in the date range that the From and To options
specify, on the weekdays that the On option specifies.

Weekdays
Between

Between the times of day that the Between option specifies, in the date range that the
From and To options specify, at the frequency that the Every option specifies, on the
weekdays that the On option specifies. Do not set Every to less than 30 seconds.

Monthly At Once a month, at the time that the At option specifies, in the date range that the From and
To options specify.

Monthly
Between

Once a month, between the times of day that the Between option specifies, in the date
range that the From and To options specify, at the frequency that the Every option
specifies. Do not set Every to less than 30 seconds.

6. Select either Now to initiate the watch as soon as the wizard settings are complete, or select At and then set
the date and time.

7. Click Next. The PDF Options dialog box opens.
8. In the PDF Options dialog box, enter or select values for the following:

Field Description

Version The Acrobat PDF version for rendered output.

Optimize for fast
web view

Makes PDF files more suitable for viewing on the Web. This option makes the first page
of a PDF document load as fast as possible.

The PDF Document Properties dialog box in Adobe Acrobat indicates whether a PDF
document is optimized for fast Web view.

Delete blank
bookmarks

When heading level styles are not included in a source document, includes blanks in the
bookmark tree by default for the missing heading levels. If you select this option,
InSight Rendering removes the blank bookmarks and adjusts the nesting of the
bookmarks. For example, if Heading 1 is missing from the source document, the
Heading 2 bookmark is nested in the bookmark tree where Heading 1 would have been.

Bookmark level on
open

The number of bookmark levels in a rendered document when it is opened. This can be
All or a number from 1 to 20.

If Bookmark level on open is set to any value except All:

• If the Page Mode option is set to UseNone, a rendered document is opened without
bookmarks and the Bookmark level on open option is not used.

• If Page Mode is set to UseBookmarks, a rendered document is opened with the
number of bookmark levels that Bookmark level on open specifies.

Show bookmark
panel when no
bookmarks

Shows an empty bookmark panel in a rendered document when the document does not
contain bookmarks.

Open cross-
document links in
same window

Sets whether cross-document links in rendered output are opened in the same window:

• Default: Use the Preferences setting configured in the user's PDF viewer.
• No: Do not open cross-document links in the same window.
• Yes: Open cross-document links in the same window.

User Password To password-protect the file, select User Password and enter a password. Passwords
are case-sensitive. Do not use the same password for User Password and Owner
Password.
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Field Description

Owner Password To prevent unauthorized changes to the other PDF security properties that you set,
select Owner Password and enter a password. Passwords are case-sensitive. Do not
use the same password for Owner Password and User Password.

Do not allow
printing

Prevents printing of the PDF.

Do not allow
changing text

Prevents editing of the PDF.

Do not allow
copying text

Prevents copying text from the body of the PDF.

Do not allow
changing comments

Prevents adding comments to the PDF.

Page Layout One of the following page layouts for a rendered document when it is opened:

• Single Page: Displays one page in the document pane at a time.
• OneColumn: Arranges the pages in one continuous column.
• TwoColumnLeft: Arranges the pages in two columns, with all odd-numbered pages

in the left column.
• TwoColumnRight: Arranges the pages in two columns, with all odd-numbered pages

in the right column.

The default page layout is set on a user's Adobe Acrobat Document Properties dialog
box.

Page Mode One of the following page modes for a rendered document when it is opened

• UseNone: Displays the document pane without bookmarks and thumbnails.
• UseBookmarks: Displays the document pane and the navigation pane with

bookmarks. The Bookmark pane is displayed only if bookmarks are defined in the
PDF document. 

• UseThumbnails: Displays the document pane and the navigation pane with
thumbnails for the pages.

Magnification One of the following kinds of magnification for a rendered document when it is opened:

• Default: The default zoom magnification on the user’s Adobe Acrobat Document
Properties dialog box.

• Fit Width: The width of the page is the width of the window.
• Fit Height: The height of the page is the height of the window.
• Fit Visible: The width of the page content (text and graphics) is the width of the

window. The window does not contain the left and right vertical margins.
• A percentage of the actual page size.

Watermark To add a watermark to all the pages in the PDF, select Watermark and enter the
watermark text.

Text The watermark text.
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Field Description

Font The font family for the watermark text.

• For a watermark where Office 2013 is installed throughout the InSight Rendering
domain, select Arial Unicode MS. This has all of the characters that will be needed
for most languages.

• For a watermark where there is at least one instance of Office 2016 installed in the
InSight Rendering domain, use the following as a guide (select any font that will
work; these are merely suggestions):

• Arial - Latin characters
• Meiryo - Japanese characters
• PMingLiU - Traditional Chinese (Taiwan/HK/Macau) characters
• SimSun - Simplified Chinese (P.R.C. Mainland/Singapore) characters
• Betang - Korean characters

Position The watermark location on the page. The default position is Centered On Page.

Intensity The watermark darkness expressed as a percentage.

Hide menubar Hides the Acrobat or Acrobat Reader menu bar.

Hide toolbar Hides the Acrobat or Acrobat Reader toolbar.

Hide window
controls

Displays a PDF file without the left pane and status bar.

Fit window Displays the PDF page to fill the screen.

Center window Centers the PDF page on the screen.

Display document
title

Displays the document title on the page.

9. Click Next.
The Mail Notification dialog box opens.

10. If you want users to receive automatic e-mail notifications of the progress of this watch item, perform the
following for each user:
a) In the Notification recipient list box, click Add and enter the user's e-mail address.
b) In the Monitored events list box, click each event for which you want the user to receive e-mail
notifications, or click Select All if you want the user to receive e-mail notifications for all monitored events.

You must set up an SMTP server for mail notification on each repository.

You can also establish e-mail notifications at the domain level so that one or more users receive e-mails about
the progress of all jobs defined in a domain.

11. Click Next.
The Finish dialog box summarizes the watch for you to review.

12. If you want to view the XML job ticket that the wizard created, click Display info.
13. If you want to save a displayed XML job ticket as an .xml file, click Save Request As.

This can be useful if you need to manually submit jobs.
14. Click Finish.

The watch that you created appears in the left pane of the Watch Manager under WatchManger > Watches >
<document repository>, with an icon indicating the watch status.
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Copying a Watch
The Copy this Watch option is available on the status page of a previously submitted Watch. Select the Watch in
the navigation tree to view the status details.

Use the Copy this Watch option to reopen the Watch Wizard to create a new Watch by copying the original.
When the Watch Wizard opens, 'Copy of' is prepended to the name of the original Watch.

Follow the same procedures presented in the topic General Watch Item Setup to define the settings for the Watch
you copied. All the settings established for the original Watch appear in the subsequent dialog boxes. You have
the option to change these settings, as needed.

Editing a Watch
The Edit this Watch option is available on the status page of a previously submitted Watch. Select the Watch in
the navigation tree to view the status details.

Use the Edit this Watch option to reopen the Watch Wizard and revise settings for a Watch. When the Watch
Wizard opens, the settings previously established for the Watch are presented.

Deleting a Watch
The Delete this Watch option is available on the status page of a previously submitted Watch. Select the Watch in
the navigation tree to view the status details.

Use the Delete this Watch option to permanently delete the Watch from the schedule and delete its settings. A
confirmation message opens for confirming whether to delete the Watch.

If you do not want to delete the Watch yet, remove it from the schedule.

Suspend/Resume this Watch

1. Select the Watch in the navigation tree to view the status details.
The Suspend/Resume this Watch option is available on the status page of a previously submitted Watch.

2. One of the following occurs if you select this option:

• If the Watch is active, clicking this option prevents the Watch from being performed, yet keep the Watch
settings on file.

• If the Watch is suspended, clicking this option reactivates the Watch schedule.

In both cases, a confirmation message is displayed for you to confirm your selection.

Submitting a Scheduled Job
A scheduled job is an XML job ticket that has a specified time or recurring interval associated with it, that is, the
job ticket is to be executed at a defined schedule. A job ticket alone without a schedule is processed one time
when it is submitted. A “scheduled job” is different from a “job” because of the schedule, which dictates when and
how often the job ticket is processed.

A scheduled job can run when an InSight Rendering server is turned on, but nobody is logged on to the server.
Using InSight Rendering this way is referred to as using it in non-interactive mode.
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In InSight Rendering, there are two ways to submit a scheduled job ticket: the Scheduled Work Wizard provided
with the Watch Manager application, or the scheduled job dialog provided with the Domain Manager application.
Both user interfaces function the same way, differing only in their presentation.

Scheduled Work Wizard

To submit a scheduled job using the Scheduled Work Wizard:
1. Start the Watch Manager application.
2. Choose Edit > New > Scheduled work.

The Scheduled Work Wizard opens with the Work Properties dialog displayed.
3. Do the following:

a) In the Name box, assign a name to the scheduled job.
b) Type an XML job ticket or click the browse button to import an job ticket from an existing XML file on a

local or network drive.
c) Click Save Request As if you want to save the currently displayed job ticket as an XML file on a local or

network drive.
If you import a job ticket, you may edit the job ticket.

4. Click Next.
The Scheduling dialog is displayed.

5. On the Scheduling dialog, select from the list the schedule frequency at which your watch item should run,
and then define the settings for that frequency.

6. Choose from the following frequencies:

• Once At – Runs a job once at the time specified.
• Daily At – Runs a job daily at the time specified.
• Daily Between – Runs a job daily between a specified start time and end time.
• Weekdays At – Runs a job once at the time specified but only during weekdays.
• Weekdays Between – Runs a job between a specified start time and end time but only during weekdays.
• Monthly At – Runs a job at the time specified once a month.
• Monthly Between - Runs a job between a specified start time and end time but only once a month.

Note: If you select one of the Between schedules, do not set the Every polling frequency to less than 30
seconds.

7. Click Next.

With the Mail Notification dialog, you can specify the e-mail address of one or more users to receive
automatic e-mail notifications of this scheduled job’s progress each time it is executed.

An SMTP server for mail notification must be setup on each InSight Rendering repository.

The Mail Notification dialog is displayed.
8. In the Notification recipient list box, click Add and enter a user's e-mail address.
9. In the Monitored events list box, click each event for which you want this user to receive e-mail notifications.

Note: E-mail notifications can also be established at the domain level so that one or more users receive e-mails
regarding the progress of all jobs defined in an InSight Rendering domain.

Click Select All for e-mail notifications on all monitored events.
10. Click Finish.

The established scheduled job appears in the left pane of the Watch Manager under Watch Manager >
Scheduled Work.
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Scheduled Job Dialog in Domain Manager

To submit a scheduled job ticket using Domain Manager:
1. In Domain Manager, click the Administration tab in the left pane.
2. Click Domain at the top of the directory tree in the left pane.
3. In the right pane, click the Scheduled Jobs tab.
4. Right-click within the Scheduled Jobs tab and choose New scheduled job from the shortcut menu.

The remainder of this procedure is identical to the Scheduled Work Wizard with two exceptions: instead of a
Next button, you click the tab corresponding to the step in the procedure, and instead of a Finish button you
click OK..

Once complete, the established scheduled job appears under the Scheduled Jobs tab in the right pane of the
Domain Manager’s Administration tab.

The New Scheduled Jobs Properties dialog box opens.

Submitting a Job
InSight Rendering allows you to submit an XML job ticket as a one-time request to the business services to
perform tasks. When submitting a job, the XML ticket is processed once. There is no recurring schedule defined
for the job ticket request to be processed again. Using InSight Rendering this way is referred to as using it in
interactive mode.

To submit a job ticket:
1. In Domain Manager, click the Administration tab in the left pane.
2. Click Domain at the top of the directory tree in the left pane.
3. In the right pane, click the Jobs tab.
4. Right-click within the Parent Job Status pane of the Jobs tab and choose Submit new job from the shortcut

menu.
The Submit Job dialog box opens.

5. Under Specify File Containing Request, do one of the following:
a) Click the browse button to submit a job ticket directly from an existing XML file on a local or network drive.

You must make any necessary edits to the XML file before selecting and submitting the job ticket.
b) Check Wait until job done to view the XML-encoded results of the processed job ticket and any messages

regarding the job’s status in the Submit Job dialog box.
When unchecked, you must use the Job Details pane of the Jobs tab to monitor the job’s progress.

c) Click Submit Job.
6. Under Enter/modify request below or select file containing request, do one of the following:

a) Either type an XML job ticket or click the browse button to import a job ticket’s XML code from an existing
XML file on a local or network drive.
If you import a job ticket, you may edit the XML code on this screen.

b) Click Save Request As if you want to save the currently displayed job ticket as an XML file on a local or
network drive.

c) Check Wait until job done to view the XML-encoded results of the processed job ticket and any messages
regarding the job’s status in the Submit Job dialog box.
When unchecked, you must use the Job Details pane of the Jobs tab to monitor the job’s progress.

d) Click Submit Job.

Submitting a Job Submitting Job Requests

Liquent InSight Rendering 4.4 Administration 58



7. If you checked Wait until job done, use the Current Results tab to view the XML-encoded results of the
processed job ticket.
a) The Status Description tab displays any message generated by the repository to regarding the current

status.
If the job failed, this description should contain an appropriate error message.

8. Click Close once the job has been processed.

Watch Manager
The InSight Rendering Watch Manager is a user interface tool that includes monitoring and administering
capabilities for managing domains. This tool is made available to all installations, regardless of the licenses that
they have.

To open the Watch Manager:
1. On the Windows desktop, double-click the Watch Manager icon.

This icon is shown in Icons Used in the Watch Manager.
2. When you are prompted to log in, type your user ID and password, and press Enter or click Login.
3. When you log in for the first time after installing , type Admin for the user and 123 for the password.

When InSight Rendering is installed, the login render-perfect with this username and this password is created
for the Watch Manager. For instructions on changing this username and password, see the Liquent InSight
Rendering Installation Guide.

4. In the left pane, click on items in the directory tree to change the information displayed in the right pane.

Watch Manager Components
File Menu

• Logout – This exits the current domain and returns you to the Login screen to administer another InSight
Rendering domain.

• Exit – Exits the application.

Edit Menu

Use the Edit menu to create and administer rendering Watches and custom Scheduled Work job tickets. You have
complete access to this GUI functionality, but your license key determines the business services that an XML job
ticket can use.

The Watch Manager window has icons that correspond to some of the Edit menu options. The following table
describes these menu options and icons:

Option Icon Description

New Create a render Watch or a custom Scheduled Work job ticket.

Copy No icon Copy a render Watch or Scheduled Work job ticket.

Delete Remove a render Watch or Scheduled Work job ticket.

Suspend Suspend a render Watch or Scheduled Work. Suspended items remain in this state
indefinitely.
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Option Icon Description

Resume Resume a suspended render Watch or Scheduled Work.

Properties Edit the properties of a render Watch or Scheduled Work job ticket.

Navigation Pane

The left pane presents rendering Watches and Scheduled Work in their groups. In the Watches group, rendering
watch items are organized by the file system and Document Management Systems (DMSs) (for example,
Documentum) being watched.

You can create a rendering Watch by clicking a DMS in the left pane, right-clicking in the right results pane, and
selecting New Watch on the shortcut menu. This invokes the Watch Wizard described in Watch Wizard for
Rendering.

Scheduled Work is a feature that enables you to schedule a job ticket. This option requires an XML job ticket to
be entered manually.

Results Pane

As you make a selection in the left pane, the Watches or Scheduled Work associated with your selection is
displayed in the right pane. You can right-click an existing Watch or Scheduled Work in the right pane to access
the shortcut menu for editing item. The following color-coded icons quickly communicate the status of a
rendering Watch or Scheduled Work:

Icon Name Description

Active Indicates the Active status of a rendering Watch or Scheduled Work.

Suspended Indicates the Suspended status of a rendering Watch or Scheduled Work.

Expired Indicates the Expired status of a rendering Watch or Scheduled Work.

Error Indicates the Error status of a rendering Watch or Scheduled Work.

Watches with this status are usually XML or SVG render watches that InSight Renderingno
longer supports. Remove or redefine these watches.

Icons Used in the Watch Manager
You can use the following icons in the Watch Manager:

Icon Name Description

Watch Manager On your Windows desktop, double-click this to open the Watch Manager window.

New Create a render Watch or a custom Scheduled Work job ticket.

Delete Remove a render Watch or Scheduled Work job ticket.

Suspend Suspend a render Watch or Scheduled Work. Suspended items remain in this state
indefinitely.
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Icon Name Description

Resume Resume a suspended render Watch or Scheduled Work.

Edit Edit the properties of a render Watch or Scheduled Work job ticket.

Active Indicates the Active status of a rendering Watch or Scheduled Work.

Suspended Indicates the Suspended status of a rendering Watch or Scheduled Work.

Expired Indicates the Expired status of a rendering Watch or Scheduled Work.

Error Indicates the Error status of a rendering Watch or Scheduled Work.

Watches with this status are usually XML or SVG render watches that InSight
Renderingno longer supports. Remove or redefine these watches.
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Plug-In File Formats and Settings
This topic presents the file formats that can be processed by the plug-ins and discusses how to customize
rendering and extraction settings in InSight Rendering.

File Formats
Many different file formats can be processed by using the plug-in applications that are supplied with InSight
Rendering. This topic lists the common file formats that can be processed by each of the plug-ins supplied with .
You can use this information to help you determine which plug-in you should use for rendering source documents
with .

Note: For current descriptions of supported file types, please refer to the respective manufacturers of those plug-
ins.

For each plug-in, you will find a description of all the file formats that plug-in can process. The file formats are
listed using file system extensions. For DMS content type equivalents, see your DMS administrator to determine
the DMS content type assignments for file formats.

Some graphic file format extensions can have several variations. For example, .jpg, .jpeg, .jfif, and .jpe are
all JPEG file interchange formats. Unless otherwise noted, all variations of a listed file format extension can be
processed by a plug-in. An asterisk (*) after a file format indicates that any one of several numbers may be a part
of this file format extension.

Plug-in (as shown in
Domain Manager)

File types

Imaging .tif (single and multi page), .bmp, .gif (non-animated only), .jpg
Microsoft Excel .csv, .dbf, .lab, .prn, .slk, .wks, .xla, .xlc, .xlm, .xls, .xlsx, .xlt, .xlw
Microsoft PowerPoint .bmp, .pot, .pps, .ppt, .pptx
Microsoft Outlook .msg
Microsoft Project .mpp
Microsoft Visio .emf, .gif (only non-animated), .jpg, .png, .vsd, .vss, .vsw, .vsx
Microsoft Word .asc, .doc, .docx, .mcw, .msw, .rtf, .txt, .wri
PDF .pdf, .ai (only in PDF, not EPS, format)

Text .asc, .dat, .lst, .m11, .sas, .txt, .xpt
Tiffx .tif, .tiff (single and multi page)

Rendering and Extraction Settings for Plug-Ins
Several plug-ins have rendering and/or bookmark extraction settings that specify how the content of a document
is laid out in the PDF rendition or which entities will be extracted from its text. Extracted entities are stored in the
PDF rendition as bookmarks. Some plug-ins have settings that you can customize and those plug-ins are
described below.

File Formats Plug-In File Formats and Settings

Liquent InSight Rendering 4.4 Administration 62



Some plug-ins permit you to strip-out or replace special characters that may appear in a file.

Text Plug-In
The text plug-in defines how InSight Rendering formats each page and lays out the document text when it creates
a rendition of a text file. The options you set determine the look of the published document because text files
contain no formatting information for printing.

InSight Rendering uses the values you supply for paper size, paper orientation, margins, and font size along with
the ESPS ASCII font dimensions to calculate how many text characters can fit on a line and how many lines can fit
on a page. If the calculated values are greater than your selections for the maximum number of characters per line
and lines per page, InSight Rendering displays an error message. You must then modify the appropriate settings
until you find a combination that will fit on a page.

You can also specify text characters that you want replaced or removed from the document text. It is
recommended, however, that you do not replace or strip-out control codes (or escape sequences), since these will
change the format of the document text.

Setting Text Transformation Options

To set text transformation options:
1. From the Character Encoding list, choose a character encoding preference.

You may select Auto Detect, but if you know the text documents use ANSI or JIS character sets, then that
encoding can be specified in the drop down list to ensure proper interpretation by the plug-in.
This setting enables the text plug-in to interpret the characters in the document by employing the proper
encoding scheme.

2. Under Process, select a process method.
3. From the Paper Size list, choose the paper size for the rendition.
4. From the Orientation list, choose the page orientation.
5. In the appropriate fields, enter the left, right, top, and bottom margins (in inches).

Use decimals for fractional sizes.
6. From the Font list, choose a font character set.
7. From the Font Size list, choose a font size.
8. Set the maximum number of characters for a line in Max. Characters/Line.
9. Set the maximum number of lines for a page in Max. Lines/Page.

10. If you want to remap any special characters, click Special Char.
11. Click OK.

Text Option Interaction
Many text plug-in rendering transformation options interact with each other. A change in one setting can cause a
conflict with other settings. For example, assume you want to have 100 characters per line and 85 lines per page
on US Letter paper with one-half inch margins. Under these conditions, you could not use a 9-point font size
because it only produces 93 characters per line and 80 lines per page. To resolve this conflict you could either
select another Font Size, smaller Char Count values, or smaller page margins. You could also change the paper size
or orientation, but this might not solve the problem entirely. Changing the paper size provides more length but
reduces the available width. Changing the orientation provides more width but reduces the available length.

You can avoid many conflicts by using any process methods. A process method adjusts other rendering options to
match one or more option values deemed critical to properly processing a text file.

The following process methods are available:
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• Fit Char Count To Font Size increases the Char Count values to accommodate the selected Font Size. If this
does not create a conflict, the selected Font Size is used.

• Fit Font Size To Char Count reduces the Font Size to accommodate the selected Char Count values. If this
does not create a conflict, the selected Font Size is used.

When you use a process method, you enter the appropriate paper and font values. Remember to leave room in
the page margins for any headers and footers.

Microsoft Powerpoint Plug-In

The Microsoft PowerPoint plug-in processes Microsoft PowerPoint presentation slides into PDF pages. Each slide
is placed on an individual page. The slide background, title, body text and images are included in the rendition.
You can define how to format each slide on a page.

To set PowerPoint transformation options:
1. Do any of the following:

• To print a slide's text, images and notes in black and white, check Black & White.
• To enlarge text and images proportionally to fit the width of the printable area, check Scale To Fit.
• To print a border around the slide's contents, check Frame Slides.
• To print any associated notes below a slide's contents, checkPrint Notes.
• To print the handout for a slide show, check Handouts, then choose a value from Slides per page.

2. Click OK.

Microsoft Powerpoint Plug-In Options
The Microsoft PowerPoint plug-in can extract the title of each slide in a PowerPoint presentation to make
bookmarks for the rendition. You can specify a list of characters (using character codes) to be replaced or removed
from all slide titles.

Microsoft Project Plug-In
The Microsoft Project plug-in processes project information, such as tasks, resources, costs, and progress, that is
created and stored in a Microsoft Project file. The plug-in generates a PDF file containing the project information.

Microsoft Project stores the project information in views. The view format that you select in InSight Rendering
determines how the project information appears in the rendered PDF file. You can select one or more views and
apply some Microsoft Project print options to the views.

The plug-in does not process information in any Microsoft Project report format.

For more information on the view formats and printing options, see your Microsoft Project documentation.

Microsoft Project Plug-In Options

To set Microsoft Project transformation options:
1. To turn off the printing of headers and footers, check Hide Headers and Footers.

This option applies only to Microsoft Project 95 files.
2. To scale the text to fit the information on one page width, check One Page Wide.
3. To begin a new page at each page break inserted into the file, check Manual Page Breaks.
4. Under Time Scale, select the range of dates to include in the rendition.
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If you selected Dates From, enter the starting and ending dates.
5. Under Views, check one or more view formats for the rendition.
6. Click OK.

Microsoft Word Plug-In
Microsoft Word Transformation Options

With the Microsoft Word transformation options feature, you can do the following:

• Suppress headers and footers
• Update field codes
• Preserve Word Web links
• Set the link color for Web links and any rendered links in a source document
• Preserve internal cross-references
• Preserve table of contents, table of figures, and table of tables links
• Preserve cross-document links
• Preserve the Word font formatting
• Add line numbers to every printed page of a rendition
• Set conditions for the line numbering format 
• Obtain access to protected documents that you want to render
• Provide the password for opening or modifying a document or template
• Disallow A4/letter paper resizing
• Preserve endnote and footnote links

Special conditions apply to some of these settings. External document links must be absolute paths. Links are
broken if the target document is moved. External document links are supported only for file system documents.
Graphics or drawing objects, such as lines, are not suppressed during rendering. If text is highlighted in a header
or footer, the highlight is not suppressed during rendering.

Internal Microsoft Word links are preserved using the Page Layout view. This view ensures that all links are
targeted to the proper page. Whenever the view is changed, Microsoft Word might automatically process any
field codes in the document. At times, the link targets are not properly defined and the links in the rendition do
not jump to the proper destination. If you want to preserve any links or cross-references in a Microsoft Word
document, select the Update Field Codes option. Selecting this option ensures that the field codes are updated
before the rendition is created.

Font formatting in the source document is retained when the Preserve Word Font Formatting check box is
selected. This overrides the link color set on the Microsoft Word Transformation Options dialog box. If this
option is not selected, the source document link color is replaced with the setting from the Microsoft Word
Transformation Options dialog box.

Font formatting of the preserved cross-references in the source document is retained when the Preserve Word
Font Formatting is selected. This overrides the link color set on the Microsoft Word Transformation Options
dialog box. If this option is not selected, the source document link color is replaced with the setting from the
Microsoft Word Transformation Options dialog box. Some cross-reference font formatting, such as underlines
and strikethroughs, are removed during link color replacement. Use the Preserve Word Font Formatting option if
you want to preserve the cross-reference links from the document and want the text to appear exactly as it
appears in the source document.

For more information about Word hyperlinks and line numbering, see your Microsoft Word documentation.

Microsoft Word Plug-In Options

To set Microsoft Word transformation options:
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1. To turn off the printing of headers, check Suppress Headers.
2. To turn off the printing of footers, check Suppress Footers.
3. To update all field codes in the document, check Update Field Codes.
4. Under Word Internal Links, do any of the following:

• To include Web hyperlinks in the rendition, check Preserve Word Web Links.
• To include cross-reference links in the rendition, check Preserve Internal XRefs.
• To include table of contents, table of figures, and table of tables links in the rendition, check Preserve TOC

Links.
• To include links to external documents in the rendition, check Preserve Cross Document Links.
• To include endnotes and footnotes in the rendition, check Preserve Endnote and Footnote Links.
• To include Microsoft Word font formatting, check Preserve Word Font Formatting.
• To specify the color of all preserved links, use the Link Color list to choose the color.

5. To add line numbers on all pages, check Add Line Numbering, and then do the following:
a) To set the number for the first line, enter or choose a number in the Start at box.
b) To set the distance from the text that line numbers are placed, enter or choose a number (in inches) in the

From text box.
Auto uses Microsoft Word's default setting.

c) To specify how the line numbers increment, type or choose a number in the Count by box.
d) Select how line numbers are applied by selecting Restart each page, Restart each section, or Continuous.

6. To enable InSight Rendering to render documents that are protected (encrypted) in Microsoft Word, click Stop
protection and, if making the documents unprotected requires a password, type the password in the
Protection password box.

Note: Passwords in Word are cases-sensitive.

7. If opening the documents you are rendering requires a password, type the password in the Open document
password box.

Note: This enables InSight Rendering to open the documents if all of them require the same password.

8. If modifying the documents you are rendering requires a password, type the password in the Modify
document password box.

Note: This enables InSight Rendering to create bookmarks, links, line numbers, and headers and footers from
styles in the documents if all the documents require the same password. This does not enable anyone to
modify the documents.

9. If opening the templates that the documents you are rendering use requires a password, type the password in
the Open template password box.

Note: This enables InSight Rendering to open the templates if all of them require the same password.

10. If modifying the templates that the documents you are rendering use requires a password, type the password
in the Modify template password  box.

Note: This enables InSight Rendering to create bookmarks, links, line numbers, and headers and footers from
styles in the templates if all of templates require the same password. This does not enable anyone to modify
the templates.

11. To prevent resizing, check Disallow A4/Letter paper resizing. If the document to be rendered has preserved
internal links, make sure that the default is not overridden. That would allow a resized rendition, in which the
active links do not align with the original document.

12. Click OK.
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Note: When rendering a read-only Word document (Windows read-only property), the Word plug-in fails
when any of the following transformation options are selected: Suppress Headers, Suppress Footers, Preserve
Word Web Links, or Add Line Numbering.

Microsoft Word Plug-In Table Setup

To set table of contents, table of figures, or table of tables options:
1. Click the Table of Contents, Table of Figures, or Table of Tables option label to the right of the option check

box that you already selected.
2. Click Options.
3. Do any of the following:

• To separate multiple sets of extracts, select the Precede Extracts With check box, and type a label in the
box. This text is used as a heading for each set of extracts produced by extraction.

• To extract using heading styles, select the Use Heading Styles check box. In the Show levels up to box, type
or select the number of levels that  InSight Rendering gathers.

• To extract using table entry fields, select the Use Table Entry Fields check box. In the Type identifier for
Table Entry Fields box, type one or more table entry field codes to be extracted. If you type more than one
code, type a semicolon (;) between the codes.

4. Click OK.

Microsoft Word Extraction Options
The Microsoft Word plug-in can also extract entities from document text by using either the styles in a document
template or an auto-generated table of contents.

If you use document templates, you can specify a list of styles that the plug-in uses to identify document entities
to extract and turn into bookmarks. For each style, specify a hierarchical level that describes how a bookmark is
related to other bookmarks. You can use the styles, for example, for documents in a compound document outline.
You can select a level number or one of two special level assignments:

• Subordinate is one level below the previous extract assigned a level number.
• Same is at the same level as the previous extract assigned a level number.

You can change the characters in the extracted bookmark title by using a template and selecting characters to be
replaced in the title or removed from it.

When extracting using document templates, you can also specify a secondary method to be used if a document
template is not in the list. You can choose to either skip extracting, use another template from the list, or extract
using Heading Styles or Table Entry Fields. If you use an auto-generated table of contents, figures or tables, you
can extract those entities marked as either Heading styles (Heading 1, Heading 2, Heading 3 and so on) or Table
Entry Fields.

Auto-generated tables of figures or tables extract any text created by using the Word Insert Caption function. You
can specify the identifiers to be used when extracting using Table Entry Fields. Each identifier is usually a single
character between A and Z. In InSight Rendering, you can specify more than one identifier, and the table of
contents generated contains all entities marked by Table Entry Fields with the designated identifiers. The table of
contents entries are then extracted and turned into bookmarks.

You can use any combination of these extraction options. The final set of bookmarks contains all the entities
extracted from each method in the order you specified. To distinguish between multiple sets of extracts gathered
by different methods, specify the text to precede each set of extracts.

The bookmarks created in the PDF output for the extracted entities resolve to the top of the page on which the
target extracts reside.
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Microsoft Word Extraction Options Process

To set Microsoft Word extraction options:
1. Under Extraction By, select the check box for each method that you want to use to identify entities to be

turned into bookmarks:

• Template Styles
• Table of Contents
• Table of Figures
• Table of Tables

2. If you selected the check box for more than one method, specify the order of extraction as follows:
a) To move a method up one position, select the option label, and then click the UP ARROW.
b) To move a method down one position, select the option label, and then click the DOWN ARROW.

3. Set the options for each method.
4. To control the case of the bookmarks, set the Apply case of extracted text option:

If this option is selected:

• If the extracted text style or any part of the extracted text has the All caps or Small caps font setting, the
bookmark is in uppercase.

• Otherwise, the bookmark is in the same case as the extracted text.

If Apply case of extracted text is cleared and the extracted text was entered in mixed case:

• If the extracted text or the paragraph containing it has the All caps font setting, the bookmark is in
uppercase.

• If the extracted text has a custom style with an All caps font setting, but neither the extracted text nor the
paragraph containing it has the All caps font setting, the bookmark is in mixed case.

• If the extracted text has the Small caps font setting, the bookmark is in mixed case.
5. Click OK.

Microsoft Word Template Styles Extraction Options

To set template styles extraction options:
1. Select the Template Styles check box label to the right of the Template Styles check box that you already

selected.
2. Click Options.
3. Under Microsoft Word List of Templates area, define the templates that you want to use to extract entities

from document text.
4. To add a template, click Add, click a template, and click Open.
5. To add a style to the style list for a template, click a template, and click Modify.

a) Under List of Styles, click a style, and click the RIGHT ARROW.
b) In the Level list, click a hierarchical level.
c) To remap characters, click Special Char.
d) Click OK.

6. To remove a style from the style list for a template, click a template, and click Modify.
a) Under Extract Following Styles, click a style, and click the LEFT ARROW.
b) Click OK.

7. To remove a template, click the template and click Delete.
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8. To specify the label that separates one set of extracts from another, select the Precede Extracts With check
box, and type a label in the box.

9. Under If Template Not Found, select the action taken if a template listed under Microsoft Word List of
Templates is not found.
a) To specify that no action is taken to replace the extraction using that template, click Skip.

10. To specify that another template listed under Microsoft Word List of Templates is used to perform an
extraction, click Use, and select the template from the list box.

11. To specify that the table of contents is used to perform an extraction, click Table of Contents, click Options,
and set the necessary options.

12. Click OK.

Microsoft Excel Plug-In
The Microsoft Excel plug-in processes Microsoft Excel spreadsheets into PDF pages.

To set Microsoft Excel transformation options:
1. Under Page Setup, do the following:

a) Set the Fit to properties by entering a number in the page(s) wide by box and a number in the tall box.
b) To fill the paper width and use as many pages as necessary, enter 1 in the pages(s) wide by box and leave

the tall box blank.
c) Set a different paper size, if needed.
d) Set a different page orientation, if needed.

2. Under Print What, do one of the following:

• To print all sheets in the workbook, select Entire Workbook.
• To print each of the selected sheets, select Active Sheet(s).

3. Under Links, do any of the following:

• To keep the hyperlinks from your Microsoft Excel documents in the PDF renditions generated by InSight
Rendering, select Preserve Links.

• To use the font formatting used in Microsoft Excel documents, select Preserve Excel Font Formatting.
4. Click OK.

Microsoft Visio Plug-In
The Microsoft Visio plug-in processes a Visio source document into a PDF file containing Visio diagrams.

You can specify the size and orientation of the pages on which the diagrams are rendered and the size of the
rendered diagrams.

To set Visio transformation options:
1. In the Paper layout area, to specify the size and orientation of the pages on which the diagrams are rendered,

select Apply custom paper size and do the following:
a) Select the page size.
b) Select the Portrait or Landscape page orientation.
c) To specify the pages to which you want to apply the paper layout that you define, click Apply to all pages

or Apply to active page.
2. In the Print zoom area, to adjust the size of the diagrams, select Apply custom zoom and do any of the

following:
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• To make the diagrams proportionally fit one entire page, select Fit to content.
• To increase or reduce diagram size by a specific percentage, select Adjust to and type or select the

percentage.
• To specify the number of printed sheets (tiles) in the width and in the length of a diagram, select Fit to.

Then, in the sheet(s) across box, type the number of sheets in the width, and in the sheet(s) down box, type
the number of sheets in the length.

• InSight Rendering might not render a diagram with the number of sheets (tiles) in the width or length that
you specify. For example, if you specify two sheets across and two sheets down, InSight Rendering might
render the diagram with two sheets across but only one sheet down.

If you set the number of sheets in the width or length of a Visio diagram to 2 but Visio prints a diagram on one
page, the link hot spots in the rendered diagram can be misaligned.

3. To specify the pages to which you want to apply the print zoom values that you define, click Apply to all pages
or Apply to active page.

4. In the Print what area, to specify how much of a document to render, select Entire document or Active page
only.

5. To render diagrams with the links that a source document contains, select Preserve links.
6. Click OK.

Imaging and TIFFX Plug-Ins

The Imaging and TIFFX plug-ins convert scanned TIFF image files into PDF. The option settings describe the page
layout and how the image is scaled and positioned in the PDF rendition. You can specify the paper size,
orientation and margins of the PDF rendition’s page. It is recommended that the paper settings match the
intended output paper size for your publication.

The TIFFX plug-in incorrectly transforms 16 bit color TIFF files. To avoid this issue, Black Ice, the creator of the
TIFFX plug-in, instructs users to convert any 16 bit images to 24 bit images before transforming the document
with the TIFFX plug-in. Also, indexed palette .gif images less than 8 bit must be converted to 8 bit to be
successfully rendered.

To set the Imaging plug-in or TIFFX plug-in rendering options:
1. Under Orientation, select a paper orientation.
2. In the Scale drop down list, choose one of the following:

• Scale to Width to scale the image proportionally to fit the width of the page
• Scale to Page to stretch the image to fill the page
• Use Image DPI to render the image with the original image size, which the dots per inch (DPI) for the image
specifies

3. Use the Paper Size drop down list to select a paper size.
4. Under Print Option, use the check boxes to center the image horizontally and/or vertically.
5. Under Page Setup, type the desired page margins (in inches) in the appropriate boxes.

Use decimals for fractional sizes.
6. Click OK.

Remapping Special Characters
You can translate (remap) special characters that may appear in a file, such as Greek characters or scientific
symbols, with the plug-ins that allow remapping. The plug-ins that allow for character remapping can handle octal,
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hexadecimal and decimal character codes. You build a library of commonly used special characters and assign
another character to replace the special character in the rendition. You can also strip-out any character so that it
will not appear in the rendition.

For example, to replace any tab found in a document extract's title with a space, type the control code for a tab
(\t) in the Special Character box and then type the character code for a space from the appropriate font character
set in the Replacement Character box. When the plug-in extracts the entities, it replaces all tabs with a space in
the extract titles.

Special characters defined in a plug-in affect either the text of a document's pages in the rendition or the
bookmark labels in a rendition. Only the ASCII plug-in provides the ability to select which font character set to
use (ESPS ASCII, ESPS ANSI, or Courier); all other plug-ins use the ESPS ANSI character set.

The Font character sets topic list the decimal character codes for the fonts available in  InSight Rendering. When
entering special characters, typing the character code number designates it as a decimal character code. For other
character codes, use the following code prefixes before the character code number:

• \ Control Codes
• 0x Hexadecimal

To re-map special characters:
1. From a plug-in, click Special Char to view the screen shown above.
2. To add a character to the list:, do the following.

a) In the Special Characters box, enter the code for the character you want to replace or not print.
b) In the Replacement Character box, enter a code for the character you want to print, or type a zero (0) to

strip-out the character
c) Click Add.

3. To remove a character from the list, select a character code in the list and then click Remove.
4. Click OK.

Font Character Sets
This topic contains a listing of the common decimal codes for characters found in each of the fonts used for
rending transformation and extraction. You can use these lists when designating characters to be stripped out or
replaced in a plug-in.

You should note that the Courier and ESPS ANSI fonts contain the standard ANSI character set. The ESPS font
contains the standard ANSI character set, with the exception of codes 177 through 185; these have been
replaced with superior numbers (one through nine). The ESPS Ascii font contains the standard ASCII character set.
When rendering or extracting, you should use the same font set that was used to create the document since
character mapping can vary between fonts. InSight Rendering uses the ESPS ANSI font for special character
replacement in all plug-ins. You can choose which font to use in the ASCII plug-in.

For special language or graphical characters beyond the standard ANSI (Latin 1) code page, see your system
administrator for a list of the codes specific to the ANSI code page(s) used in your organization.

In the following font character sets, those values that have an empty box displayed are not supported. A blank
represents a space (the character produced by the spacebar on your keyboard). The code number precedes the
actual printed character in the font character sets. You should use the code number in the Special Characters
dialog box.

For example, to replace a capital "I" with a lowercase "i" using the Courier font, you should type 73 in the Special
Character box and type 105 in the Replacement Character box.

To identify special printer controls, you can use the following control codes (escape sequence codes):

Font Character Sets Plug-In File Formats and Settings

Liquent InSight Rendering 4.4 Administration 71



This code Matches this control character

\\ Backslash

\b Backspace

\r Carriage Return

\" Double Quote

\f Form Feed

\n Newline

\' Single quote

\t Tab

\v Vertical Tab

Control codes identify printer commands used to format the text in a document. Though you can replace or strip-
out these codes in the Special Characters dialog box, be careful when stripping out or replacing these codes. The
control codes behave differently in different file formats. For example, consider the carriage return and newline
control codes. In source documents created with word processing programs, a carriage return ends a line and goes
to the beginning of the next line. You can replace a carriage return with a space to bring two lines together into
one line.

However, in an ASCII file a carriage return only returns to the beginning of the same line. It is used to overstrike a
line, which results in a bolding effect on the text. Used in combination with a newline code, the carriage return
makes the printer essentially end the line and start at the beginning of the next line. Stripping out or replacing
these control codes from an ASCII file is not recommended because the result will not reflect the proper format of
the document text.
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ESPS Font
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ESPS ASCII Font
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ESPS ANSI Font
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Courier Font
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