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Liquent InSight Rendering 4.4
Installation Guide
This document describes how to install and configure Liquent InSight Rendering repository on a server.

Perform the procedures in this guide, in the order presented, on each server that will act as a repository in the
Liquent InSight Rendering domain.

It includes domain migration options for Oracle database domains. Configuration steps are included for several
(but not all) authoring applications supported by the Rendering Service. Any other supported authoring
application not listed in the System Support Document is beyond the scope of this document.
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Liquent InSight Rendering
Installation Prerequisites
Before installing InSight Rendering, ensure that your machine meets the following prerequisites.

• Please refer to the Liquent InSight Rendering System Support Document (SSD) for complete system hardware and
software prerequisites and recommendations.

• Make sure that you have the license key for the Liquent InSight Rendering version that you want to install.
Each new version of Liquent InSight Rendering requires a new license.

For SharePoint Only
When using InSight or InSight Rendering with SharePoint, versioning must be set to ‘on’ in the SharePoint
Libraries in use for InSight Rendering to render documents without error.

To configure versioning:
1. In SharePoint, select your library.
2. Choose the versioning settings.
3. Select Create major and minor versions.
4. Set the option Require documents to be checked out before they can be edited? to No.

Upgrade Installation Requirements
You may only upgrade from the following Liquent InSight Rendering releases, as these releases were the only ones
certified on Windows 2012, R2.

• Liquent InSight Rendering 4.2
• Liquent InSight Rendering 4.2 CHF 1
• Liquent InSight Rendering 4.2 CHF 2
• Liquent InSight Rendering 4.2 CHF 3
• Liquent InSight Rendering 4.3
• Liquent InSight Rendering 4.3 CHF 1

You may upgrade your Oracle database to Oracle 12.2.0.1, or you may create a new Oracle 12.2.0.1 database.

Recommended InSight Rendering Hardware
Requirements
Recommended hardware requirements for the installation of InSight Rendering.

• 2.8 GHz quad core processor based on current Intel platform
• 8 GB RAM or higher
• 35 GB available hard disk space for document rendering
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• 50 GB of additional free space for publishing

Software Requirements
General Software Requirements
Software requirements for installing InSight Rendering.

• Microsoft Windows Server 2012, R2, Update KB2919355
• Java

• Publishing only: JRE 1.8.0_152 (32-bit only) and higher patches
• Using Documentum D2 only: JRE 1.8.0_XX (64-bit only)and higher patches

 
• Microsoft.NET Framework 4.5.2 and later CLR 4 versions (reboot after installing)
• Confirm that the Print Spooler service is running prior to installing InSight Rendering
• Ensure that you have installed all the necessary fonts on your InSight Rendering repository servers for full and

accurate rendering of your documents
• The following font types are not supported: Custom Encoding (Unable to read certain encodings), Type3, and

Macroman

DMS Repository Communication Requirements
The following are required for DMS Repository Communication:

Documentum

• Documentum Foundation Classes (DFC) 7.2.
• Documentum eContent server Docbase Owner Username and Password
• Rendering Service Only: Documentum Directory for Rendering service Watch Folder (create one if needed, e.g.

create a new folder in a cabinet within Documentum).

Note: This section is optional for creating a watch folder in Documentum

Open Text Content Server

• Open Text Content Server 10.0 or 10.5

SharePoint

• SharePoint Server 2013, 64-bit

Rendering Service Requirements
Rendering Service Requirements for InSight Rendering.

• Ensure that every authoring application can successfully launch and that all registration dialogs and foreground
help applications are disabled.

• Ensure that you have installed all the necessary font sets on each InSight Rendering repository server for full
and accurate rendering of your documents. The following font types are not supported: Custom, Encoding
(unable to read certain encoding), Type 3, and MacRoman.

• Microsoft Office (Word, Excel, PowerPoint): 2016 (32-bit and 64-bit).
• Microsoft Project (application not mandatory but configurations are included in this procedure): 2016 (32-bit

and 64-bit).
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• Microsoft Visio (application not mandatory but configurations are included in this procedure): 2016 (32-bit and
64-bit).

• Any additional authoring software programs to be used (configuration for additional authoring software is not
included as part of this installation procedure).

• Network Share Drive access (for watch queue).
• Share hostname.
• Share domain Username and Password.

Domain Activity Notification Requirements
Domain activity requirements for InSight Rendering

The requirements below are not applicable if you are not setting up Domain Activity Notifications.

• SMTP (email) Server Name
• InSight Rendering Administrator email account

Domain Repository Migration Requirements
Domain Migration Requirements for InSight Rendering.

Migrating to Oracle: Oracle Enterprise or Standard 12c (12.2.0.1.0) 

• Oracle server hostname
• Oracle server Database Owner Username and Password
• Oracle Client (Administrator), version 12.2.0.1.0, 32-bit only

Windows SharePoint Communication Prerequisites
Prerequisites for the Windows SharePoint Communication portion of InSight Rendering

• The Windows firewall must be disabled on the InSight Rendering server.
• The Windows WebClient service must be started on the InSight Rendering server.
• You must install the Desktop Experience so that the WebClient service is present.
• You must set security on the InSight Rendering server so that your SharePoint login credentials are persisted.

Go to Start > Control Panel > Internet Options, and then click the Security tab. With the Internet zone
selected, click Custom Level. Under User Authentication > Logon, select Automatic logon with current
username and password. Restart the server.

• You must install the LIQUENT SharePoint Web service on the SharePoint server. See “Installing the SharePoint
Web Services” in this document for instructions. Note that this release of  Liquent InSight Rendering uses a
new Sharepoint Web Connector.  Liquent InSight Rendering  4.4 is not certified against the older, pre-4.2
connector version, so you will have to upgrade this on your Sharepoint server. If you have a mixed system (you
will be using a pre-4.2 version of Liquent InSight Rendering as well as ), you may leave the current connector
on the Sharepoint server and install this one. They can co-exist on the same Sharepoint server, but they will
have different URLs.

Setup Data
That person must also know the name of the company/organization for the client installation, the location of the
installation drives on the client for the client applications, and the directory path for the Oracle database. The
following data objects are used to reference these items in the installation procedures.
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Page Options Description

<name> A user with Local Administrator privileges for the client installations.

<company name> The name of the company/organization for the client installation.

<install drive> The installation drives on the client for the client applications.

<Oracle database> Directory path for the database.

Setting Up the Account Used for Installation
Before you install Liquent InSight Rendering, set up a service account for installing all applications in your
publishing or rendering environment, including the Liquent InSight Rendering repositories.

Using a service account to install the applications does the following:

• Ensures that the user profile and application configuration settings are consistent in all repositories in a 
Liquent InSight Rendering domain.

• Ensures that the BusinessServiceManager services inherit consistent and correct profile information.
• Increases stability in the domain.
• Prevents configuration problems.

A domain service account is a Windows domain user account that is given local administrative privileges to
Windows for each server in the Windows domain. The domain service account for  Liquent InSight Rendering
does not need to have domain-wide administrative privileges.
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Installing Liquent InSight Rendering
4.4
1. Verify the following for the installation user account:

a) The account is a Windows domain user account placed in the Administrators group on the server.
b) That this account is the same one used to install all prerequisite software for the server.
c) This account will be referred to as local administrator.

Note: The account name may only contain the standard Latin 256 characters.

2. Verify appropriate TCP/IP network access. (Enter NA for all items below that are not applicable.)
a) Ping the InSight Rendering Rendering Server by hostname.
b) Enter the hostname of the InSight Rendering Server: ___________________________________________
c) The InSight Rendering Server is going to be communicating with an Oracle Database on another network

server. Ping that server by hostname. Enter the following information about the Database Server:
d) Host Name_______________________ DB Type_________________________ DB version_______________________

Database Name___________________
3. Verify that the server’s operating system is set to optimize Applications/Programs (not background services).

a) Select Start, right click on This PC, select Properties.
b) Select the Advanced tab and click the Performance button.
c) On the Visual Effects tab, select the Adjust for best performance radio button.
d) On the Advanced tab, select the Adjust for best performance of Programs radio button.
e) Select OK twice.

4. Disable Data Execution Prevention:
a) Select Start > Run and type cmd.
b) Type bcdedit.exe /set nx AlwaysOff and press Enter.
c) You will have to reboot the server for this change to take effect.  You can do that now or wait until the

server configuration is complete.

Note: You may skip this step if it cannot be performed.

5. Verify that Internet Explorer Enhanced Security Configuration is not configured.
6. Launch Server Manager.

a) In the tree on the left, select the Local Server.
b) Under the Properties section, select IE Enhanced Security Configuration.
c) Select Off for both Administrators and Users.
d) Click OK to apply your changes.

Installing Internet Information Services (IIS)
How to install Internet Information Services for LIQUENT InSight Rendering

Prerequisites
While still in the Server Manager Dashboard, if IIS is not already installed, select Add roles and features.

Installing Internet Information Services (IIS) Installing Liquent InSight Rendering 4.4
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1. If the Before you begin screen is displayed, click Next.
2. In the Select installation type screen, select the Role-based or feature-based installation radio button and

click Next.
3. In the Select destination server screen, select the Select a server from the server pool radio button, choose

the desired server in the Server Pool list, and click Next.
4. In the Select server roles screen, add the following Roles: Application Server, File And Storage Services

(should already be selected), Web Server (IIS) (if the Add features that are required for Web Server (IIS)?
dialog displays, ensure the Include management tools checkbox is selected and click the Add Features button).
Click Next.

5. In the Select features screen, select .NET Framework 4.5 Features and WoW64 Support (should already be
selected) and click Next.

6. In the Application Server screen, click Next.
7. In the Select role services screen, add the following Role Services: .NET Framework 4.5, Web Server (IIS)

Support (if the Add features that are required for Web Server (IIS)? dialog displays, ensure the Include
management tools checkbox is selected and click the Add features button) and everything under and including
Windows Process Activation Service Support (for any popup screen that displays asking for confirmation to
install features, ensure the Include management tools checkbox is selected and click the Add features button)
and select Windows Process Activation Service Support – HTTP Activation. Click Next.

8. In the Web Server Role (IIS) screen, click Next.
9. In the Select role services screen, leave the defaults and click Next.

10. In the Confirm installation selections screen, select the Restart the destination server automatically if
required checkbox and click the Install button.

Disable the Windows Firewall

1. Click Start > Control Panel > System and Security > Windows Firewall.
2. Select the Turn Windows Firewall on or off link. 
3. Select all the Turn off Windows Firewall (not recommended) radio buttons. 
4. Click OK.
5. Close the Control Panel.

Configure the Service Account to log on as a
Windows Service

1. Select Start > Run.
2. Type secpol.msc and press Enter. 
3. In the Security Settings tree, expand Local Policies. 
4. Click User Rights Assignment.
5. In the right pane, right-click Log on as a service and select Properties.
6. In the Log on as a service Properties box, add the Liquent InSight Rendering service account to the list.
7. Click OK.
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Disable User Account Control (UAC)

1. While still in the Local Security Policy dialog, select Security Options in the tree.
2. In the right pane, right-click User Account Control: Run all administrators in Admin Approval Mode and select
Properties.

3. In the Local Security Setting tab, select the Disabled radio button.
4. Click OK.
5. Close the Local Security Policy dialog.

Note: If you choose Action Center to change or view the UAC settings, you must Cancel out of that dialog.
Clicking OK, even if you do not make any changes, will change this value to Enabled.

For changes to take effect, you must reboot the system. You may do this now or later, after you have
completed all the configuration steps.

Install LIQUENT InSight Rendering on a Drive
other than the C: Drive

1. Launch Windows Explorer.
2. Right-click the disk drive, and click Properties.
3. In the Properties dialog box, on the Security tab, click the service account.  
4.  Click Edit.
5.  Click the service account again.
6.  Click OK.
7. In the Properties dialog box, click Advanced.  
8. On the Advanced dialog box, on the Permissions tab, click the service account and Change Permissions.
9.  In the Change Permissions dialog box, click the service account, and ensure that Replace all child objects with

inheritable permissions from this object is not selected.
10. Click OK.
11. In the Advanced dialog box, click OK.
12. In the Properties dialog box, click OK.

Create a NUL: Printer Port

1. Select Start > Control Panel > Devices and Printers.
2. Click Add a printer. 
3. Select The printer that I want isn’t listed.
4. Select Add a local printer or network printer as an Administrator.
5. Select The printer that I want isn't listed.
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6. Select Add a local printer or network printer with manual settings and click Next.
7. Select Use an existing port. 
8. Click the arrow to display all available ports in the drop-down list. Look for a port called NUL:. If the NUL: port

is on your system, click Cancel; you do not need to do anything further. 
9. If the NUL: port is not on your system, select Create a new port. Select Local Port from the drop-down

list. Click Next. Enter NUL: for the port name.
10. Click OK.
11. Click Cancel.

Reserve Ports

1. Select Start > Run.
2. Type regedit, and press Enter.
3. Navigate to HKLM\System\CurrentControlSet\Services\Tcpip\Parameters.
4. Right-click in a blank spot in the right pane, and click New > Multi-String Value.
5. Name the new item ReservedPorts, and press Enter.
6. Press Enter to edit the value.
7. For Value data, type the following on one line: 2866-2872
8. Click OK.
9. Close the registry editor.

Configure Microsoft Word 2016
Prerequisites

Open the Windows Explorer and navigate to the following directories and verify that they contain no files; if they
do, remove the files.

For Microsoft Word 2016 32-Bit:

• %ProgramFiles(x86)%\Microsoft Office\Office16\Startup
• %ProgramFiles(x86)%\Microsoft Office\Office16\XLStart
• %appdata%\Microsoft\Word\STARTUP
For Microsoft Word 2016 64-Bit:

• %ProgramFiles%\Microsoft Office\Office16\Startup
• %ProgramFiles%\Microsoft Office\Office16\XLStart
• %appdata%\Microsoft\Word\STARTUP

1. If you are not already logged in, login to the Liquent InSight Rendering Server as local administrator.
2. Launch Microsoft Word.
3. In Microsoft Word, click File > Options.
4. Click General, and do the following:

Reserve Ports Installing Liquent InSight Rendering 4.4
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a) Under User Interface options set the ScreenTip style option to Don’t show ScreenTips.
b) Clear the following under Start up options:

• Tell me if Microsoft Word isn't the default program for viewing and editing documents.
• Open e-mail attachments and other uneditable files in reading view
• Show the Start screen when this application starts

5. Click Display, and then ensure that nothing is selected under Always show these formatting marks on the
screen.

6. Under Printing options, clear the following options:

• Print background colors and images
• Print hidden text
• Update fields before printing
• Update linked data before printing

7. Click Proofing and then under When correcting spelling and grammar in Word, clear the following options:

• Check spelling as you type
• Mark grammar errors as you type
• Frequently confused words
• Check grammar with spelling

8. Click Save and then under Save documents, clear the following option:

• Save AutoRecover information every
9. Click Advanced.

10. Under Editing options, clear the following options:

• Typing replaces selected text
• When selecting, automatically select entire word
• Allow text to be dragged and dropped
• Use CTRL + Click to follow hyperlink
• Automatically create drawing canvas when inserting AutoShapes
• Use smart paragraph selection
• Use smart cursoring
• Prompt to update style
• Keep track of formatting

11. Under Cut, copy and paste, clear the following options:

• Show Paste Options button when content is pasted
• Use smart cut and paste

12. Under Show document content, clear the following options:

• Show background colors and images in Print Layout view
• Show field codes instead of their values

13. Under Show document content, select the following option:

• Show drawings and text boxes on screen
14. Under Print, clear the following options:

• Print in background
• Print XML tags 
• Print field codes instead of their values
• Scale content for A4 or 8.5 x 11" paper sizes

15. Under Save, clear the following option:

• Always create backup copy

Configure Microsoft Word 2016 Installing Liquent InSight Rendering 4.4

Liquent InSight Rendering 4.4 Installation Guide 10



• Allow background saves
16. Under General, clear the following options:

• Provide feedback with sound
• Provide feedback with animation
• Confirm file format conversion on open
• Update automatic links at open

17. Click Trust Center.

• Under Microsoft Word Trust Center, click Trust Center Settings.
• Click Privacy Options and then clear all options under Privacy Options in the right pane.

18. Under Document-specific settings, clear the following option:

• Warn before printing, saving or sending a file that contains tracked changes or comments
19. Under Document-specific settings, select the following options:

• Store Random numbers to improve Combine accuracy
• Make hidden markup visible when opening or saving

20. Click File Block Settings and clear all Open and Save boxes.
21. Select Message Bar, and then select Never show information about blocked content.
22. Select Protected View, and then clear all items.
23. Select Macro Settings.

• Select Enable all macros.
• Select Trust access to the VBA project object model.

24. Select ActiveX Settings.

• Select Enable all controls without restrictions and without prompting.
• Clear Safe mode.

25. To close the Word Options dialog box, click OK twice.
26. Click Review tab on the Menu Bar.

• In the Tracking options section upper drop-down list, select All Markup.
27. Close Microsoft Word.

Configure Microsoft Excel 2016
Prerequisites

If you are not already logged in, login to the Liquent InSight Rendering Server as local administrator.

1. Launch Microsoft Excel.
2. In Microsoft Excel, click File > Options.
3. Click General.
4. Under User Interface options, set the ScreenTip style to Don't Show ScreenTips option.
5. Under Start up options, clear the following options:

• Tell me if Microsoft Excel isn't the default program for viewing and editing spreadsheets
• Show the Start screen when this application starts 

6. Click Formulas and then under Error Checking, clear the Enable background error checking option.
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7. Click Save and then under Save workbooks, clear the Save AutoRecover information every option.
8. Click Advanced.
9. Under Cut, copy and paste:

a) Clear the following options:

• Show Paste Options button when content is pasted
• Show Insert Options buttons

b) Select the following option:

• Cut, copy and sort inserted objects with their parent cells
10. Under Display, clear the Show function ScreenTips option.
11. Under General, clear the following options:

• Ask to update automatic links
• Scale content for A4 or 8.5 x 11" paper sizes

12. Click Trust Center.
a) Under Microsoft Excel Trust Center, click Trust Center Settings.
b) Click Privacy Options and then clear all options.

13. Click File Block Settings and clear all Open and Save boxes.
14. Select Message Bar, and then select Never show information about blocked content option.
15. Select Protected View, and then clear all options.
16. Select Macro Settings.

a) Select Enable all macros option.
b) Select Trust access to the VBA project object model option.

17. Select ActiveX Settings.
a) Select Enable all controls without restrictions and without prompting option.
b) Clear Safe mode option.

18. To close the Excel Options dialog box, click OK twice.
19. Close Microsoft Excel.

Configure Microsoft PowerPoint 2016
Prerequisites

If you are not already logged in, login to the  Liquent InSight Rendering Server as local administrator.

1. Launch Microsoft PowerPoint.
2. In Microsoft PowerPoint, click File > Options.
3. Click General, and do the following:

a) Under User Interface options set the ScreenTip style option to Don’t show ScreenTips.
b) Clear the following under Start up options:

• Tell me if Microsoft PowerPoint isn't the default program for viewing and editing presentations.
• Show the Start screen when this application starts

4. Click Proofing and then under When correcting spelling in PowerPoint, clear the following option:

• Check spelling as you type
5. Click Save and then under Save presentations, clear the following option:
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• Save AutoRecover information every
6. Click Advanced.
7. Under Editing options, clear the following options:

• When selecting, automatically select entire word
• Allow text to be dragged and dropped

8. Under Cut, copy and paste, clear the following options:

• Use smart cut and paste
• Show Paste Options button when content is pasted

9. Under Slide Show, clear the following options:

• Show menu on right mouse click
• Show popup toolbar
• Prompt to keep ink annotations when exiting
• End with black slide

10. Under Print, clear the following option:

• Print in background
11. Under General, clear the following options:

• Provide feedback with sound
• Show add-in user interface errors

12. Click Trust Center.

• Under Microsoft PowerPoint Trust Center, click Trust Center Settings.
• Click Privacy Options and then clear all options under Privacy Options in the right pane.

13. Click File Block Settings and clear all Open and Save boxes.
14. Select Message Bar, and then select Never show information about blocked content.
15. Select Protected View, and then clear all items.
16. Select Macro Settings.

• Select Enable all macros.
• Select Trust access to the VBA project object model.

17. Select ActiveX Settings.

• Select Enable all controls without restrictions and without prompting.
• Clear Safe mode.

18. To close the PowerPoint Options dialog box, click OK twice.
19. Close Microsoft PowerPoint.

Configure Microsoft Project 2016
Prerequisites
If you are not already logged in, login to the  Liquent InSight Rendering Server as local administrator.

1. Launch Microsoft Project.
2. In Microsoft Project, click File > Options.
3. Click General.
4. Under User Interface options, set the ScreenTip style to Don't Show ScreenTips option.
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5. Under Start up options, clear the Show the Start screen when this application starts option.
6. Click Schedule and then under Schedule, clear the Show scheduling messages option.
7. Under Schedule Alerts Options, clear the following options:

• Show task schedule warnings
• Show task schedule suggestions

8. Click Save and then under Save projects, clear the Auto save every option.
9. Click Advanced.

10. Under General, clear the following options:

• Set AutoFilter on for new projects
• Prompt for project info for new projects
• Show add-in user interface errors
• Open last file on startup

11. Under Planning Wizard, clear the Advice from Planning Wizard option.
12. Under General options for this project, clear the Automatically add new resources and tasks option.
13. Under Edit, clear the Ask to update automatic links option.
14. Click Trust Center.

a) Under Microsoft Project Trust Center, click Trust Center Settings.
b) Click Privacy Options and then clear all options.

15. Click Legacy Formats and clear the Allow loading files with legacy or non-default file formats. option.
16. Click Macro Settings and select the Enable all macros option.
17. To close the Project Options dialog box, click OK twice
18. Close Microsoft Project.

If you are asked to save the changes to the document, select No.

Configure Microsoft Visio 2016
Prerequisites

If you are not already logged in, login to the Liquent InSight Rendering Server as local administrator.

1. Launch Microsoft Visio.
2. In Microsoft Visio, click File > Options.
3. Click General.
4. Under User Interface options, set the ScreenTip style to Don't Show ScreenTips option.
5. Under Start up options, clear the Show the Start screen when this application starts option.
6. Click Proofing.

• Under When correcting spelling in Microsoft Office programs, select the Ignore words that contain
numbers option.

• Under When correcting spelling in Visio, clear the Check spelling as you type option.
7. Click Save and then under Save documents, clear the the following options:

• Save AutoRecover information every
• Prompt for document properties on first save

8. Click Advanced.
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9. Under Save/Open, clear the following options:

• Show file save warnings
• Show file open warnings

10. Click Trust Center.
a) Under Microsoft Visio Trust Center, click Trust Center Settings.
b) Click Privacy Options and then clear all options.

11. Click File Block Settings and clear all Open and Save boxes.
12. Select Message Bar, and then select Never show information about blocked content option.
13. Select Macro Settings.

a) Select Enable all macros option.
b) Select Trust access to the VBA project object model option.

14. Select ActiveX Settings.
a) Select Enable all controls without restrictions and without prompting option.
b) Clear Safe mode option.

15. To close the Visio Options dialog box, click OK twice
16. Close Microsoft Visio.

If you are asked to save the changes to the document, select No.

Configure Microsoft Outlook 2016
If you intend to use Outlook to render e-mail messages, you must configure Outlook to have an e-mail
box. Configure this per your company’s guidelines. It would be best to use the service account as the Outlook
entity.

If you are not already logged in, login to the  Liquent InSight Rendering Server as local administrator.

1. Launch Microsoft Outlook.
2. In Microsoft Outlook, click File > Options.
3. Click General.
4. Under User Interface options, set the ScreenTip style to Don't Show ScreenTips option.
5. Under Start up options, clear the Make Outlook the default program for E-mail, Contacts, and Calendar
option.

6. Click Mail and then under Save Messages, clear the following options.

• Automatically save items that have not been sent after this many minutes
• Save forwarded messages
• Save copies of messages in the Sent Items folder

7. Under Tracking, set the option For any messages received that includes a read receipt request to Never send
a read receipt.

8. Click Search and then under Sources, clear the Show prompt to enable Instant Search option.
9. Click Advanced and then under Outlook start and exit, clear the Empty Deleted Items folders when exiting

Outlook option.
10. Under Reminders, clear the following options:

• Show reminders
• Play reminder sound

11. Under Other, clear the Prompt for confirmation before permanently deleting items option.
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12. Click Trust Center.
a) Under Microsoft Outlook Trust Center, click Trust Center Settings.
b) Click Privacy Options and then clear all options.

13. Click Automatic Download and clear the Warn me before downloading content when editing, forwarding, or
replying to e-mail option.

14. To close the Outlook Options dialog box, click OK twice.
15. Close Microsoft Outlook.

If you are asked to save the changes to the document, select No.

Configure Microsoft Internet Explorer 11

1. Launch Internet Explorer. 
2. From the menu, select Tools > Internet options. 
3. Select the Advanced tab. Under Security, uncheck the following:

• Warn about certificate address mismatch
• Warn if changing between secure and not secure mode
• Warn if POST submittal is redirected to a zone that does not permit posts

4. Click OK.
If you need to reboot your computer because of changing the checkbox for Warn about certificate address
mismatch, you may do so now or later.

Oracle Database Installation
These topics describe in detail how to install or upgrade an Oracle Database.

First Time Installation Table Creation Notes
Note: When creating your database, deselect the Create as Container database option in the Oracle Database
Configuration Assistant Select Database Creation Mode or Specify Database Identification Details dialog.

Note: When creating your database, select the Unicode (AL32UTF8) and National Character Set UTF8 - Unicode
3.0 UTF-8 Universal character sets.

If you are installing Liquent InSight Rendering for the first time, arrange for an Oracle DBA or qualified technician
to execute the Oracle SQL script Oracle-repositoryINSTALL.sql. The person who executes this script
needs to be aware of the following:

• The installation script can be run either directly on the database server or remotely from a  Liquent InSight
Rendering client running Windows with Oracle's SQL*Plus. The Oracle client must be the same version as the
Oracle DB software on the DB server.

• Verify that you are running the Oracle Database installation SQL script on a Windows based computer. If your
Oracle Database is hosted by a Unix server, you must run the Oracle Database installation SQL script on a
Windows client that can remotely access the database server using Oracle's SQL*Plus.

• The newly created service must be included in the local tnsnames.ora file on each Liquent InSight
Rendering repository.
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First Time Installation Table Creation

1. On the computer where you are running the installation script, create a temporary install directory, for
example C:\Install\IRDB.

2. From the Liquent InSight Rendering installation media, copy every file from the EnterpriseServices
\Common\Liquent\Database folder to the temporary install directory.

3. Use a text editor to edit the define.install file to define the orapath variable as the locations of the
database tables on the Oracle database server.

4. Save and close the file.
5. Use a text editor to edit the define.passwords file to define the vistapass variable as the password of the

new vista1 user that is used to connect the Liquent InSight Rendering server to the database.
6. Save and close the file.
7. Open a Command Prompt window and do the following:

a) At the command prompt, enter: sqlplus /nolog.
b) At the SQL> prompt, enter: connect system/<system password>@<SID>.

The command prompt returns Connected and then SQL>.
c) Enter @ followed by the complete file path to the customized SQL script.

For example, @”C:\Install\IRDB\Oracle-repositoryINSTALL.sql”.
The SQL script runs and the SQL> prompt is returned when the script completes.

Note: It is normal to receive ORA-01418: specified index does not exist errors since the script
is trying to delete indexes that do not exist.

d) Enter exit to close the sqlplus connection.
8. To test the connection to the database for the vista1 user, do the following:

a) At the command prompt, enter sqlplus /nolog
b) At the SQL> prompt, enter connect vista1/<new vista1 password>@<SID>
c) Confirm that the connection is successful.

9. Enter Exit to close the sqlplus connection.
10. Enter Exit to close the Command Prompt window.

Installation Using an Oracle Database Domain (Oracle Only)

Note: You must have already installed the 32-bit version of the Oracle version 12.2.0.1 client (Administrator) on
the  Liquent InSight Rendering server. The 64-bit client will not work with Liquent InSight Rendering.

Note: Due to a known Oracle issue, an "unable to connect" error can appear. Perform the following procedure to
be able to connect.

1. Select Start > Run. Type cmd and press Enter. 
2. cd to the bin folder under the Oracle client installation path. 
3. At the prompt, type: regsvr32 oraoledb12.dll and press Enter. Select OK for the acknowledgment pop

up. 
4. Type exit and press Enter to close the command prompt.
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Install the LIQUENT InSight Rendering
Software

1. If you are not already logged in, login to the  Liquent InSight Rendering server as local administrator.
2. Copy the installation files from the LIQUENT installation media to either a local drive on the Liquent InSight

Rendering server, or to a network drive that the Liquent InSight Rendering server can access. LIQUENT
recommends performing the installation from a local drive.

3. Locate the setup.exe file in the installer’s EnterpriseServices directory, right-click it and select Run as
administrator.

4. On the InstallShield Welcome window, click Next.
5. On the Customer Information window, enter the User Name and the Company Name, and leave the default of

Anyone who uses this computer (all users) selected. Click Next.
6. On the License Agreement window, read the License Agreement and click Yes.
7. On the Choose Destination window: to accept the default installation destination, click Next. To change the

default location, click Browse, select the desired location, click OK, and then click Next.
8. On the License File window, click Browse, navigate to the license file, highlight it, and select Open. Click Next.
9. On the User Information window, enter the following:

a) Domain: _____________________________________________________
b) User: local administrator
c) Password: ___________________________________________________
d) Confirm the password

10. On the Oracle Database Information page, enter the following:
a) Service (Global Database Name) ___________________________________
b) User – vista1 by default.
c) Enter Password for vista1 ________________________________________
d) Confirm the password.
e) Click Test Connection.
f) When completed, click Next.

11. On the Start Copying Files page, verify the information and click Next.
12. On the InstallShield Wizard Complete page, click Finish.
13. Launch Windows Explorer and check for the existence of the following folder:

a) For Office 2016, 64-bit:%WINDIR%\SysWOW64\config\systemprofile\AppData\Local
\Microsoft\Windows\INetCache

b) For Office 2016, 32-bit:%WINDIR%\system32\config\systemprofile\AppData\Local
\Microsoft\Windows\INetCache

c) If the folder does not exist, create it.
14. If you are upgrading from InSight Rendering 4.2, 4.2 CHF 1, 4.2 CHF 2, 4.2 CHF 3, 4.3, or 4.3 CHF 1, or if you

are reusing the database from a previous installation, check the following after upgrading all InSight Rendering
servers in the domain:

• Launch Domain Manager (via the menu or desktop icon) from any server.
• In the Configuration tab, in the tree on the left, select Services under the first server.

15. In the pane on the right, check the following:
a) Ensure Concurrent for Alias printer is 1.
b) Ensure Retry Interval is 1 or greater if Retry Count is 1 or greater.
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This default has changed to prevent timeout errors of generate-printer-output requests for PostScript
printers.

16. If the above values are not as specified, double-click the service, make the change in the Service Properties
dialog, and select OK.

17. Repeat the checks for all the other servers in the domain.
a) If you made changes, select the Save icon and click Yes in the confirmation dialog.

Liquent InSight Rendering Service (IRS)
Installation
Prerequisites
If you will be connecting to a Liquent InSight Rendering Publisher system, you must install the Liquent InSight
Rendering Service on at least one  Liquent InSight Rendering server in the domain. This server is specified in the
insight.var file on the InSight Application Server. Installing the  Liquent InSight Rendering Service on more than
one  Liquent InSight Rendering Server will ease disruption caused if the Liquent InSight Rendering Server
specified in insight.var goes down.

Note: If this is an upgrade and you have the Liquent Enterprise Services Connector installed, you must uninstall
that before installing the Liquent InSight Rendering Service. Since they use the same port, they cannot coexist on
the same server.

1. Install the IRS via the installer. Copy the installation files locally from the InsightRenderingService folder
in the installer. Right-click on setup.exe and select Run as administrator.

2. On the Welcome page, click Next.
3. On the Customer Information page, enter the User Name, Company Name, and Serial Number. Click Next.
4. On the License Agreement page, read the License Agreement and then click Yes.
5. On the Choose Destination Location page, choose to accept the default Destination Folder or Browse to

another folder. Click Next.
6. On the Start Copying Files page, verify the displayed information and then click Next.
7. On the Setup Status page, when the InstallShield Wizard Complete page appears, select Finish.
8. Launch IIS Manager (Start > Control Panel > Administrative Tools).

a) Select the server in the tree on the left.
b) Double-click ISAPI and CGI Restrictions in the middle panel (if it is not displayed, select the Features View

at the bottom of the middle pane).
c) If any of the entries are Not Allowed, right-click on it and select Allow.

9. Select Application Pools under your server name in the tree on the left.
a) Right-click on InSightRenderingService and select Advanced Settings.
b) Edit the value for Identity (under Process Model) and select ApplicationPoolIdentity in the dropdown

under Built-in account.
c) Under Load User Profile, select True.
d) Click OK twice.
e) Stop and Start the InSightRenderingService application pool (right panel).

10. Select the InSight Rendering Service site in the tree.
a) Double-click Authentication in the middle pane.
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b) Right-click on Anonymous Authentication and select Enable.
If any other entries are Enabled, right-click on them and select Disable.

11. Repeat the previous step for the InSightRenderingService Virtual Directory, located under the Liquent InSight
Rendering site.

12. Select the Liquent InSight Rendering site and click Restart.
13. Check that IIS is properly configured by entering the following in a browser: http://server_name:2861/

InSightRenderingService/Service.svc?wsdl . If Internet Explorer displays some XML (with no
error), the setup is correct.

Liquent InSight Rendering Backbone
Generator Installation
If you will be using , you must manually install the Backbone Generator to be able to create eCTD XML
backbones.

1. Create the following directory on your InSight Rendering server: <IR_INSTALLATION_DIRECTORY>
\BackboneGeneratorService\3.5\Lib
If the directory already exists, delete all files in it.

2. In the installation media for Liquent InSight, navigate to the folder called ectd-backbone. 
a) Unzip the contents to a network share that all the Liquent InSight Rendering servers have access to.
b)  Copy the unzipped files to the folder in the previous step on each  Liquent InSight Rendering server that

will be used for publishing.
3. Set the JAVA_Home environment variable:

a) Right-click on the Start, select System.
b) Select the Advanced system settings link.
c) On the Advanced tab, click Environment Variables.
d) In the System variables field, if JAVA_HOME is not specified click New and create it.
e) For Variable name, type JAVA_HOME.
f) For Variable value, type the path to the Java installation, for example: <drive>:\Program Files
\AdoptOpenJDK\jre-8.0.202.08. Note that this is the correct path if you can append \bin\server
to it to get to the folder where jvm.dll is located.

g) When completed, click OK two or three times to close all dialogs.
4. In the Environment Variables dialog box, add the TNS_ADMIN variable.

a) In the System variables field, click New.
b) For Variable name, type TNS_ADMIN.
c) Open Windows Explorer, navigate to the admin directory of the Oracle client installation, and copy the path

to the clipboard.
d) For Variable value, paste the path you copied to the clipboard.

5. Ensure the JAVA\bin path is in the Path variable as follows:
a) Select the Path System Variable and select Edit.
b) If the path to the JAVA bin file is not in the Path: For Windows 2016 - Select New, provide the path to

the bin folder of the JAVA installation, and click OK. Click Move Up until this entry is at the top of the list.
For Windows 2012 - Prepend the path to the bin folder to the Path.

c) Press OK three times to close all dialog boxes.
6. Reserve ports:
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a) Right-click Start, select Run, type regedit, and press Enter.
b) Navigate to HKLM\System\CurrentControlSet\Services\Tcpip\Parameters.
c) Right-click in a blank spot in the right pane and click New | Multi-String Value.
d) Name the new item ReservedPorts, and press Enter.
e) Press Enter to edit the value.
f) For Value data, type the following on one line: 2866-2872
g) Click OK.
h) Close the registry editor.

Configuring Services

1. Select Start > Run, type services.msc, and click Enter.
2. If you intend to publish to paper, start the Print Spooler service and set it to Automatic.

a) Right-click on the Print Spooler service.
b) Select Properties.
c) Set Startup type to Automatic.
d) Click Start. Click OK.

3. If you will be connecting to a SharePoint server, start the WebClient service and set it to Automatic.
a) Right-click on the WebClient service.
b) Select Properties.
c) Set Startup type to Automatic.
d) Click Start.
e) Click OK.

Memory Allocated to Java-based Business Services
Liquent InSight Rendering uses the Java-based eCTD backbone business service to create the XML files and
checksum files required for a compliant eCTD submission. The eCTD backbone business service, as well as any
other Java-based business service, is allocated a maximum of 512 MB of memory by default on a  Liquent InSight
Rendering repository server, which is usually sufficient for most publishing jobs. However, if the memory
allocation is not enough, the eCTD backbone job will fail. To avoid this error, Domain Manager enables you to
increase the maximum amount of memory on the servers in the  Liquent InSight Rendering domain that can be
allocated to a Java-based business service.

Memory Allocated to Java-based Business Services Memory Increase

1. In Domain Manager, click the Configuration tab in the left pane.
2. At the top of the directory tree, right-click Domain and choose Properties.
3. In the Domain Properties dialog box, select the General tab.
4. Under JVM Option (Java business services), in the Memory Size box, enter a value between 512 and 1024

MB.
5. Click OK.
6. Choose File > Save to save your changes.
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Liquent PostScript Printer Notes
Installing the LIQUENT PostScript Printer Requirements and Notes.

The installation of this printer is optional and only required for PostScript-based printer published output. The
following printers are supported:

• Xerox XPIF Job Ticket with Postscript
• Xerox ASCII Job Ticket with Postscript
• Network Imaging System Job Ticket with Postscript
• All Canon imageRUNNER printers with imagePASS controllers
• Konica Minolta bizhub PRO 1050 / bizhub PRO 1050P PS
• Konica Minolta bizhub PRO 1200P / bizhub PRO 1051 PS

Windows must have access to the certificate chain of authority. The certificate chain is available if the server has
access to the Microsoft Trusted Root Certificate Program. This is part of Windows Updates.

Otherwise, the customer is responsible for the certificate chain of authority to be available to Windows using the
customer's certificate policies.

Install the Liquent PostScript Printer

1. If you are upgrading and the Liquent PS Printer already exists, remove it as follows:
a) Go to Control Panel, View Devices and printers.
b) Right-click on the Liquent PS Printer and select Remove device.
c) Click Yes at the Remove Device confirmation.

2. Create a new folder called LiquentPSPrinter .
 It can be anywhere on the server, but it is recommended to be in the service account’s local user directory, i.e.,
C:\Users\<service_account_user>.

3. Select Start > Control Panel > Devices and Printers > Add a Printer.
4. Click The Printer that I want isn’t listed.
5. Select Add a local printer or network printer with manual settings and click Next.
6. Select the Create a new port option and select Local Port for the Type of port. Click Next.
7. On the Port Name dialog box, in the Enter a port name field, enter an existing local directory path, including a
file name with a .ps extension (e.g., C:\Users\<service_account_user>\LiquentPSPrinter
\pdf2ps.ps). Click OK.  Click Next.

8. On the Install the printer driver dialog box, click Have Disk… and browse to the location of the postscript
printer driver (the installation files location in the LiquentPSPrinter folder) and select the LIQTPS.inf
file. Click Open, and then click OK and Next.

9. On the Type a printer name dialog box, do not change the Printer name from Liquent PS Printer. Click Next.  
If you get a Windows Security prompt asking Would you like to install this device software?,
select the Install button.

10. On the Printer Sharing page, choose Do not Share this Printer. Click Next.
11. On the You’ve successfully added a printer page, do not choose Set as default printer. Click Finish.
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Configure a Document Managment System
(DMS)
Documentum DMS
Configure Documentum DMS on an InSight Rendering Server

In order to be able to connect to a Documentum Docbase, you must first install the proper Documentum
Foundation Classes (DFC) on each InSight Rendering Rendering server and have the correct information in the
dfc.properties file. See the pertinent Documentum documentation for more information.

If you are upgrading your DFC, it is recommended that you uninstall the previous version of DFC and run a
registry cleaning utility before installing the new DFC.

If you are unable to connect to your Documentum docbase with DFC installed, this may be because your Oracle
Client installation has placed the incorrect Java version in the Path environment variable. To fix this, prepend the
locations of the Java\bin and Java\bin\client folders to the Path environment variable.

1. To edit the Path variable, select Start, right-click on Computer, and click Properties.
2. Select Advanced system settings. 
3. Click the Environment Variables button.
4. Under System variables, double-click the Path variable, and then in the Edit System Variable dialog box,

prepend the value in the Variable value field with the locations of the Java\bin and Java\bin\client
folders.
For example: C:\Program Files (x86)\Java\jre1.8.0_74\bin;C:\Program Files
(x86)\Java\jre1.8.0_74\bin\client;

5. Right click on Start, select Run, type regedit and press Enter.
6. Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Documentum\Components\DJCB and

proceed as follows:

• If the VMArgs key exists, proceed to Step 11.

• If the VMArgs key does not exist, proceed to the next step.
7. Right click in a blank spot in the right pane, ans select New > String Value. Name the new item VMArgs, and

press Enter.
8. Press Enter to edit the data.
9. Type -Xmx512M and press Enter.

10. Close the registry editor.
11. Select OK three times and restart the server.

Configure a Documentum DMS in Domain Manager

1. Launch Domain Manager.
2. In the Domain Manager, choose File > Configure DMSs.

The DMS Properties dialog box is displayed.
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3. Click the Documentum tab.
4. In the Docbase Properties window, provide the following information:

Field Description

Name: The name of the Documentum Docbase.

DMS API URL: The URL of the DMS API, in the form of:

<scheme>://<DMSAPIService_Server>:<Port>
Where:

• <scheme> is either http or https
• <DMSAPIService_Server> is the name of the server that the DMS API Service is
connecting to

• <Port> is the port on the server that the DMS API Service connects through

5. You will need to do this step on each Liquent InSight Rendering server in the domain.

SharePoint DMS
Install the Sharepoint Web Service (Sharepoint DMS Only) Requirements
You need only do this section if you intend to connect to one or more Sharepoint servers. 

Repeat this installation procedure on each Sharepoint server that will act as a Sharepoint repository server.

Note: A prerequisite for installing the Sharepoint Web Service on Sharepoint 2013 is that .NET 4.5 must already
be installed on the Sharepoint server. .NET 4.0 will not work.

If you need to uninstall this Web service, stop the IIS service, then use Add/Remove Programs or Programs and
Features to remove the LIQUENT Sharepoint Services program. Then manually remove the LIQUENT Web
Services IIS site.

Uninstall the Web Service from older LIQUENT Enterprise Services\ Liquent InSight Rendering versions and install
the one supplied in 4.4.

This version of the Sharepoint connector has been refactored and will not work with older versions of Liquent
InSight Rendering/LIQUENT Enterprise Services, SmartLink for Word, and SmartLink for PDF. Sharepoint 2010 is
no longer supported in Liquent InSight Rendering 4.4.

Install the Sharepoint Web Service (Sharepoint DMS Only)

1. Login to the SharePoint server as the local administrator. If you run MSTSC, use the /admin switch.
2. On the LIQUENT installation media, locate the LiquentSharePointServices folder and copy the installer

to a local drive on the Sharepoint server.
3. To run the Sharepoint Web Services installer, right-click setup.exe, and select Run as administrator and

complete the installation.

Note: The installer creates an IIS website called LiquentSharepointServices.

4. After running the LiquentSharePointServices installer:
a) Click the Windows Start button.
b) Go to Administrative Tools > Internet Information Services (IIS) Manager

5. Launch IIS Manager.
a) Expand <Local Computer>, Sites.
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b) Select the LiquentSharepointServices site.
6. Double-click Authentication in the middle pane.

a) Right-click Anonymous Authentication and select Disable.
b) Right-click Windows Authentication and select Enable.

7. Select the LiquentSharePointServices site. Right-click on Authentication and select Basic Settings.
a) If the Application pool is not Sharepoint (usually Sharepoint – 80), click Select and choose your Sharepoint
application pool.

b) Click OK.
8. Expand LiquentSharepointServices and select the DMSSharepointServices Virtual Directory.

a) Double-click Authentication (in the pane in the middle).
b) Right-click Anonymous Authentication and select Disable.
c) Right-click Windows Authentication and select Enable.

9. Select the DMSSharePointServices virtual directory. Right-click on Authentication and do the following:
a) Select Basic Settings.
b) If the Application pool is not Sharepoint (usually Sharepoint – 80), click Select and choose your Sharepoint
application pool.

c) Click OK.
10. Select the LiquentSharepointServices web site and select Restart in the right pane.
11. Close the Internet Information Services (IIS) Manager window.
12. To check that everything is correctly configured, launch the following URL in a browser: http://

machine_name:2861/DMSSharePointServices/dmssharepointservices.svc
Configuration Notes for LIQUENT SharePoint Services

After installing LIQUENT Sharepoint Services, if you are unable to connect to your Sharepoint server using its
UNC path in Windows Explorer, or if you cannot use the Explorer View in the browser, perform the following
steps. 

Installing LIQUENT Sharepoint Services may also break the shortcut you use to connect to your Sharepoint
Administrator. Just append default.aspx to the URL the shortcut places in your browser.

If you need to uninstall the Web service, use Add or Remove Programs and remove the LIQUENT Sharepoint
Services program. After uninstalling the Sharepoint Web service, you must then manually uninstall the LIQUENT
Web Services site from the Sharepoint server using IIS Manager

1. Open Sharepoint Administrator.
2. Select Application Management.
3. Select Create or extend Web Application.
4. Under Web Application, select Change Web Application.
5. Select your primary Sharepoint application, that is, the Sharepoint application that uses port 80. Leave all the

defaults and make note of the port number under Create a new IIS site.
6. Click OK.
7. Verify that you are now able to use UNC and the Explorer view.
8. Return to Application Management in Central Administration and select Remove Sharepoint from IIS Web site.
9. Under Select IIS Web site and zone to remove, select the Sharepoint Intranet item you just created.

10. Under Delete IIS Web sites, select Yes.
11. Click OK.
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Transfer Files Larger than 100MB

By default, LIQUENT Sharepoint Services will only allow transfer of files that are under 100MB. If you need to
transfer files larger than 100MB, do the following:

1. Connect to the Sharepoint server as the local administrator:
a) If you run MSTSC, use the /admin switch.

2. Log on to the server as the service account user that you set up.
3. Go to the <installation_location>\DMSSharePointServices\ folder.
4. Open web.config file.

Use any XML editor for this (Notepad, for example).
5. Update maxRequestLength and maxAllowedContentLength parameters with the new limit value.

Please note that the value for maxRequestLength should be specified in KB but the value for
maxAllowedContentLength should be specified in bytes.

6. Save the web.config file.

Configure SharePoint DMS in Domain Manager

You only need do this Step if you intend to connect to one or more Sharepoint server(s). You will need to do this
Step on each  Liquent InSight Rendering server in the domain.

1. Launch Domain Manager.
2. In the Domain Manager, choose File > Configure DMSs.

The DMS Properties dialog box is displayed.
3. Click on the SharePoint tab.
4. Click Add. Provide the following information:

Field Description

Name: Any unique way to identify the Sharepoint site. This will be used later to configure the
login.

Site URL: The site URL, usually in the form of:http://{SP_Server_Name}/sites/
{Site_Name}

WebService URL: The URL to access the LIQUENT Sharepoint Services web site, usually in the form
of:http://machine_name:2861/DMSSharePointServices/
dmssharepointservices.svc

5. Click OK twice.
6. Click File > Save.
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Veeva Vault DMS
Configure the Veeva Vault

Create a Permission Set in Veeva Vault

To create a permission set in the Veeva vault:
1. If the rightmost item on the bar is Admin, click Admin.
2. On the bar, click Users & Groups.
3. On menu on the left, click Permission Sets.
4. In the top-right area of the Permission Sets page, click Create.
5. On the New Permissions Sets page, enter the information for the Parexel InSight Permissions

permission set.
6. Click Save.
7. On the Permissions Sets page, click Parexel InSight Permissions.
8. At the top of the Parexel InSight Permissions page, click Application.
9. In the top-right area of the page, click Edit.

10. In the Vault Actions section of the page:
a) On the API row, select All API.
b) On the Document row, select Download Document and Download Rendition.

11. Click Save.
Create a Security Profile in Veeva Vault

To create a security profile in the Veeva vault:
1. If the rightmost item on the bar is Admin, click Admin.
2. On the bar, click Users & Groups.
3. On menu on the left, click Security Profiles.
4. In the top-right area of the Security Profiles page, click Create.
5. On the New Security Profiles page, enter the information for the Parexel Service service profile.
6. Click Save.
7. On the Security Profiles page, click Parexel Service.
8. In the top-right area of the Parexel Service page, click Edit.
9. In the bottom-right area of the page, click Add and Existing Permission Set.

10. In the list click Parexel InSight Permissions, and click OK.
Create a User in Veeva Vault

To create a user in the Veeva vault:
1. If the rightmost item on the bar is Admin, click Admin.
2. On the bar, click Users & Groups.
3. On menu on the left, click Users.

4. In the top-right area of the Users page, click the Add a User icon:
5. On the Add User page, enter at least the required information for the InSight Service user.  
6. In the Primary Information section of the page, for Security Profile, click Parexel Service.
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7. Click Save.
8. Do one of the following:

• If are prompted to use the same credentials that are configured for the user in another vault, click Yes.
• If you do not see the prompt (because the user is not configured to use any other vault), type the required
information.

Creating a Role and Adding the Role to Lifecycle States in Veeva Vault

Perform this procedure for each lifecycle-state combination that a user needs to access from Liquent InSight
Rendering.

To create a role in the Veeva vault:
1. If the rightmost item on the bar is Admin, click Admin.
2. On the bar, click Configuration.
3. On menu on the left, under LIFECYCLE MANAGEMENT, click Lifecycles & Workflows. 
4. On the Lifecycles page, click General Lifecycle.
5. At the top of the General Lifecycle page, click Roles.
6. In the top-right area of the General Lifecyle page, Click Create.
7. On the Create Lifecycle Role page, enter the information for the Liquent InSight Service Role. For Add Default

Users When, select Starting a workflow and Creating a document.
8. Click Save.
9. Click on Liquent InSight Service Role. 

10. On the Liquent InSight Service Role page, click Default Rule.
11. Click Edit.
12. In the empty box, click the arrow on the right, and click the user InSight Service.
13. Select Default User.
14. Click Save.
15. Add the Liquent InSight Service Role role to the Approved state and to each other state for which you want to

create LIQUENT renditions. For each state:
a) At the top of the General Lifecycle page, click States.
b) Click the state, such as the Approved state.
c) At the top of the next page, click Security Settings > Edit.
d) On the Liquent InSight Service Role row, select View Document, Edit Fields, Download Source, Edit

Document, and Manage Viewable Rendition.
e) Click Save.

Create Veeva Rendition Types and Obtaining Veeva Rendition Names

In Veeva, an administrator creates rendition types for document renditions. If the rendition type is for a custom,
non-standard rendition, the administrator can add the rendition type to a document. The administrator can also
add a standard rendition type to a document type, if the standard rendition type is not by default added to all
standard document types.

To create a rendition type and obtain the rendition name that will use:
1. In the Veeva vault, if the rightmost item on the bar is Admin, click Admin.
2. On the bar, click Configuration.
3. On menu on the left, under DOCUMENT SETUP, click Rendition Types. 
4. In the top-right area of the Rendition Types page, click Create.
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5. On the Create Rendition Type page, for Rendition Type type parexel.

Note: InSight Rendering requires the rendition type parexel in the Veeva Vault repository that InSight
Rendering connects to. InSight Rendering uses this rendition type to reference the standard rendition.

6. Click Save.
7. To obtain the rendition name that Veeva generates from the rendition type, call Veeva Support.

Note: Veeva generates a unique rendition name from each rendition type. The rendition identifier values that
you create in InSight Rendering Administration must match the rendition names that Veeva generates.

8. Note the following:

• Editing a rendition type does not change the generated rendition name.
• Deleting a rendition type does not delete the generated rendition name.
• Recreating a deleted rendition type creates a new rendition name, not the name generated from the
rendition type before the rendition type was deleted. If you recreate a deleted rendition type, call Veeva
Support to get the new rendition name.

Associating Rendition Types with Document Types
You need to associate each rendition type with document types.

For instructions on how to do this, see Adding the Rendition Type to All Documents.

Adding the Rendition Type to All Documents

Assign the Parexel rendition type to every document type in the vault:

1. If the rightmost item on the bar is Admin, click Admin.
2. On the bar, click Configuration.
3. On menu on the left, under DOCUMENT SETUP, click Document Types.
4. Assign the parexel rendition type and give the InSight Service account Create Document Permission to every

document type in the vault. For each document:
a) On the Document Types page, navigate to and point to the document type.
b) Click the arrow to the right of the document type, and click Edit Details.
c) On the Edit Details page, for Rendition Types click parexel.
d) Click the Security link.
e) For Create Document Permission, click the arrow and add InSight Service.
f) Click Save.

Note: If you add a document type after performing the preceding procedure, remember to add the parexel
rendition type to the new document type.

Making Pre-existing Vault Documents Accessible from LIQUENT InSight Rendering

To enable InSight Rendering users to access Veeva Vault documents that were in their Vault before your Veeva
administrator created the InSight Service user, do either of the following:

• Ask Veeva Professional Services to share all documents with the InSight Service user, set as the default user
for the Liquent InSight Service role.

• If your Veeva administrator enabled the Library: Bulk Update feature for your vault, perform the following
procedure.

To enable users to access Veeva Vault documents from :

Configure a Document Managment System (DMS) Installing Liquent InSight Rendering 4.4

Liquent InSight Rendering 4.4 Installation Guide 29



1. If the rightmost item on the bar at the top of the page is Vault, click Vault.
2. On the bar, click Library or Documents, whichever is displayed.

(Which is displayed depends on your vault type).

3. Click the rightmost icon: 
4. Under PERFORM BULK ACTION click the fist option, for all documents.
5. On the Refine Selection page, click Next.
6. Under Edit Sharing Settings click Add Users to Role, and click Next.
7. On the Add Users to Role page:

a) For Users click InSight Service.
b) For Role click Liquent InSight Service Role.

8. Click Next.
9. On the Confirmation Page, click Finish.

Configure LIQUENT InSight Rendering

Configure a Veeva Vault DMS in Domain Manager

This configuration procedure is required only if you intend to connect to one or more Veeva Vaults. When
connecting to one or more Veeva Vaults, you must perform this procedure on each InSight Rendering server in the
domain.

1. Launch Domain Manager.
2. In the Domain Manager, choose File > Configure DMSs.

The DMS Properties dialog box is displayed.
3. Click the Veeva tab and click Add. Provide the following information:

Field Description

Repository
Name:

The name that identifies the Veeva Vault.

Site URL: The Veeva Vault URL in the format:https://<vault_name>.veevavault.com/
Rendition
Name:

The name that identifies the rendition type that Liquent InSight Rendering uses when
performing an operation that requires a rendition. This name must be:<rendition type
configured in your Veeva vault>__c.

Note: The characters before the terminating c are two underscores.

4. Click OK twice.
5. Click FileSave.
Configure a Veeva Vault Login

To enable Liquent InSight Rendering to communicate with a Veeva Vault DMS, perform the following on one 
InSight Rendering server in the domain.

1. Start Domain Manager. Use the shortcut on the desktop.
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2. On the Domain Manager Configuration tab, in the tree on the left, right-click Logins, and click New login.
3. On the New Login Properties dialog box, in the What field, type dms://veeva/<repository_name>.
<repository_name> is the name of a configured Veeva repository in the DMS configuration.

4. In the User field, type the InSight Service user ID.

Note: The user ID must be the same user ID configured for logging in to your network. The user ID must have
create, read, write, and delete privileges for all Veeva objects that Liquent InSight Rendering accesses.

5. In the Password field, type the password for the InSight Service user ID.

Note: The password must be the same password configured for logging in to your network.

Open Text DMS
Configure Open Text DMS on an InSight Rendering Server

Click Start > Run, type regedit, and press Enter. Create the following registry keys:
a) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip\Parameters

Entry Type of Value Value

TcpTimedWaitDelay DWORD 30

MaxUserPort DWORD 65534
b) HKEY_LOCAL_MACHINE\SYSTEM\SOFTWARE\Wow6432Node\LIQUENT\DMS\Livelink Intranet\
{OTCS_Server_Name}
Entry Type of Value Value

Cache DWORD 1

Cachesize DWORD 1000

Cachetimeout DWORD 300000

Configure an Open Text DMS in Domain Manager

This configuration procedure is required only if you intend to connect to one or more Open Text Content
Servers. When connecting to one or more Open Text Content Servers, you must perform this procedure on each
InSight Rendering server in the domain.

1. Launch Domain Manager.
2. In the Domain Manager, choose File > Configure DMSs.

The DMS Properties dialog box is displayed.
3. Click the Open Text tab and click Add. Provide the following information:

Field Description/Value

Repository Name: The Livelink service name (case sensitive).

Server Name: The HTTP server name.
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Field Description/Value

Session Name: The Database name.

Server Port Name: 2099

Web Application Name: The name of the Livelink Web application.

4. Click OK twice.
5. Click File.
6. Click Save.

Configure Logins

You only need to do this on one Liquent InSight Rendering server in the domain.

1. Launch Domain Manager (shortcut is on the desktop).
2. In Domain Manager, on the Configuration tab, in the tree on the left, select Logins. Right-click in the right

pane and select New login.
3. On the New Login Properties dialog box, supply the following information in the What field for each DMS you

intend to connect to (including the DMS location for eCTD Definition and Rules files):
a) SharePoint: dms://shpt/sharepoint_site_name
b) Documentum: dms://dctm/docbase_name (case sensitive)
c) Veeva Vault: dms://veeva/repository_name
d) OpenText: dms://llin/OpenText_repository_name
e) File System: \\machine\share

(usually, you do not need to supply this for the File System)
f) Supply the User and Password.

4. Click OK. Repeat for each login.
5. When completed, click File > Save.
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