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Linking plug-in (PDF) 1.9

Linking plug-in (PDF) is a desktop application which enables you to create and modify hyperlinks and bookmarks in
PDF documents.
Calyx RIM 7.3 is only supported by Linking plug-in (PDF) 1.9.

Linking plug-in (PDF) functionality (applies to all the repositories except the secured file system):

— Create a hyperlink in a PDF document that targets a page in the same document.
— Create a hyperlink in a PDF document that targets a page in an external document.
— Create comment-only links that serve as placeholders for links to documents that do not yet exist.
— Invoke Linking plug-in (PDF) from Calyx RIM to create and modify links for in-process renditions. For Calyx

RIM in-process renditions, you can create intra-assembly links to other documents or bookmarks in the assembly
tree.

— When creating a hyperlink, you can specify attributes for the link, such as the text color and the line width and
color of the bounding box.

— Open the target document for an external link if you need to determine the destination page in the target
document.

— Create and modify multiple bookmarks and hyperlinks using the Link and Bookmark Manager.
— Automatically create hyperlinks in a PDF based on search criteria using the Keyword Linker.

Linking plug-in (PDF) is installed as an Adobe Acrobat plug-in and is compatible with several versions of Acrobat.

Linking plug-in (PDF) 1.9

© Calyx™ 2023. 1 Linking Plug-in (PDF) 1.9 Online Help
Calyx.ai



Linking plug-in (PDF) Release Notes

Linking plug-in (PDF) 1.9 Release Notes

The Release Notes contain information about updated files, new functionality, and any open issues and workarounds
in this release of Linking plug-in (PDF) 1.9.
In the Release Notes are internal tracking numbers that are shown inside brackets [#####] in the first column of the
tables used to describe issues. These numbers are used by the Product Development and Technical Support teams to
track known and resolved issues.

The details in these Release Notes supersede all similar details that appear anywhere else in this release of the product
or its other documentation.

New in Linking plug-in (PDF) 1.9

Linking plug-in (PDF) 1.9 includes the following updates and enhancements.

New Brand: Linking plug-in (PDF)
Linking plug-in (PDF) was formerly Liquent SmartLink for PDF. The rebranded software user interface will appear
in this release:
— The headers and icons are updated with Calyx RIM name.
— The Save to InSight option is replaced with Save to Calyx RIM.
— The About page is replaced with About Linking plug-in (PDF), Calyx RIM name and a new copyright (Help >

About Third Party Plug-Ins > About Linking plug-in).
— For better user experience, the Link Stamper and Keywords dialog boxes are updated with Chromium-based

embedded browser.
— All navigation references now include the Calyx RIM name.

Functionality and Technology Not Supported
External links created using Linking plug-in (PDF) and Linking add-in (Word) are not supported in Calyx RIM
7.2.6 and later versions and in Calyx RIM 7.3. This issue will be fixed in future releases of Calyx RIM.

Functionality and Technology Removed
Starting with Linking plug-in (PDF) 1.9, SharePoint and Open Text Content Server (Livelink) Document
Management Systems will not be supported.

Linking plug-in (PDF) Release Notes
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Linking plug-in (PDF) 1.9 System Support Document (SSD)

Specifications for Linking plug-in (PDF) 1.9.

Linking plug-in (PDF) 1.9 supports Calyx RIM 7.3.

Operating System

Windows Operating System
Windows 10

Note: Linking plug-in (PDF) has been tested against en-US locale of the specified operating systems
and software.

Applications English Japanese

Adobe Acrobat (32 bit only)
— Adobe Acrobat Pro DC
— Adobe Acrobat Standard DC
— Acrobat Pro 2020
— Acrobat Standard 2020

Note: For in-process linking in Linking plug-in (PDF), the PDF document
must be opened using a supported version of Adobe Acrobat after it is
downloaded using any browser supported by Calyx RIM.

YES YES

Documentum REST Versions

— Documentum 16.4 REST Services
— Documentum 20.2 REST Services

Note: Check Documentum for content server compatibility. If you encounter any issues with
compatible content server versions, contact Client Enablement through Technical Support.

.NET Framework

.NET Framework is managed by Windows as a component of the operating system.

.NET Framework 4.5.2, and later CLR 4 versions

Linking plug-in (PDF) 1.9 System Support Document (SSD)
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Linking plug-in (PDF) User Guide

Use Linking plug-in (PDF)

Open Linking plug-in (PDF)

Use Linking plug-in (PDF) to create, modify, and remove hyperlinks in PDF documents.
Linking plug-in (PDF) options are available on the Acrobat menu, icons that appear on the Advanced Editing
toolbar, and in the Tools pane. All three methods provide access to the same Linking plug-in (PDF) functions:

— DMS Repository Configuration
— Update Link Character Encoding
— Save to Calyx RIM (available only for interface with Calyx RIM Publisher)
— Link and Bookmark Manager
— Link Stamper
— Linking plug-in Help

Linking plug-in (PDF) User Guide
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Figure 1: Linking plug-in Help menu

Figure 2: Linking plug-in toolbar

Figure 3: Tools pane

Access Linking plug-in (PDF)

Provide access to Linking plug-in (PDF) to start working with hyperlinks in PDF documents.
To display Linking plug-in (PDF) by default:

1. On the Adobe Acrobat menu, click the Tool tab.

Linking plug-in (PDF) User Guide
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2. Scroll down.
3. Under the Linking plug-in (PDF) instance, click Add.

The Linking plug-in (PDF) icon will be added to the Tools pane.

Add Linking plug-in (PDF) Toolbar Icons

Add Linking plug-in (PDF) Toolbar Icons: Acrobat

After the installation of Linking plug-in (PDF),  add Linking plug-in (PDF) icons to the Acrobat toolbar for quick
access to the Linking plug-in (PDF) tools.

Prerequisites

Depending on the Acrobat version, the menu items names may vary.

To add Linking plug-in (PDF) icons to the Acrobat toolbar:
1. Right click on the Acrobat toolbar > Сustomize Quick Tools or select View > Show/Hide > Toolbar Items

> Сustomize Quick Tools.
2. Select and expand Linking plug-in .
3. Click the plus sign button next to the arrow to move the Linking plug-in (PDF) icons to the Tools to show in

toolbar pane.

Linking plug-in (PDF) User Guide

© Calyx™ 2023. 6 Linking Plug-in (PDF) 1.9 Online Help
Calyx.ai Add Linking plug-in (PDF) Toolbar Icons



Example

4. Click Save.
The Linking plug-in (PDF) icons are now available in the Acrobat toolbar.

Linking plug-in (PDF) Icons

Graphical elements used in the Linking plug-in (PDF) interface.

Icon Description

Document Management System (DMS) configuration

Linking plug-in (PDF) User Guide
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Icon Description

Calyx RIM connection

Link Stamper, link editor

Link manager

Browse

Link

Next

Previous

Refresh

Unlink

Configure a Document Management System

Configure Linking plug-in (PDF) to work with Documentum document management system (DMS).

Prerequisites

To configure Linking plug-in (PDF) with your document management system, you must use the properties specific
to the DMS.

To configure DMS:
1. In Linking plug-in (PDF), click DMS Repository Configuration.

The DMS Properties window appears.
2. On the DMS tab, click Add.
3. Specify your DMS properties.

See your DMS system guide for more details.
4. Click OK.
5. To save your property settings and continue working in the DMS Properties window, click Apply.

Action Option

To save your property settings and close the DMS Properties window: Click OK.

Linking plug-in (PDF) User Guide
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Action Option

To close the DMS Properties window without saving any added or modified
properties:

Click Cancel.

DMS Properties: Documentum

Appropriate Documentum values must be used to set up a repository to work with Linking plug-in (PDF).

Prerequisites

To access a Documentum system, you must have established a Windows Domain property on the User's Info page
in the Documentum Administrator. You must be able to log on to your Documentum system to configure the
repository.

To configure the repository:
1. In Linking plug-in (PDF), click DMS Repository Configuration > DMS Properties:

Note: The Documentum repository name configured here must match the Repository Name in Calyx RIM
Technical Administration.

2. To modify properties for a selected repository , click Edit.
3. Click Apply.
4. Click OK.

Open Linking plug-in (PDF) from Calyx RIM

When you edit an assembly, you can add or modify links in Acrobat using Linking plug-in (PDF).

Prerequisites

Linking plug-in (PDF) must be installed on your desktop to open it when using Calyx RIM. Successful installation
of Linking plug-in (PDF) creates new toolbar icons on the Acrobat menu bar.

To add or modify links:
1. Right-click on an assembly folder or document.
2. Select Prepare Documents for Linking.

The documents are prepared for links. This runs as a job request.
3. In Calyx RIM , click Edit Document Links.
4. On a document, click the Edit Links option.

The rendition opens in Acrobat and Linking plug-in (PDF) is automatically enabled.

Linking plug-in (PDF) User Guide
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Linking plug-in (PDF) Hyperlinks

Use Linking plug-in (PDF) to create hyperlinks to point to documents or to specific elements within a document.
The types of links you can create depends on the source and destination of the documents.
— a file system
— a DMS
— an in-process PDF rendition from Calyx RIM

When the source document for a link is in the same assembly as the destination document, the target can be an
extract (bookmark), leaf, or document. When the source document for a link is in a different assembly than the
destination document, the target can only be leaf.

If the link target is a native leaf or a bookmark within a leaf of a previous sequence, the link will resolve to the first
page of the document regardless of which page or bookmark you have selected as the target.

When text across multiple lines are used to create links, limitations in Adobe PDF require you to create multiple
links. These links show up multiple times in the Link Inspector query, although they represent one link. Care must
be taken when creating cross-references to avoid multiple page stamps.

Depending on the location of the PDF rendition, the linking option can be active or inactive on the application
interface.

Link Types

The types of links and the source and destination of the documents.

The following are the document sources:
— a file system
— a DMS
— an in-process PDF rendition from Calyx RIM

Link type PDF opened from

Internal link to a page within the same PDF. Secure File System/DMS only.

External link to a page in another PDF. Secure File System/DMS only.

A comment link that serves as a placeholder. Secure File System/DMS or Calyx RIM.

A link to another PDF within an Calyx RIM assembly. Calyx RIM only.

Note: If the link target is a native leaf or a bookmark within a leaf of a previous sequence, the link will resolve to the first
page of the document regardless of which page or bookmark you have selected as the target.

Linking plug-in (PDF) User Guide
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Note: Starting with Linking plug-in (PDF) 1.8 , the create and update support for post-publishing links is discontinued.

Microsoft Defender SmartScreen

Microsoft Defender provides protection from malicious sites and downloads.
Microsoft Defender SmartScreen blocks downloads that it recognizes to be unsafe and notifies you of the same.

If you experience performance issue when checking out a document from Calyx RIM or when navigating to an
external link, you can try disabling the Microsoft Defender SmartScreen.

Note: It is not recommended to access untrusted web sites or download files from suspicious sources when Microsoft Defender
SmartScreen is turned off.

Modify the Microsoft Defender SmartScreen Settings

Modify the Microsoft Defender SmartScreen setting to enable or disable its security capability.

Note: Disabling Microsoft Defender SmartScreen can make your computer vulnerable to unathorized access. It is
recommended to have an alternative security solution in place before disabling Microsoft Defender SmartScreen.

To modify the Microsoft Defender SmartScreen setting:
1. In Microsoft Edge Settings > Privacy, search and services > Security, find Microsoft Defender

SmartScreen.
2. Turn Microsoft Defender SmartScreen on or off.

Link Stamper

Use Link Stamper to create or modify different types of links to reference a page in the same or another document.
You can also create link placeholders for future reference.

To create links using Link Stamper:
1. Click Linking plug-in > Link Stamper or Edit Link to open Link Stamper
2. Select text in the PDF document by creating a bounding box.

Option Action

To define the link settings in Link Stamper: Use the Link Stamper dialog box or the previously
defined settings.

To create a Linking plug-in (PDF) hyperlink
immediately with the settings defined in
the Link Stamper dialog box:

Create the bounding box with the Fast Linking option
selected.

Linking plug-in (PDF) User Guide
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Option Action

To quickly create multiple links to the
same target destination with the same
link appearance attributes:

Click the Link button after drawing the bounding box
to create a link.

Note: It is not recommended to click the Link button
after drawing the bounding box to create a link.

Note: Selecting Keep Linking plug-in on top of Acrobat keeps the Link Stamper dialog box on top of Acrobat as
you create and edit links. Otherwise, the dialog box will minimize and restore itself each time it is used.

Linking plug-in (PDF) User Guide

© Calyx™ 2023. 12 Linking Plug-in (PDF) 1.9 Online Help
Calyx.ai Linking plug-in (PDF) Hyperlinks



Example

3. Repeat steps 1 to 2 to create multiple links.
The Link Stamper dialog box retains the previously defined settings for further use.

4. To save your hyperlinks to the PDF, click File > Save in Acrobat.

Set Link Attributes

Use Linking plug-in (PDF) to define hyperlink characteristics.
You can specify the destination magnification, the color of the hyperlink text, and the thickness and color of the
hyperlink bounding box.

Linking plug-in (PDF) User Guide
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1. In the Link Stamper dialog box under Appearance, define the following:

Option Action

To set magnification: In the Magnification drop-down list, select the magnification at
which the destination page is viewed. The default
magnification is Inherit Zoom.

To set the thickness of the
bounding box lines:

In the Box Width drop-down list, select the thickness of the
bounding box lines.

To hide the bounding box: In the Box Width drop-down list, select Invisible.

To set the color for the bounding
box lines:

In the Box Color drop-down list, select the color for the
bounding box lines.

To set the color for the hyperlink
text:

In the Text Color drop-down list, select the color for the
hyperlink text. For non-OCR scanned documents, you cannot
change the color of the hyperlink text.

2. Click the Link icon to create or modify a hyperlink.

Create an Internal Link

Use Link Stamper to create a link to navigate to a page in the same document.

To create a link to a page within a document:
1. Open Link Stamper.
2. For the text to create a hyperlink, click-and-drag the pointer to create a bounding box around that text.
3. In the Link Stamper dialog box, do the following:

Option Action

To create an internal link: Select Internal.

To enter the target page in this PDF document: Use PDF Page # box.

To specify the magnification, text color and bounding box: Use the attributes under Appearance.

To create an internal hyperlink with the attributes defined: Click the Link icon.

Linking plug-in (PDF) User Guide
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Example

4. Repeat steps 1 to 3 to create multiple links.
The Link Stamper dialog box retains the previously defined settings for further use.

5. To save your hyperlinks to the PDF, click File > Save in Acrobat.

Create an External Link

An external link is a hyperlink that points to a page in another PDF document.
Use the Link Stamper to create a link to navigate to a page in another document.

To create a link to navigate to a page in another document:
1. Open Link Stamper.
2. For the text to create a hyperlink, click-and-drag the pointer to create a bounding box around that text.
3. In the Link Stamper dialog box, select External and do the following:

Option Action

To specify the target PDF document: In the Link To drop-down list, click the Browse button to
locate the target document. If the target document
resides in a DMS repository, you will be prompted to log
on.

Linking plug-in (PDF) User Guide
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Option Action

To select a new target document: Select document to link to, click . Locate and select a
document in the Select File.

If there are more than one version of
the document in the DMS:

Click the Select Version icon: .Choose the version and
click OK.

Note: Although the Link To box displays the full path to the
target documents, the links are created with relative paths.

To enter the target page in the target
PDF document:

Use the PDF Page # box.

To view the target PDF document and
locate the target page:

Click Open target.

Linking plug-in (PDF) User Guide
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Option Action

To set magnification, text color, and
bounding box attributes.

Use the attributes under Appearance.

4. To create an external hyperlink with the attributes defined, сlick the Link icon.
5. Repeat steps 1 to 4 to create multiple links

The Link Stamper dialog box retains the settings from the previously created hyperlink for further use.
6. To save your hyperlinks to the PDF, click File > Save in Acrobat.

Create a Comment Link

Use a comment link to create a placeholder for future document reference.
A comment link serves as a placeholder for a link to a document that does not yet exist. The comment link is a means
for reminding publishers that a link must be created once the document exists.

1. Do one of the following:

Condition Action

If you opened a PDF from the file system or
DMS,

Open Link Stamper .

If you used link editing for an in-process PDF
rendition from Calyx RIM, the log on prompt
appears after Acrobat opens.

Log on to maintain a connection between
Linking plug-in (PDF) and Calyx RIM. Type your 
Calyx RIM User Name and Password, and then
click OK.

2. For the text to create a hyperlink, click-and-drag the pointer to create a bounding box around that text.
3. In the Link Stamper dialog box, do the following:

Linking plug-in (PDF) User Guide
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Option Action

To enter an appropriate
comment to remind publishers
of the link that needs to be
created once the target
document exists:

Select Comment > Link To.

To specify the magnification, text
color, and bounding box:

Use the attributes under Appearance.

Note: If you invoked link editing for an in-process PDF rendition
from Calyx RIM, the link appearance attributes do not appear in
the Linkin plug-in dialog box. The comment link is automatically
created with blue text and a red bounding box. During the
publishing process, the appearance of the link is changed to the
link attributes defined in the Publishing Settings in Calyx RIM.

4. To create a comment hyperlink with the attributes defined, сlick the Link icon.
5. Repeat steps 1-4 to create multiple steps.

The Link Stamper dialog box retains the previously defined settings for further use.
6. To save your hyperlinks, do one of the following:

Condition Action

If you opened a PDF from the file
system or DMS

Click File > Save in Acrobat.

Linking plug-in (PDF) User Guide
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Condition Action

If you invoked link editing for an in-
process PDF rendition from Calyx
RIM

a. Choose Linking plug-in > Save to Calyx RIM. If you are
prompted to log on to Calyx RIM, type your Calyx RIM
User Name and Password, and then click OK.

b. When documents are saved, click OK.

Intra-Assembly Links for Calyx RIM In-Process Renditions

If you invoked link editing for an in-process PDF rendition from Calyx RIM, you can use Link Stamper to create
assembly links. An assembly link is a link to another document or bookmark that appears in the same Calyx RIM
assembly tree as the in-process rendition you are editing.

By default, Linking plug-in (PDF) displays the lifecycle Working View in the Link Stamper dialog box.

You can create:

— In-process links to intra-assembly documents.
— Lifecycle links to application working view leafs that have published output location paths populated in the

submitted view.

Warning: Bookmarks should not be added, modified, or deleted when Linking plug-in (PDF) is invoked from in-
process linking. When  Linking plug-in (PDF) is opened from Calyx RIM for in-process linking, you are working
with a copy of the PDF and only hyperlink information is saved to the Calyx RIM database. Bookmark information
is not saved in the database during in-process linking. Because you are working with a copy of the document, any
changes made to bookmarks are not saved to the original PDF.

Create Intra-Assembly Links for Calyx RIM In-Process Renditions

Create a link to another document or bookmark that appears in the same Calyx RIM assembly tree as the in-process
rendition you are editing.

To create intra-assembly links:
1. In Calyx RIM, select the document with links to modify.
2. Open the in-process rendition in Acrobat.

The Calyx RIM log on prompt appears.
3. Log on to establish connection between Linking plug-in (PDF) and Calyx RIM
4. Type your Calyx RIM User Name and Password.
5. Click OK.
6. For the text to create a hyperlink, click-and-drag the pointer to create a bounding box around that text.
7. In the Link Stamper dialog box, do the following:

a) Select Calyx RIM (this is selected by default).
b) Select a target document or a target bookmark in the assembly tree.

Linking plug-in (PDF) User Guide
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c) Click OK.
d) If necessary, click the Refresh icon to refresh the assembly tree from Calyx RIM.

Note: When targeting a document, you cannot use the Open Target button to view the document in the assembly.
When targeting a bookmark, the PDF Page # field is not used by Linking plug-in (PDF). The presence of a parent
leaf is not required.

e) Click the Link icon to create the assembly link.
The assembly link is created with blue text and a red bounding box. When the assembly is published, the
appearance of the link is changed to the link attributes defined in the Publishing Settings in Calyx RIM. This
is why no link appearance attributes appear in the Linking plug-in (PDF) dialog box.

8. Repeat steps 1-7 to create multiple links.
The Link Stamper dialog box preserves the previously defined settings so you can create multiple links with
minimal or no changes.

9. To save the hyperlinks to the in-process rendition, the changes must be saved to Calyx RIM.

In-Process Linking and Sequence Assemblies

Create links between assembly elements when working on sequence assembly.

In Linking plug-in (PDF), if a sequence is locked and added to a lifecycle before it is published, the resulting
Submitted view of an assembly will not include the output location for leaf elements. However, when a sequence is
published (electronic output channel, leaf elements), the output location for leaf elements will be included in the
Sequence view.

As a result, for leaf elements on which leaf operations have been performed in subsequent sequences, in-process
links to those leaf elements must be targeted using the Link Inspector query and the Sequence view. Attempts to
target in-process links to those leaf elements with Linking plug-in (PDF) results in the error Target leaf in
the other assembly should have an output path.

Note: Calyx RIM 7.3 is only supported by Linking plug-in (PDF) 1.9 for in-process linking.

Save In-Process Rendition Changes to Calyx RIM

Create links for Calyx RIM in-process PDF rendition and save changes to the Calyx RIM database.

To save the link changes:
1. Choose Linking plug-in > Save to Calyx RIM, or click Save to Calyx RIM in the Advanced Editing

toolbar.
If you are prompted to log on to Calyx RIM, type your Calyx RIM User Name and Password, and then
click OK.
The appropriate message will be displayed indicating that your linking changes are uploaded to Calyx RIM.

2. When documents are saved, click OK.
The PDF document closes. Check Job Request to confirm the documents were saved successful.

Linking plug-in (PDF) User Guide

© Calyx™ 2023. 20 Linking Plug-in (PDF) 1.9 Online Help
Calyx.ai Linking plug-in (PDF) Hyperlinks



Bookmarks and In-Process Links

When Linking plug-in (PDF) is opened from Calyx RIM for in-process linking, you are working with a copy of the
PDF and only hyperlink information is saved to the Calyx RIM database. Bookmark information is not saved in the
database during in-process linking.

Because you are working with a copy of the document, any changes made to bookmarks are not saved to the original
PDF.

Note: Bookmarks should not be added, modified, or deleted when Linking plug-in (PDF) is invoked from in-process
linking.

Manage Hyperlinks

With Linking plug-in (PDF), you can manage hyperlinks the way you need.
You can modify, replace, or remove existing Linking plug-in (PDF) hyperlinks.

In the Link Stamper dialog box, locate the hyperlinks you want to modify by using the Previous and Next
buttons to navigate through the links in your PDF.

Resize or Reposition Hyperlinks

Modify links for its size and position of the bounding box, and link attributes.
The links you create with Link Stamper are Adobe Acrobat links, so you can use Acrobat Link Tool to make changes.
To resize or reposition a Linking plug-in (PDF) hyperlink, you must use Acrobat Link Tool.

To modify the link attributes:
1. In Acrobat, choose Tools > Advanced Editing > Link Tool, or click the Link icon in the Advanced Editing

toolbar.
2. Move the pointer over the bounding box and do one the following:

Option Action

To move the bounding box: Position the arrow anywhere in the box, and drag it to the new
location.

To resize the bounding box: Drag any corner point until the box is the size you want.
If the bounding box now surrounds additional text and the text color needs to be modified, modify the Attribute
Settings using the Link Stamper dialog box.
If you moved the bounding box and the color of the previously surrounded text needs to be modified, use Acrobat
TouchUp Text Tool to adjust the color of the text.

3. To save your changes to the PDF, click File > Save in Acrobat.
Calyx RIM in-process rendition changes must be saved to Linking plug-in (PDF).
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Modify Hyperlink Attributes Values

Values of hyperlink attributes can be modified using Link Stamper.

To modify hyperlink attributes value:
1. Select the link you wish to modify by clicking the link or using the Previous and Next buttons.
2. In the Link Stamper dialog box, make changes to the link attributes value as needed.
3. Click the Link button.
4. To save your changes to the PDF, click File > Save in Acrobat.

Calyx RIM in-process rendition changes must be saved to Calyx RIM. See Save In-Process Rendition Changes to
Calyx RIM.

Replace a Hyperlink

You can use Link Stamper to replace a hyperlink by drawing a new bounding box over the existing link.

To replace a Linking plug-in (PDF) hyperlink:
1. Identify the link you wish to replace and draw a new bounding box over the existing bounding box.
2. In the Link Stamper dialog box, modify the link attributes as needed.
3. Click the Link button.
4. To save your changes to the PDF, click File > Save in Acrobat.

Calyx RIM in-process rendition changes must be saved to Calyx RIM.

Remove a Hyperlink

You can use Link Stamper to remove a hyperlink that you have created.

To remove a hyperlink:
1. Select the link you wish to remove by clicking the link or using the Previous and Next buttons.
2. In the Link Stamper dialog box:

Condition Action

If the color of the hyperlinked text is different
from the rest of the text

Use the Text Color drop-down box to change the
hyperlinked text color to match the color of the
rest of the text.

If the text color is not listed in the Text Color
drop-down box

Use Acrobat’s TouchUp Text Tool to change the
text color.

3. Click the Unlink button. To save your changes to the PDF, click File > Save in Acrobat.
Calyx RIM in-process rendition changes must be saved to Calyx RIM. See Save In-Process Rendition Changes to
Calyx RIM.
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Link and Bookmark Manager

Use Link and Bookmark Manager to view, modify or delete bookmark and hyperlink properties.
Link and Bookmark Manager scans your PDF to identify the bookmarks and hyperlinks in a PDF document and
exports their properties to a CSV (comma-separated values) file.

You can use the CSV file to modify the bookmarks and hyperlinks properties. The updated CSV can be imported
back into Link and Bookmark Manager to use the latest properties.

Export and Import Bookmarks and Hyperlinks

Use Linking plug-in (PDF) to load all the bookmarks and hyperlink properties from a PDF into the Link and
Bookmark Manager, and then export the properties to a CSV file for editing.

Note: You cannot export a CSV file for bookmarks, links, or keywords during in-process linking.

To export the bookmarks or hyperlinks properties to a CSV file:
1. Open the Link and Bookmark Manager.

The Link and Bookmark Manager dialog box opens.
2. Under Search, select Bookmarks, Links, or both options.

For Calyx RIM in-process PDFs, you can select the Bookmarks option to include them in your search, but you
cannot edit the contents of an in-process rendition.

3. Click Reload.
The dialog box displays the properties for bookmarks, hyperlinks, or both.

4. Click Export.
5. In the Save As dialog box, specify the save location and name for the CSV file, and then click Save.
6. Click OK.

Modify Bookmark and Hyperlink Properties

Use the CSV (comma-separated values) file to add, modify, or remove bookmarks and hyperlinks.
After exporting the bookmark and hyperlink properties to a CSV file, open this file to add, modify, or remove
bookmarks and hyperlinks.

To modify bookmark and hyperlink properties:
1. Do one of the following:

Description Action

To add a bookmark or hyperlink: Insert a row in Excel and define the properties.

To modify a bookmark or hyperlink: Edit the attribute values in an existing row in Excel.

To delete a bookmark or hyperlink: Delete the row from Excel.

Note: Do not edit bookmarks for Calyx RIM in-process PDFs. You cannot edit the contents of an in-process rendition.
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2. Save file.
3. Import the modified CSV file.

See Import the CSV File to Update a PDF.

Links and Bookmarks CSV File

The columns in the CSV file correspond to the columns in the Link and Bookmark Manager dialog box. Each
column in the CSV file represents an attribute of the bookmarks and links.

Attribute Description

s.page The page on which a hyperlink appears in the PDF. This value is 0 for bookmarks.

title The bookmark or hyperlink text. You cannot modify the text in the PDF by changing
this value. This is an information-only column.

type Whether the line item is a Bookmark or a Link.

action The action type of the bookmark or hyperlink.

d.file The destination file path and name, if the link is to another PDF.

d.page The destination page, if the link is to another PDF.

fit The magnification at which the destination page is viewed. The default magnification
is Inherit Zoom, which is represented by XYZ.

border style The bounding box border width, if not invisible.

border color The bounding box border color, if not invisible.

text color The color of the bookmark or hyperlink text.

bm.level The bookmark hierarchy level.

left, top,

right, bottom

Device-dependent coordinates determining the height, width, and position of a
hyperlink.
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Attribute Description

annot.left,

annot.top,

annot.right,

annot.bottom

Device-independent coordinates determining the height, width, and position of a
hyperlink.

Import the CSV File to Update a PDF

Use the Import function in Linking plug-in (PDF) to import a CSV file that was previously exported for the purpose
of updating the bookmarks and links in a PDF document.

Note: You cannot import a CSV file for bookmarks, links, or keywords during in-process linking.

1. Using the Link and Bookmark Manager, under Import, specify the Output location where the
exported CSV is stored.

2. Click Import.
The imported bookmarks and hyperlinks appear in the Link and Bookmark Manager dialog box. These
bookmarks and links are now present in the PDF, but are not preserved until you save the document.

3. To save your changes, click File > Save in Acrobat.

Bulk Edit of Destinations

Perform mass editing of destination files and pages using the bulk edit .
While all of the properties in the CSV file are editable, the most common use for this feature is the mass editing of
destination files and pages (d.file and d.page) for existing links.

With the Link and Bookmark Manager and the CSV file in Excel, you have a convenient method for adjusting the
destination target for multiple links in a PDF file.

Add Bookmark

In post-publishing output and PDF source documents, use the Add command in the Link and Bookmark Manager
to add new internal or external bookmarks in a PDF document. The Add Bookmark dialog provides options for
setting the destination and properties for the bookmark.

During in-process linking, any bookmarks added to the temporary PDF will not be committed to the Calyx RIM
database.
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Add Bookmarks

Create bookmarks to quickly navigate to specific pages in a document.

To add bookmark:
1. In Acrobat, open the PDF file in which you want to add bookmarks.
2. Select Linking plug in > Linking plug-in > Link and Bookmark Manager 
3. On the Link and Bookmark Manager window, select Bookmarks and click Reload.
4. In the bookmark list, select a bookmark where the new bookmark will be added.
5. Click Add.

Add Bookmark dialog appears.
6. In the Add Bookmark dialog, select the Destination and Properties attributes for the new bookmark.

Example

7. Click OK.
The bookmark is added.

8. Click Save in the Acrobat toolbar to save your changes.
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Add Bookmark Attributes

You can specify the following attributes using the Add Bookmark dialog when creating bookmarks with Linking
plug-in (PDF).

Attribute Description

Bookmark Name The unique name of the bookmark.

Destination Description

Internal An internal bookmark link in the current document.

External An external bookmark link, outside of the current
document Eternal is the default setting.

Link to The location of the external bookmark link.
(External only)

PDF Page # The page number of the bookmark link. (Internal or
External)

Properties Description

Magnification The magnification size of the bookmark in the
document. Inherit Zoom is the default setting. The
usual zoom setting for Acrobat are available:
— Inherit Zoom (This is the default setting.)
— Fit Page
— Fit Width
— Fit Visible
— Custom
— Fit Height
— Fit Window
— Fit Window Height
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Properties Description

Text Color The color for the bookmark text.
— Black (This is the default setting.)
— White
— Gray
— Blue
— Magenta
— Red
— Yellow
— Green
— Cyan

Open Preference The preference for opening the bookmark link,
either in the current window or in a new window.
This option is available for External bookmark links
only.
— Window set by user preference (This is the

default setting.)
— New window
— Existing window

Path Preference The path preference for External bookmarks.
— Relative (This is the default setting.)
— Absolute

Insert location Where the added bookmark will be inserted,
relative to the selected bookmark.
— Above selected bookmark (This is the default

setting.)
— Below selected bookmark
— Child to selected bookmark

Distribute Bookmarks

In post-publishing output and PDF source documents, the Distribute command in the Link and Bookmark
Manager enables you to distribute bookmarks in a PDF document to another file, or to a group of files in a folder.

The Distribute bookmarks dialog provides options for selecting the destination files or folders for the bookmarks.
The Distribute bookmarks functionality is for use with PDFs stored on a file system.
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Distribute Bookmarks

The Distribute bookmarks functionality enables you to copy bookmarks from a document to other documents.
Use the Distribute bookmarks dialog to select the destination files or folders for bookmarks.

Files included in the Distribute bookmarks dialog must be unique. A PDF file must not be added twice.

To distribute bookmarks:
1. In Acrobat, open the PDF file that contains the bookmarks and choose Linking plug-in > Link and Bookmark

Manager.
2. In the Link and Bookmark Manager dialog, select Bookmarks and click Reload.
3. In the Link and Bookmark Manager dialog, select bookmarks..

Use the Shift key or Ctrl key to select contiguous or non-contiguous bookmarks in the Link and
Bookmark Manager dialog.

4. Click Distribute.
5. In the Distribute bookmarks dialog, do the following:

Option Action

To browse your system and select
PDF files:

Click Add Files.The selected PDF files appear in the Files to
receive bookmarks list of the Distribute bookmarks dialog.

To browse your system and select
folders:

Click Add Folder. The PDF files from the selected folders
appear in the Files to receive bookmarks list of the Distribute
bookmarks dialog.

To remove the files from the list in
the Distribute Bookmarks dialog:

Click to select a file. Click and use CTRL to select multiple
files, click Remove Files.

To update/overwrite an existing
bookmark in a receiving file when
a distributed bookmark has the
same name:

Select the Use new bookmark when names are the same
option. If this option is not selected, the existing bookmarks
in the receiving files with the same name will not be not
updated or overwritten by the distributed bookmark.
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Example

6. To merge the selected bookmarks into the recipient files, click Write Bookmarks.
— A progress bar shows the status of the process.
— The bookmarks are distributed to the selected files and the Distribute Bookmarks dialog closes.
— Linking plug-in (PDF) adds the bookmarks at the top of the bookmark tree structure in the recipient PDF

files.
7. Click OK in the confirmation dialog.

Modify Hyperlinks with Link and Bookmark Manager

Use Link and Bookmark Manager to modify hyperlinks.

Note: With Link and Bookmark Manager, you can only modify hyperlinks and not bookmarks.

To modify hyperlinks with a link:
1. In the Link and Bookmark Manager dialog box, click the hyperlink you want edit, click Edit Links.

The Linking plug-in (PDF) Link Stamper opens.
2. Do one of the following:

Option Action

To retarget a link: Use the options in  Linking area of the Link Stamper dialog
box. See Create an Internal Link, Create an External Link,
Create a Comment Link.
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Option Action

To make changes to a hyperlink: Modify the attribute values of the hyperlinks using the Link
Stamper dialog box.

3. To save your changes, do one of the following:

Condition Action

If you opened the PDF from a file
system or DMS

Click File > Save in Acrobat.

If you invoked link editing for an in-
process PDF rendition from Calyx
RIM

See Save In-Process Rendition Changes to Calyx RIM.

The modified hyperlinks are saved.

Delete Hyperlinks with Link and Bookmark Manager

Use Link and Bookmark Manager to delete unwanted hyperlinks.

Note: With Link and Bookmark Manager, you can delete only hyperlinks and not bookmarks.

To delete hyperlinks:
1. In the Link and Bookmark Manager dialog box, click a hyperlink to select it or use Shift or Ctrl keys to

select multiple contiguous or noncontiguous hyperlinks.
2. Click Delete Links.
3. Click Yes to confirm.

The links are removed from the PDF document.
4. To save your changes, do one of the following:

Condition Action

If you opened the PDF from a file system or DMS: Click File > Save in Acrobat.

If you invoked link editing for an in-process PDF
rendition from Calyx RIM:

Save your in-process rendition changes
to Calyx RIM.

Keyword Linker

Use the Keywords Autolinking command on the Link and Bookmark Manager window to automatically create
hyperlinks based upon the results of keyword searches in a PDF document.
Keyword searches and hyperlinks created using Keywords in Linking plug-in (PDF) are case-sensitive.

— The Export and Import buttons are not available when you invoke Linking plug-in (PDF) from Calyx RIM for
in-process linking.

— You cannot export and import a CSV file for in-process PDFs. However, you can use the CSV functionality for
authoring PDFs.
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Keywords Autolinking and Multi-Word Links

The Keywords Autolinking function can alter multi-word links in a document when those links include a keyword
specified for automatic linking.

When you apply Keyword Autolinking to a text document that contains multi-word links, Linking plug-in (PDF)
finds all words equal to the specified keyword and makes those words hyperlinks. When a keyword is contained in an
existing multi-word link, the multi-word link is removed and a link for the keyword alone remains.

Table of contents items and other multi-word links in a document can be affected. If the keyword is found in the
document text and it is already a link, the keyword linking action will delete that link and set a new link for the
keyword.

If the keyword is found in the table of contents as part of a multi-word link, then the original hyperlink is removed
and a new link is set on the specified keyword. As a result, only the single keyword is an active hyperlink, the rest of
the multi-word TOC entry is not linked.

Keyword Search Rules

This table lists the search parameters that you can use, and is followed by examples of search rules and their results.

Before you can create hyperlinks in a PDF with the Keyword Linker, you must define the search conditions for which
links will be created.

Keyword searches are case-sensitive.

Parameter Description

* Matches any sequence of characters, including zero.

? Matches exactly one character which can be anything.

[abc] Matches exactly one character which is a, b, or c.

[a-f] Matches anything from a through f.

[^a-f] Matches anything except a through f.

[-_] or [^-_] [-_] matches - or _ whereas [^-_] matches anything else. (The - is non-special if it
occurs immediately after the opening bracket or ^.)
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Parameter Description

[a^] Matches an a or a^. (The ^ is non-special if it does not occur immediately after the
opening bracket.)

\*, \?, \[, \], \\ Match the single characters *, ?, [, ], \.

All other characters are non-special and match themselves.

The search string * *Tab?? * * * will match and create a link around the text 1.1.1 Table One a
Study or the Table is nice or a Tabby cat is purring but will not match insert tab
here.

The search string see study *report* [0-9][0-9][0-9][0-9][0-9][^0-9]?? *table* *
will match the text see study reporting 12345 table 2 or see study report 55446ABC
table 1 or See study pre-report 43253A23 table 12.2.1 but will not match See study
123 or See study report 234234512 or see study 12345A tabular summary A.

The search string table will match the text table but will not match the text table. You must use table* to
match punctuation.
Create Keyword Search Rules

Create search rules list to use it for auto-linking keywords.

To create a search rules list:
1. In the Link and Bookmark Manager dialog box, click Keywords Autolinking.

The Keywords dialog box appears.
2. Click Add New.
<new> appears in the Keyword box and the rules list.

3. In the Keyword field, define a search parameter.
4. Select a link type to create from one of the following: Internal Link, External Link, Comment Link, Calyx

RIM Link.
5. Define values for the link and make changes as necessary in the attribute settings.

Option Action

For external links: Open the target document.

For Calyx RIM in-process links: Open the assembly tree to select target
documents or bookmarks.

6. Click Apply.
The search parameter appears in the rules list box.

7. Repeat these steps to add multiple search conditions.

Modify Keyword Search Rules

Change the rules list attributes if needed.

To modify the search rules:
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1. Click the search parameter to modify in the rules list.
2. Do any of the following:

Option Action

To redefine the search parameter: Use the Keyword box.

To redefine the type of link and link
attributes:

Redefine the type of link and link attributes as you
would using Link Stamper.

3. Click Apply.

Save and Reuse Keyword Search Rules

Save a rules list for reuse on PDF documents.

To save rules list:
1. Create a rules list.
2. Click Export to save the rules list as a CSV file.
3. Click Import to import the CSV file and reuse the rules list.

Remove Keyword Search Rules

You can delete one search rule or all the search rules from the list if needed.

To delete the keyword search rules from the rules list:
1. Select a search rule and click Delete.
2. To remove all the search rules , click Clear.

Example

Create Links Based on Search Criteria

Use Link and Bookmark Manager to create and modify hyperlinks.

Prerequisites

You must have a predefined search rules list to create links based on search criteria.

To create hyperlinks:
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1. Open Link and Bookmark Manager.
2. Add your search criteria rules list.

To create a search criteria list, see Create Keyword Search Rules.
3. Сlick Search.

The search results appear in the Link and Bookmark Manager dialog box. These links are now present in the
PDF, but not preserved until you save the document.

4. If necessary, edit the hyperlinks in the Link and Bookmark Manager dialog box.
5. To save your changes, do one of the following:

Condition Action

If you opened the PDF from a file system or DMS: Click File > Save in Acrobat.

If you invoked link editing for an in-process PDF
rendition from Calyx RIM:

See Save In-Process Rendition Changes
to ICalyx RIM.

Link Character Encoding

For external links in PDF renditions that were created with Acrobat prior to Acrobat version 8, non-Unicode
encoding of the links may not be correct after they are extracted to Calyx RIM. The Update link character
encoding option enables you to update external links for source PDF renditions that are assigned to Calyx RIM
assemblies.

Encoding updates must be performed on source PDFs. You cannot update link character encoding in-process.

To successfully update link character encoding in documents, the language support for the selected character
encoding must be installed on your computer.

Update Link Character Encoding

Use Update Link Character Encoding to modify the selected character set.

To update link character encoding:
1. Open the source PDF in Acrobat.
2. In the Linking plug-in (PDF) menu, select Update Link Character Encoding.
3. Select the original encoding language used in the document.
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Example

4. To set the selected character set for the encoding update, click OK.
5. To end the procedure without changing character encoding, click Cancel.
6. Click Yes to confirm the update for the document using the selected character set.,.

When the update is finished, Linking plug-in (PDF) displays this message: The links have been
correctly updated.

7. Click OK to close the message.
8. Save .

If the source PDF resides in a DMS, you must check-in the updated source PDF.

After Update of Link Character Encoding

Use Link Inspector for character encoding to ensure the links created in older Acrobat Adobe versions work correctly.
After updating link character encoding in your source PDF document, do the following in Calyx RIM:

1. In the assembly to which the source PDF is assigned, run DMS Synchronization on the PDF document.
This causes Calyx RIM to execute a link extraction on the updated PDF document.

2. Run a Prepare to Publish to refresh the Link Inspector data.
3. Run the Link Inspector query and the Character Encoding Status column shows that the links are updated.

Character Encoding Status

For external links in PDF renditions that were created with Acrobat prior to Acrobat version 8, non-Unicode
encoding of the links may not be correct in Calyx RIM.

When assigning a document to an Calyx RIM assembly, Calyx RIM extracts linking information from the
PDF. During the extraction, Calyx RIM applies the default character encoding of the Windows operating system that
is used on the Calyx RIM Rendering server that processes the job. As a result, the character encoding that was used
when creating the links in the existing PDF rendition of the document may be different than the character encoding
applied by Calyx RIM when performing extractions.
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The purpose of the Character Encoding Status column of the Link Inspector query is to identify external links
affected by this scenario. When the encoding of the external links is flagged by this column, the following actions can
be taken:

— You can re-render the source document.
— You can re-target the links using the re-targeting functionality built into the Link inspector query.
— For source PDF files, you can update the character encoding using Linking plug-in (PDF), and then perform a

DMS Synchronization to re-extract the links.
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Linking plug-in (PDF) Installation Guide

Uninstall Linking plug-in (PDF)

If you have a previous version of Linking plug-in (PDF) on your machine, it must be uninstalled prior to installing
the latest version.
Perform the steps below to uninstall Linking plug-in (PDF) from Adobe Acrobat.

1. Close Adobe Acrobat if it is open.
2. Choose Start > Settings > Control Panel .
3. Double-click Add/Remove Programs.
4. Click Linking plug-in (PDF) to select it and then click Remove.
5. Click Yes to confirm uninstallation.
6. Start Adobe Acrobat.

The Linking plug-in (PDF) plug-in is removed and no longer appears on the Acrobat menu bar or on the
Advanced Editing toolbar.

Linking plug-in (PDF) 1.9 IQ Scripts

PDF copy of the Installation Qualification (IQ) script is provided for guidance in performing your installation or
upgrade of Linking plug-in (PDF).
This PDF copy of the Installation Qualification script is intended for use in conjunction with the other reference
information provided in SSD topic.
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